summaryrefslogtreecommitdiffstats
path: root/meta-multimedia
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2023-01-25 22:13:57 -0800
committerKhem Raj <raj.khem@gmail.com>2023-01-26 10:24:25 -0800
commitd41cfd1d9a38fbabaa4b10801f8c17a2630acb55 (patch)
treef4544105ee7f3304910d50a7366c72d76f64caea /meta-multimedia
parent8284a018f3fb4274bb09308185da2a153be858a8 (diff)
downloadmeta-openembedded-d41cfd1d9a38fbabaa4b10801f8c17a2630acb55.tar.gz
crossguid: Fix build with gcc13
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-multimedia')
-rw-r--r--meta-multimedia/recipes-support/crossguid/crossguid/0001-include-missing-cstdint.patch31
-rw-r--r--meta-multimedia/recipes-support/crossguid/crossguid_0.2.2.bb3
2 files changed, 33 insertions, 1 deletions
diff --git a/meta-multimedia/recipes-support/crossguid/crossguid/0001-include-missing-cstdint.patch b/meta-multimedia/recipes-support/crossguid/crossguid/0001-include-missing-cstdint.patch
new file mode 100644
index 000000000..a12eba8eb
--- /dev/null
+++ b/meta-multimedia/recipes-support/crossguid/crossguid/0001-include-missing-cstdint.patch
@@ -0,0 +1,31 @@
1From 1eb9bea38c320b2b588635cffceaaa2a8d434780 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Wed, 25 Jan 2023 22:09:26 -0800
4Subject: [PATCH] include missing <cstdint>
5
6gcc 13 moved some includes around and as a result <cstdint> is no longer transitively
7included [1]. Explicitly include it for uint{32,64}_t.
8
9[1] https://gcc.gnu.org/gcc-13/porting_to.html#header-dep-changes
10
11Upstream-Status: Submitted [https://github.com/graeme-hill/crossguid/pull/67]
12Signed-off-by: Khem Raj <raj.khem@gmail.com>
13---
14 include/crossguid/guid.hpp | 1 +
15 1 file changed, 1 insertion(+)
16
17diff --git a/include/crossguid/guid.hpp b/include/crossguid/guid.hpp
18index 61e0f17..70966f2 100644
19--- a/include/crossguid/guid.hpp
20+++ b/include/crossguid/guid.hpp
21@@ -29,6 +29,7 @@ THE SOFTWARE.
22 #include <jni.h>
23 #endif
24
25+#include <cstdint>
26 #include <functional>
27 #include <iostream>
28 #include <array>
29--
302.39.1
31
diff --git a/meta-multimedia/recipes-support/crossguid/crossguid_0.2.2.bb b/meta-multimedia/recipes-support/crossguid/crossguid_0.2.2.bb
index b496531ab..58b049bb4 100644
--- a/meta-multimedia/recipes-support/crossguid/crossguid_0.2.2.bb
+++ b/meta-multimedia/recipes-support/crossguid/crossguid_0.2.2.bb
@@ -8,7 +8,8 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=1373274bc8d8001edc54933919f36f68"
8DEPENDS += "util-linux" 8DEPENDS += "util-linux"
9 9
10SRCREV = "ca1bf4b810e2d188d04cb6286f957008ee1b7681" 10SRCREV = "ca1bf4b810e2d188d04cb6286f957008ee1b7681"
11SRC_URI = "git://github.com/graeme-hill/crossguid;protocol=https;branch=master" 11SRC_URI = "git://github.com/graeme-hill/crossguid;protocol=https;branch=master \
12 file://0001-include-missing-cstdint.patch"
12 13
13S = "${WORKDIR}/git" 14S = "${WORKDIR}/git"
14 15