diff options
author | Khem Raj <raj.khem@gmail.com> | 2016-11-25 22:24:33 -0800 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2016-12-02 09:23:43 +0100 |
commit | a85e12928131fce057f777daa76a7f0c75cffa14 (patch) | |
tree | 8a9028197262ab00b26bae57e58c31d8399db440 /meta-multimedia | |
parent | 41d7bac5d50091cab835eac0a5eaa6c431fb2023 (diff) | |
download | meta-openembedded-a85e12928131fce057f777daa76a7f0c75cffa14.tar.gz |
tvheadend: Update to 4.0.9
* Add missing build and runtime deps
* add packageconfig for uriparser
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-multimedia')
8 files changed, 197 insertions, 146 deletions
diff --git a/meta-multimedia/recipes-dvb/tvheadend/tvheadend/0001-Fix-checks-for-sse2-mmx.patch b/meta-multimedia/recipes-dvb/tvheadend/tvheadend/0001-Fix-checks-for-sse2-mmx.patch new file mode 100644 index 000000000..3283a5b6a --- /dev/null +++ b/meta-multimedia/recipes-dvb/tvheadend/tvheadend/0001-Fix-checks-for-sse2-mmx.patch | |||
@@ -0,0 +1,40 @@ | |||
1 | From f0dab6d6fe4b0aae4394eee93be86e9747c6ed5c Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Tue, 22 Nov 2016 05:07:38 +0000 | ||
4 | Subject: [PATCH] Fix checks for sse2/mmx | ||
5 | |||
6 | Just checking for cmdline options is not enough | ||
7 | its better to check for builtin defines to be | ||
8 | sure, clang does not error out on sse2 options on | ||
9 | arm e.g. and it ends up doing SSE2 stuff for arm | ||
10 | which is not desired | ||
11 | |||
12 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
13 | --- | ||
14 | configure | 10 ++++++++-- | ||
15 | 1 file changed, 8 insertions(+), 2 deletions(-) | ||
16 | |||
17 | diff --git a/configure b/configure | ||
18 | index 47d2cf2..4be000c 100755 | ||
19 | --- a/configure | ||
20 | +++ b/configure | ||
21 | @@ -118,8 +118,14 @@ fi | ||
22 | # Valiate compiler | ||
23 | check_cc || die 'No C compiler found' | ||
24 | check_cc_header execinfo | ||
25 | -check_cc_option mmx | ||
26 | -check_cc_option sse2 | ||
27 | +check_cc_snippet mmx '#ifndef __MMX__ | ||
28 | +error "MMX not supported" | ||
29 | +#endif | ||
30 | +' | ||
31 | +check_cc_snippet sse2 '#ifndef __SSE2__ | ||
32 | +error "SSE2 not supported" | ||
33 | +#endif | ||
34 | +' | ||
35 | |||
36 | if check_cc ' | ||
37 | #if !defined(__clang__) | ||
38 | -- | ||
39 | 1.9.1 | ||
40 | |||
diff --git a/meta-multimedia/recipes-dvb/tvheadend/tvheadend/0001-Makefile-Ignore-warning-about-wrong-includes.patch b/meta-multimedia/recipes-dvb/tvheadend/tvheadend/0001-Makefile-Ignore-warning-about-wrong-includes.patch new file mode 100644 index 000000000..248a5e6a8 --- /dev/null +++ b/meta-multimedia/recipes-dvb/tvheadend/tvheadend/0001-Makefile-Ignore-warning-about-wrong-includes.patch | |||
@@ -0,0 +1,31 @@ | |||
1 | From 7d672305c7ad2f716dfe1c487b525a1a92954d4a Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Tue, 22 Nov 2016 06:22:36 +0000 | ||
4 | Subject: [PATCH] Makefile: Ignore warning about wrong includes | ||
5 | |||
6 | It happens on musl especially | ||
7 | usr/include/sys/poll.h:1:2: error: redirecting incorrect #include <sys/poll.h> to <poll.h> [-Werror,-W#warnings] | ||
8 | | #warning redirecting incorrect #include <sys/poll.h> to <poll.h> | ||
9 | | ^ | ||
10 | | In file included from src/avahi.c:48: | ||
11 | |||
12 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
13 | --- | ||
14 | Makefile | 1 + | ||
15 | 1 file changed, 1 insertion(+) | ||
16 | |||
17 | diff --git a/Makefile b/Makefile | ||
18 | index f41ef1a..cc7b249 100644 | ||
19 | --- a/Makefile | ||
20 | +++ b/Makefile | ||
21 | @@ -54,6 +54,7 @@ CFLAGS += -Wno-microsoft -Qunused-arguments -Wno-unused-function | ||
22 | CFLAGS += -Wno-unused-value -Wno-tautological-constant-out-of-range-compare | ||
23 | CFLAGS += -Wno-parentheses-equality -Wno-incompatible-pointer-types | ||
24 | CFLAGS += -Wno-error=varargs | ||
25 | +CFLAGS += -Wno-error=\#warnings | ||
26 | endif | ||
27 | |||
28 | ifeq ($(CONFIG_LIBFFMPEG_STATIC),yes) | ||
29 | -- | ||
30 | 1.8.3.1 | ||
31 | |||
diff --git a/meta-multimedia/recipes-dvb/tvheadend/tvheadend/0001-Move-tvheadend-specific-LD-CFLAGS-into-a-helper-vari.patch b/meta-multimedia/recipes-dvb/tvheadend/tvheadend/0001-Move-tvheadend-specific-LD-CFLAGS-into-a-helper-vari.patch deleted file mode 100644 index 9dfcce042..000000000 --- a/meta-multimedia/recipes-dvb/tvheadend/tvheadend/0001-Move-tvheadend-specific-LD-CFLAGS-into-a-helper-vari.patch +++ /dev/null | |||
@@ -1,92 +0,0 @@ | |||
1 | From 2ee64b359464b48f751683faa5ded3ee8200fe90 Mon Sep 17 00:00:00 2001 | ||
2 | From: Koen Kooi <koen@dominion.thruhere.net> | ||
3 | Date: Fri, 21 Dec 2012 10:15:42 +0100 | ||
4 | Subject: [PATCH] Move tvheadend specific LD/CFLAGS into a helper variable to | ||
5 | avoid being overwritten | ||
6 | |||
7 | Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> | ||
8 | |||
9 | Upstream-Status: Inappropriate [OE specific] | ||
10 | --- | ||
11 | Makefile | 20 ++++++++++---------- | ||
12 | support/configure.inc | 8 ++++---- | ||
13 | 2 files changed, 14 insertions(+), 14 deletions(-) | ||
14 | |||
15 | diff --git a/Makefile b/Makefile | ||
16 | index 8c6b293..daf5f14 100644 | ||
17 | --- a/Makefile | ||
18 | +++ b/Makefile | ||
19 | @@ -27,12 +27,12 @@ PROG = ${BUILDDIR}/tvheadend | ||
20 | # Common compiler flags | ||
21 | # | ||
22 | |||
23 | -CFLAGS += -Wall -Werror -Wwrite-strings -Wno-deprecated-declarations | ||
24 | -CFLAGS += -Wmissing-prototypes -fms-extensions | ||
25 | -CFLAGS += -g -funsigned-char -O2 | ||
26 | -CFLAGS += -D_FILE_OFFSET_BITS=64 | ||
27 | -CFLAGS += -I${BUILDDIR} -I${CURDIR}/src -I${CURDIR} | ||
28 | -LDFLAGS += -lrt -ldl -lpthread -lm | ||
29 | +TVH_CFLAGS += -Wall -Werror -Wwrite-strings -Wno-deprecated-declarations | ||
30 | +TVH_CFLAGS += -Wmissing-prototypes -fms-extensions | ||
31 | +TVH_CFLAGS += -g -funsigned-char -O2 | ||
32 | +TVH_CFLAGS += -D_FILE_OFFSET_BITS=64 | ||
33 | +TVH_CFLAGS += -I${BUILDDIR} -I${CURDIR}/src -I${CURDIR} | ||
34 | +TVH_LDFLAGS += -lrt -ldl -lpthread -lm | ||
35 | |||
36 | # | ||
37 | # Other config | ||
38 | @@ -179,8 +179,8 @@ SRCS-${CONFIG_CWC} += src/ffdecsa/ffdecsa_interface.c \ | ||
39 | src/ffdecsa/ffdecsa_int.c | ||
40 | SRCS-${CONFIG_MMX} += src/ffdecsa/ffdecsa_mmx.c | ||
41 | SRCS-${CONFIG_SSE2} += src/ffdecsa/ffdecsa_sse2.c | ||
42 | -${BUILDDIR}/src/ffdecsa/ffdecsa_mmx.o : CFLAGS += -mmmx | ||
43 | -${BUILDDIR}/src/ffdecsa/ffdecsa_sse2.o : CFLAGS += -msse2 | ||
44 | +${BUILDDIR}/src/ffdecsa/ffdecsa_mmx.o : TVH_CFLAGS += -mmmx | ||
45 | +${BUILDDIR}/src/ffdecsa/ffdecsa_sse2.o : TVH_CFLAGS += -msse2 | ||
46 | endif | ||
47 | |||
48 | # File bundles | ||
49 | @@ -217,12 +217,12 @@ all: ${PROG} | ||
50 | |||
51 | # Binary | ||
52 | ${PROG}: $(OBJS) $(ALLDEPS) | ||
53 | - $(CC) -o $@ $(OBJS) $(CFLAGS) $(LDFLAGS) | ||
54 | + $(CC) -o $@ $(OBJS) $(TVH_CFLAGS) $(TVH_LDFLAGS) $(CFLAGS) $(LDFLAGS) | ||
55 | |||
56 | # Object | ||
57 | ${BUILDDIR}/%.o: %.c | ||
58 | @mkdir -p $(dir $@) | ||
59 | - $(CC) -MD -MP $(CFLAGS) -c -o $@ $(CURDIR)/$< | ||
60 | + $(CC) -MD -MP $(TVH_CFLAGS) $(CFLAGS) -c -o $@ $(CURDIR)/$< | ||
61 | |||
62 | # Add-on | ||
63 | ${BUILDDIR}/%.so: ${SRCS_EXTRA} | ||
64 | diff --git a/support/configure.inc b/support/configure.inc | ||
65 | index 0130880..332511e 100644 | ||
66 | --- a/support/configure.inc | ||
67 | +++ b/support/configure.inc | ||
68 | @@ -464,8 +464,8 @@ ifeq (\$(origin CC),default) | ||
69 | CC = ${CC} | ||
70 | endif | ||
71 | PYTHON ?= ${PYTHON} | ||
72 | -CFLAGS += ${CFLAGS} | ||
73 | -LDFLAGS += ${LDFLAGS} | ||
74 | +TVH_CFLAGS += ${CFLAGS} | ||
75 | +TVH_LDFLAGS += ${LDFLAGS} | ||
76 | prefix = ${prefix} | ||
77 | bindir = ${bindir} | ||
78 | mandir = ${mandir} | ||
79 | @@ -482,8 +482,8 @@ EOF | ||
80 | # Add package config | ||
81 | for pkg in ${PACKAGES[*]}; do | ||
82 | cat >>${CONFIG_MK} <<EOF | ||
83 | -LDFLAGS += $(pkg-config --libs $pkg) | ||
84 | -CFLAGS += $(pkg-config --cflags $pkg) | ||
85 | +TVH_LDFLAGS += $(pkg-config --libs $pkg) | ||
86 | +TVH_CFLAGS += $(pkg-config --cflags $pkg) | ||
87 | EOF | ||
88 | done | ||
89 | |||
90 | -- | ||
91 | 1.7.7.6 | ||
92 | |||
diff --git a/meta-multimedia/recipes-dvb/tvheadend/tvheadend/0001-disable-varargs-warning-on-clang.patch b/meta-multimedia/recipes-dvb/tvheadend/tvheadend/0001-disable-varargs-warning-on-clang.patch new file mode 100644 index 000000000..a4c4c4d0f --- /dev/null +++ b/meta-multimedia/recipes-dvb/tvheadend/tvheadend/0001-disable-varargs-warning-on-clang.patch | |||
@@ -0,0 +1,32 @@ | |||
1 | From 906d95695af95970bf551ea55b6c3e70332c6b97 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Tue, 22 Nov 2016 05:22:32 +0000 | ||
4 | Subject: [PATCH] disable varargs warning on clang | ||
5 | |||
6 | The issue is that 'len' is an unsigned char and we violate the promotion rules | ||
7 | for passing the value to va_start. | ||
8 | |||
9 | passing an object that undergoes defau | ||
10 | lt argument promotion to 'va_start' has undefined behavior [-Wvarargs] | ||
11 | | va_start(ap, len); | ||
12 | |||
13 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
14 | --- | ||
15 | Makefile | 1 + | ||
16 | 1 file changed, 1 insertion(+) | ||
17 | |||
18 | diff --git a/Makefile b/Makefile | ||
19 | index 8c5e380..f41ef1a 100644 | ||
20 | --- a/Makefile | ||
21 | +++ b/Makefile | ||
22 | @@ -53,6 +53,7 @@ ifeq ($(COMPILER), clang) | ||
23 | CFLAGS += -Wno-microsoft -Qunused-arguments -Wno-unused-function | ||
24 | CFLAGS += -Wno-unused-value -Wno-tautological-constant-out-of-range-compare | ||
25 | CFLAGS += -Wno-parentheses-equality -Wno-incompatible-pointer-types | ||
26 | +CFLAGS += -Wno-error=varargs | ||
27 | endif | ||
28 | |||
29 | ifeq ($(CONFIG_LIBFFMPEG_STATIC),yes) | ||
30 | -- | ||
31 | 1.9.1 | ||
32 | |||
diff --git a/meta-multimedia/recipes-dvb/tvheadend/tvheadend/0001-dvr-Use-labs-instead-of-abs.patch b/meta-multimedia/recipes-dvb/tvheadend/tvheadend/0001-dvr-Use-labs-instead-of-abs.patch new file mode 100644 index 000000000..ea34cdb62 --- /dev/null +++ b/meta-multimedia/recipes-dvb/tvheadend/tvheadend/0001-dvr-Use-labs-instead-of-abs.patch | |||
@@ -0,0 +1,37 @@ | |||
1 | From a715671eadcbf989fdaf05f62e71b93ac1749615 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Tue, 22 Nov 2016 06:08:31 +0000 | ||
4 | Subject: [PATCH] dvr: Use labs() instead of abs() | ||
5 | |||
6 | Makes clang happy | ||
7 | |||
8 | dvr/dvr_db.c:853:10: error: absolute value function | ||
9 | 'abs' given an argument of type 'long' but has parameter of type 'int' which may cause truncation of value [-Werror,-Wabsolute-value] | ||
10 | if ((abs(de->de_start - e->start) < 600) && (abs(de->de_stop - e->stop) < 600)) { | ||
11 | |||
12 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
13 | --- | ||
14 | src/dvr/dvr_db.c | 4 ++-- | ||
15 | 1 file changed, 2 insertions(+), 2 deletions(-) | ||
16 | |||
17 | diff --git a/src/dvr/dvr_db.c b/src/dvr/dvr_db.c | ||
18 | index 165caa6..5656569 100644 | ||
19 | --- a/src/dvr/dvr_db.c | ||
20 | +++ b/src/dvr/dvr_db.c | ||
21 | @@ -414,11 +414,11 @@ dvr_entry_fuzzy_match(dvr_entry_t *de, epg_broadcast_t *e) | ||
22 | /* Wrong length (+/-20%) */ | ||
23 | t1 = de->de_stop - de->de_start; | ||
24 | t2 = e->stop - e->start; | ||
25 | - if ( abs(t2 - t1) > (t1 / 5) ) | ||
26 | + if ( labs(t2 - t1) > (t1 / 5) ) | ||
27 | return 0; | ||
28 | |||
29 | /* Outside of window */ | ||
30 | - if (abs(e->start - de->de_start) > de->de_config->dvr_update_window) | ||
31 | + if (labs(e->start - de->de_start) > de->de_config->dvr_update_window) | ||
32 | return 0; | ||
33 | |||
34 | /* Title match (or contains?) */ | ||
35 | -- | ||
36 | 1.9.1 | ||
37 | |||
diff --git a/meta-multimedia/recipes-dvb/tvheadend/tvheadend/0001-hdhomerun-Override-forced-overrdiing-og-CC-STRIP-and.patch b/meta-multimedia/recipes-dvb/tvheadend/tvheadend/0001-hdhomerun-Override-forced-overrdiing-og-CC-STRIP-and.patch new file mode 100644 index 000000000..484e723d9 --- /dev/null +++ b/meta-multimedia/recipes-dvb/tvheadend/tvheadend/0001-hdhomerun-Override-forced-overrdiing-og-CC-STRIP-and.patch | |||
@@ -0,0 +1,40 @@ | |||
1 | From c3767e189e90965407937b6178adbbd8cdafe31d Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Tue, 22 Nov 2016 05:59:10 +0000 | ||
4 | Subject: [PATCH] hdhomerun: Override forced overrdiing og CC/STRIP and CFLAGS | ||
5 | |||
6 | This is required for cross compiling otherwise it ends up | ||
7 | using build host gcc | ||
8 | |||
9 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
10 | --- | ||
11 | Makefile.hdhomerun | 6 ++++-- | ||
12 | 1 file changed, 4 insertions(+), 2 deletions(-) | ||
13 | |||
14 | diff --git a/Makefile.hdhomerun b/Makefile.hdhomerun | ||
15 | index 943ffec..8bd14ff 100644 | ||
16 | --- a/Makefile.hdhomerun | ||
17 | +++ b/Makefile.hdhomerun | ||
18 | @@ -18,8 +18,8 @@ | ||
19 | |||
20 | include $(dir $(lastword $(MAKEFILE_LIST))).config.mk | ||
21 | |||
22 | -unexport CFLAGS | ||
23 | -unexport LDFLAGS | ||
24 | +#unexport CFLAGS | ||
25 | +#unexport LDFLAGS | ||
26 | |||
27 | define DOWNLOAD | ||
28 | @mkdir -p $(LIBHDHRDIR)/build | ||
29 | @@ -75,6 +75,8 @@ $(LIBHDHRDIR)/$(LIBHDHR)/.tvh_download: | ||
30 | $(call DOWNLOAD,$(LIBHDHR_URL),$(LIBHDHRDIR)/$(LIBHDHR_TB),$(LIBHDHR_SHA1)) | ||
31 | $(call UNTAR,$(LIBHDHR_TB),z) | ||
32 | ln -sf libhdhomerun $(LIBHDHRDIR)/$(LIBHDHR) | ||
33 | + @sed -i -e "s/CC.*:=/CC ?=/" $(LIBHDHRDIR)/$(LIBHDHR)/Makefile | ||
34 | + @sed -i -e "s/STRIP.*:=/STRIP ?=/" $(LIBHDHRDIR)/$(LIBHDHR)/Makefile | ||
35 | @touch $@ | ||
36 | |||
37 | $(LIBHDHRDIR)/$(LIBHDHR)/.tvh_build: \ | ||
38 | -- | ||
39 | 1.9.1 | ||
40 | |||
diff --git a/meta-multimedia/recipes-dvb/tvheadend/tvheadend/0002-fix-issues-with-gcc6.patch b/meta-multimedia/recipes-dvb/tvheadend/tvheadend/0002-fix-issues-with-gcc6.patch deleted file mode 100644 index 55b92499b..000000000 --- a/meta-multimedia/recipes-dvb/tvheadend/tvheadend/0002-fix-issues-with-gcc6.patch +++ /dev/null | |||
@@ -1,46 +0,0 @@ | |||
1 | --- git/src/htsmsg.c.orig 2016-06-17 11:47:53.026921237 -0400 | ||
2 | +++ git/src/htsmsg.c 2016-06-17 11:49:03.086922457 -0400 | ||
3 | @@ -574,13 +574,13 @@ | ||
4 | case HMF_MAP: | ||
5 | printf("MAP) = {\n"); | ||
6 | htsmsg_print0(&f->hmf_msg, indent + 1); | ||
7 | - for(i = 0; i < indent; i++) printf("\t"); printf("}\n"); | ||
8 | + for(i = 0; i < indent; i++) {printf("\t");} printf("}\n"); | ||
9 | break; | ||
10 | |||
11 | case HMF_LIST: | ||
12 | printf("LIST) = {\n"); | ||
13 | htsmsg_print0(&f->hmf_msg, indent + 1); | ||
14 | - for(i = 0; i < indent; i++) printf("\t"); printf("}\n"); | ||
15 | + for(i = 0; i < indent; i++) {printf("\t");} printf("}\n"); | ||
16 | break; | ||
17 | |||
18 | case HMF_STR: | ||
19 | --- git/src/dvb/dvb_tables.c.orig 2016-06-17 11:51:09.142924652 -0400 | ||
20 | +++ git/src/dvb/dvb_tables.c 2016-06-17 11:54:33.962928219 -0400 | ||
21 | @@ -935,10 +935,10 @@ | ||
22 | onid = (ptr[24] << 8) | ptr[25]; | ||
23 | |||
24 | /* Search all muxes on adapter */ | ||
25 | - LIST_FOREACH(tdmi, &tda->tda_muxes, tdmi_adapter_link) | ||
26 | - if(tdmi->tdmi_transport_stream_id == tsid && tdmi->tdmi_network_id == onid); | ||
27 | - break; | ||
28 | - | ||
29 | + LIST_FOREACH(tdmi, &tda->tda_muxes, tdmi_adapter_link) { | ||
30 | + if(tdmi->tdmi_transport_stream_id == tsid && tdmi->tdmi_network_id == onid) | ||
31 | + break; | ||
32 | + } | ||
33 | if(tdmi == NULL) | ||
34 | continue; | ||
35 | |||
36 | --- git/src/epggrab/module/eit.c.orig 2016-06-17 11:49:57.726923409 -0400 | ||
37 | +++ git/src/epggrab/module/eit.c 2016-06-17 11:50:14.526923701 -0400 | ||
38 | @@ -214,7 +214,7 @@ | ||
39 | if (m && m->enabled) cptr = _eit_freesat_conv; | ||
40 | else | ||
41 | m = epggrab_module_find_by_id("uk_freeview"); | ||
42 | - if (m && m->enabled) cptr = _eit_freesat_conv; | ||
43 | + if (m && m->enabled) cptr = _eit_freesat_conv; | ||
44 | |||
45 | /* Convert */ | ||
46 | return dvb_get_string_with_len(dst, dstlen, src, srclen, charset, cptr); | ||
diff --git a/meta-multimedia/recipes-dvb/tvheadend/tvheadend_git.bb b/meta-multimedia/recipes-dvb/tvheadend/tvheadend_git.bb index bd5062c94..300daa536 100644 --- a/meta-multimedia/recipes-dvb/tvheadend/tvheadend_git.bb +++ b/meta-multimedia/recipes-dvb/tvheadend/tvheadend_git.bb | |||
@@ -1,22 +1,29 @@ | |||
1 | SUMMARY = "Tvheadend TV streaming server" | 1 | SUMMARY = "Tvheadend TV streaming server" |
2 | HOMEPAGE = "https://www.lonelycoder.com/redmine/projects/tvheadend" | 2 | HOMEPAGE = "https://www.lonelycoder.com/redmine/projects/tvheadend" |
3 | 3 | ||
4 | DEPENDS = "avahi zlib openssl python-native" | 4 | DEPENDS = "avahi zlib openssl python-native dvb-apps" |
5 | 5 | ||
6 | LICENSE = "GPLv3+" | 6 | LICENSE = "GPLv3+" |
7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=9eef91148a9b14ec7f9df333daebc746" | 7 | LIC_FILES_CHKSUM = "file://LICENSE.md;md5=9cae5acac2e9ee2fc3aec01ac88ce5db" |
8 | 8 | ||
9 | SRC_URI = "git://github.com/tvheadend/tvheadend.git \ | 9 | SRC_URI = "git://github.com/tvheadend/tvheadend.git;branch=release/4.0 \ |
10 | file://0001-Move-tvheadend-specific-LD-CFLAGS-into-a-helper-vari.patch \ | 10 | file://0001-Fix-checks-for-sse2-mmx.patch \ |
11 | file://0002-fix-issues-with-gcc6.patch \ | 11 | file://0001-disable-varargs-warning-on-clang.patch \ |
12 | file://0001-hdhomerun-Override-forced-overrdiing-og-CC-STRIP-and.patch \ | ||
13 | file://0001-dvr-Use-labs-instead-of-abs.patch \ | ||
14 | file://0001-Makefile-Ignore-warning-about-wrong-includes.patch \ | ||
12 | " | 15 | " |
13 | SRCREV = "a420c83a0e0d2c31c2c15d0fec6fedc3f5a36dfe" | 16 | SRCREV = "64fec8120158de585e18be705055259484518d94" |
14 | PV = "3.3" | 17 | PV = "4.0.9+git${SRCREV}" |
15 | 18 | ||
16 | S = "${WORKDIR}/git" | 19 | S = "${WORKDIR}/git" |
17 | 20 | ||
21 | PACKAGECONFIG ?= "" | ||
22 | PACKAGECONFIG[uriparser] = "--enable-uriparser,--disable-uriparser,uriparser" | ||
23 | |||
18 | do_configure() { | 24 | do_configure() { |
19 | ./configure --prefix=${prefix} \ | 25 | ./configure ${PACKAGECONFIG_CONFARGS} \ |
26 | --prefix=${prefix} \ | ||
20 | --libdir=${libdir} \ | 27 | --libdir=${libdir} \ |
21 | --bindir=${bindir} \ | 28 | --bindir=${bindir} \ |
22 | --datadir=${datadir} \ | 29 | --datadir=${datadir} \ |
@@ -30,3 +37,5 @@ do_install() { | |||
30 | } | 37 | } |
31 | 38 | ||
32 | FILES_${PN} += "${datadir}/${BPN}" | 39 | FILES_${PN} += "${datadir}/${BPN}" |
40 | |||
41 | RDEPENDS_${PN} += "libdvben50221 libucsi libdvbapi" | ||