diff options
author | Baptiste DURAND <baptiste.durand@gmail.com> | 2018-09-11 20:17:04 +0200 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2018-09-11 22:48:21 -0700 |
commit | 9e050f01a9edd43a3dc55c7cf63c4aa08767246d (patch) | |
tree | 346356e956ca7053e2870765a942373bb6e7f1e5 /meta-multimedia | |
parent | f0b1f3d30bff1418b655bbde7f4c2e84c2afcc4d (diff) | |
download | meta-openembedded-9e050f01a9edd43a3dc55c7cf63c4aa08767246d.tar.gz |
minidlna: restore & fix recipe
Restore minidlna recipe and bump it to v1.2.1
Move it to meta-multimedia
Signed-off-by: Baptiste Durand <baptiste.durand@gmail.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-multimedia')
5 files changed, 143 insertions, 0 deletions
diff --git a/meta-multimedia/recipes-multimedia/minidlna/minidlna.inc b/meta-multimedia/recipes-multimedia/minidlna/minidlna.inc new file mode 100644 index 000000000..187ff536a --- /dev/null +++ b/meta-multimedia/recipes-multimedia/minidlna/minidlna.inc | |||
@@ -0,0 +1,41 @@ | |||
1 | DESCRIPTION = "MiniDLNA (aka ReadyDLNA) is server software with the aim of \ | ||
2 | being fully compliant with DLNA/UPnP-AV clients." | ||
3 | LICENSE = "GPL-2.0|BSD" | ||
4 | DEPENDS = "ffmpeg flac libav jpeg sqlite3 libexif libogg libid3tag libvorbis" | ||
5 | |||
6 | # because it depends on libav which has commercial flag | ||
7 | LICENSE_FLAGS = "commercial" | ||
8 | |||
9 | inherit gettext autotools-brokensep update-rc.d systemd | ||
10 | |||
11 | SRC_URI = "git://git.code.sf.net/p/minidlna/git;branch=master;module=git \ | ||
12 | file://minidlna-daemon.init.d \ | ||
13 | file://minidlna.service \ | ||
14 | file://0001-Update-Gettext-version.patch \ | ||
15 | " | ||
16 | |||
17 | S = "${WORKDIR}/git" | ||
18 | |||
19 | # This remove "--exclude=autopoint" option from autoreconf argument to avoid | ||
20 | # configure.ac:30: error: required file './ABOUT-NLS' not found | ||
21 | EXTRA_AUTORECONF = "" | ||
22 | |||
23 | do_install_append(){ | ||
24 | install -d ${D}${sysconfdir} | ||
25 | install -m 0755 minidlna.conf ${D}${sysconfdir} | ||
26 | |||
27 | # Systemd script | ||
28 | install -d ${D}${nonarch_base_libdir}/systemd/system | ||
29 | install -m 0755 ${WORKDIR}/minidlna.service ${D}${nonarch_base_libdir}/systemd/system | ||
30 | |||
31 | # Sysvinit script | ||
32 | install -d ${D}${sysconfdir}/init.d | ||
33 | install -m 0755 ${WORKDIR}/minidlna-daemon.init.d ${D}${sysconfdir}/init.d/minidlna | ||
34 | |||
35 | } | ||
36 | |||
37 | SYSTEMD_SERVICE_${PN} = "minidlna.service" | ||
38 | |||
39 | INITSCRIPT_NAME = "minidlna" | ||
40 | INITSCRIPT_PARAMS = "defaults 90" | ||
41 | |||
diff --git a/meta-multimedia/recipes-multimedia/minidlna/minidlna/0001-Update-Gettext-version.patch b/meta-multimedia/recipes-multimedia/minidlna/minidlna/0001-Update-Gettext-version.patch new file mode 100644 index 000000000..c18095d42 --- /dev/null +++ b/meta-multimedia/recipes-multimedia/minidlna/minidlna/0001-Update-Gettext-version.patch | |||
@@ -0,0 +1,34 @@ | |||
1 | From a4290bf1887f9203288858ca76bdd20b2edf337a Mon Sep 17 00:00:00 2001 | ||
2 | From: Baptiste Durand <baptiste.durand@gmail.com> | ||
3 | Date: Sun, 9 Sep 2018 20:50:41 +0200 | ||
4 | Subject: [PATCH] Update Gettext version | ||
5 | |||
6 | Upstream-Status: Inappropriate [oe-core specific] | ||
7 | |||
8 | Signed-off-by: Baptiste Durand <baptiste.durand@gmail.com> | ||
9 | --- | ||
10 | configure.ac | 4 ++-- | ||
11 | 1 file changed, 2 insertions(+), 2 deletions(-) | ||
12 | |||
13 | diff --git a/configure.ac b/configure.ac | ||
14 | index f343d21..a556b33 100644 | ||
15 | --- a/configure.ac | ||
16 | +++ b/configure.ac | ||
17 | @@ -14,7 +14,7 @@ | ||
18 | # License along with MiniDLNA; if not, write to the Free Software | ||
19 | # Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 | ||
20 | # USA. | ||
21 | -AC_INIT(MiniDLNA,1.1.3,,minidlna) | ||
22 | +AC_INIT(MiniDLNA,1.2.1,,minidlna) | ||
23 | #LT_INIT | ||
24 | |||
25 | AC_CANONICAL_TARGET | ||
26 | @@ -28,7 +28,7 @@ m4_ifdef([AC_USE_SYSTEM_EXTENSIONS], [AC_USE_SYSTEM_EXTENSIONS]) | ||
27 | |||
28 | AM_ICONV | ||
29 | AM_GNU_GETTEXT([external]) | ||
30 | -AM_GNU_GETTEXT_VERSION(0.18) | ||
31 | +AM_GNU_GETTEXT_VERSION(0.19) | ||
32 | |||
33 | # Checks for programs. | ||
34 | AC_PROG_AWK | ||
diff --git a/meta-multimedia/recipes-multimedia/minidlna/minidlna/minidlna-daemon.init.d b/meta-multimedia/recipes-multimedia/minidlna/minidlna/minidlna-daemon.init.d new file mode 100644 index 000000000..9e64a20fd --- /dev/null +++ b/meta-multimedia/recipes-multimedia/minidlna/minidlna/minidlna-daemon.init.d | |||
@@ -0,0 +1,54 @@ | |||
1 | #!/bin/sh | ||
2 | |||
3 | NAME="minidlna" | ||
4 | DAEMON=/usr/sbin/minidlnad | ||
5 | SCRIPTNAME=/etc/init.d/$NAME | ||
6 | PIDFILE=/var/run/$NAME.pid | ||
7 | CONF=/etc/$NAME.conf | ||
8 | ARGS="-f $CONF" | ||
9 | |||
10 | # Exit if the package is not installed | ||
11 | [ -x "$DAEMON" ] || exit 0 | ||
12 | |||
13 | start_function() { | ||
14 | |||
15 | export PATH=$PWD:$PATH | ||
16 | |||
17 | if [ -f ${PIDFILE} ]; then | ||
18 | echo "$SCRIPTNAME already running with PID #`cat $PIDFILE` ( according to ${PIDFILE} )"; | ||
19 | exit 0 | ||
20 | fi | ||
21 | |||
22 | $DAEMON $ARGS | ||
23 | |||
24 | pid=$! | ||
25 | |||
26 | if [ "$pid" != "" ]; then | ||
27 | echo -n "$pid" > ${PIDFILE} | ||
28 | fi | ||
29 | } | ||
30 | |||
31 | stop_function() { | ||
32 | |||
33 | export PATH=$PWD:$PATH | ||
34 | |||
35 | if [ ! -e "${PIDFILE}" ]; then | ||
36 | echo "${SCRIPTNAME} not running ( according to ${PIDFILE} )"; | ||
37 | exit 1; | ||
38 | fi | ||
39 | PID=`cat ${PIDFILE}` | ||
40 | kill -INT ${PID} | ||
41 | rm -f ${PIDFILE} | ||
42 | } | ||
43 | |||
44 | case $1 in | ||
45 | "start") | ||
46 | start_function | ||
47 | ;; | ||
48 | "stop") | ||
49 | stop_function | ||
50 | ;; | ||
51 | *) | ||
52 | echo "Usage: $0 {start | stop}" | ||
53 | |||
54 | esac | ||
diff --git a/meta-multimedia/recipes-multimedia/minidlna/minidlna/minidlna.service b/meta-multimedia/recipes-multimedia/minidlna/minidlna/minidlna.service new file mode 100644 index 000000000..656100bb6 --- /dev/null +++ b/meta-multimedia/recipes-multimedia/minidlna/minidlna/minidlna.service | |||
@@ -0,0 +1,10 @@ | |||
1 | [Unit] | ||
2 | Description=Minidlna Daemon | ||
3 | After=network.target | ||
4 | |||
5 | [Service] | ||
6 | Type=notify | ||
7 | ExecStart=/usr/sbin/minidlnad -f /etc/minidlna.conf | ||
8 | |||
9 | [Install] | ||
10 | WantedBy=multi-user.target | ||
diff --git a/meta-multimedia/recipes-multimedia/minidlna/minidlna_1.2.1.bb b/meta-multimedia/recipes-multimedia/minidlna/minidlna_1.2.1.bb new file mode 100644 index 000000000..999d85ce7 --- /dev/null +++ b/meta-multimedia/recipes-multimedia/minidlna/minidlna_1.2.1.bb | |||
@@ -0,0 +1,4 @@ | |||
1 | require ${BPN}.inc | ||
2 | |||
3 | SRCREV = "c760a338e07ebd11d62fef701e3de824a91f8625" | ||
4 | LIC_FILES_CHKSUM = "file://LICENCE.miniupnpd;md5=b0dabf9d8e0f871554e309d62ead8d2b" | ||