diff options
author | Derek Straka <derek@asterius.io> | 2016-06-17 12:00:27 -0400 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2016-06-23 15:20:04 +0200 |
commit | 90488aa54d1abad7776f189940e38498778961cb (patch) | |
tree | 973e6f912f42dd64118d436e0bdc012421e6575a /meta-multimedia | |
parent | d24e984e286402087107e6e58796ed6f5bceb08c (diff) | |
download | meta-openembedded-90488aa54d1abad7776f189940e38498778961cb.tar.gz |
tvheadend: add a patch to fix issues with gcc 6 and drop the -Wno-error=misleading-indentation
Signed-off-by: Derek Straka <derek@asterius.io>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-multimedia')
-rw-r--r-- | meta-multimedia/recipes-dvb/tvheadend/tvheadend/0002-fix-issues-with-gcc6.patch | 46 | ||||
-rw-r--r-- | meta-multimedia/recipes-dvb/tvheadend/tvheadend_git.bb | 3 |
2 files changed, 47 insertions, 2 deletions
diff --git a/meta-multimedia/recipes-dvb/tvheadend/tvheadend/0002-fix-issues-with-gcc6.patch b/meta-multimedia/recipes-dvb/tvheadend/tvheadend/0002-fix-issues-with-gcc6.patch new file mode 100644 index 000000000..55b92499b --- /dev/null +++ b/meta-multimedia/recipes-dvb/tvheadend/tvheadend/0002-fix-issues-with-gcc6.patch | |||
@@ -0,0 +1,46 @@ | |||
1 | --- git/src/htsmsg.c.orig 2016-06-17 11:47:53.026921237 -0400 | ||
2 | +++ git/src/htsmsg.c 2016-06-17 11:49:03.086922457 -0400 | ||
3 | @@ -574,13 +574,13 @@ | ||
4 | case HMF_MAP: | ||
5 | printf("MAP) = {\n"); | ||
6 | htsmsg_print0(&f->hmf_msg, indent + 1); | ||
7 | - for(i = 0; i < indent; i++) printf("\t"); printf("}\n"); | ||
8 | + for(i = 0; i < indent; i++) {printf("\t");} printf("}\n"); | ||
9 | break; | ||
10 | |||
11 | case HMF_LIST: | ||
12 | printf("LIST) = {\n"); | ||
13 | htsmsg_print0(&f->hmf_msg, indent + 1); | ||
14 | - for(i = 0; i < indent; i++) printf("\t"); printf("}\n"); | ||
15 | + for(i = 0; i < indent; i++) {printf("\t");} printf("}\n"); | ||
16 | break; | ||
17 | |||
18 | case HMF_STR: | ||
19 | --- git/src/dvb/dvb_tables.c.orig 2016-06-17 11:51:09.142924652 -0400 | ||
20 | +++ git/src/dvb/dvb_tables.c 2016-06-17 11:54:33.962928219 -0400 | ||
21 | @@ -935,10 +935,10 @@ | ||
22 | onid = (ptr[24] << 8) | ptr[25]; | ||
23 | |||
24 | /* Search all muxes on adapter */ | ||
25 | - LIST_FOREACH(tdmi, &tda->tda_muxes, tdmi_adapter_link) | ||
26 | - if(tdmi->tdmi_transport_stream_id == tsid && tdmi->tdmi_network_id == onid); | ||
27 | - break; | ||
28 | - | ||
29 | + LIST_FOREACH(tdmi, &tda->tda_muxes, tdmi_adapter_link) { | ||
30 | + if(tdmi->tdmi_transport_stream_id == tsid && tdmi->tdmi_network_id == onid) | ||
31 | + break; | ||
32 | + } | ||
33 | if(tdmi == NULL) | ||
34 | continue; | ||
35 | |||
36 | --- git/src/epggrab/module/eit.c.orig 2016-06-17 11:49:57.726923409 -0400 | ||
37 | +++ git/src/epggrab/module/eit.c 2016-06-17 11:50:14.526923701 -0400 | ||
38 | @@ -214,7 +214,7 @@ | ||
39 | if (m && m->enabled) cptr = _eit_freesat_conv; | ||
40 | else | ||
41 | m = epggrab_module_find_by_id("uk_freeview"); | ||
42 | - if (m && m->enabled) cptr = _eit_freesat_conv; | ||
43 | + if (m && m->enabled) cptr = _eit_freesat_conv; | ||
44 | |||
45 | /* Convert */ | ||
46 | return dvb_get_string_with_len(dst, dstlen, src, srclen, charset, cptr); | ||
diff --git a/meta-multimedia/recipes-dvb/tvheadend/tvheadend_git.bb b/meta-multimedia/recipes-dvb/tvheadend/tvheadend_git.bb index 9fed0425e..bd5062c94 100644 --- a/meta-multimedia/recipes-dvb/tvheadend/tvheadend_git.bb +++ b/meta-multimedia/recipes-dvb/tvheadend/tvheadend_git.bb | |||
@@ -8,14 +8,13 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=9eef91148a9b14ec7f9df333daebc746" | |||
8 | 8 | ||
9 | SRC_URI = "git://github.com/tvheadend/tvheadend.git \ | 9 | SRC_URI = "git://github.com/tvheadend/tvheadend.git \ |
10 | file://0001-Move-tvheadend-specific-LD-CFLAGS-into-a-helper-vari.patch \ | 10 | file://0001-Move-tvheadend-specific-LD-CFLAGS-into-a-helper-vari.patch \ |
11 | file://0002-fix-issues-with-gcc6.patch \ | ||
11 | " | 12 | " |
12 | SRCREV = "a420c83a0e0d2c31c2c15d0fec6fedc3f5a36dfe" | 13 | SRCREV = "a420c83a0e0d2c31c2c15d0fec6fedc3f5a36dfe" |
13 | PV = "3.3" | 14 | PV = "3.3" |
14 | 15 | ||
15 | S = "${WORKDIR}/git" | 16 | S = "${WORKDIR}/git" |
16 | 17 | ||
17 | TARGET_CFLAGS += "-Wno-error=misleading-indentation" | ||
18 | |||
19 | do_configure() { | 18 | do_configure() { |
20 | ./configure --prefix=${prefix} \ | 19 | ./configure --prefix=${prefix} \ |
21 | --libdir=${libdir} \ | 20 | --libdir=${libdir} \ |