diff options
author | Adrian Bunk <bunk@stusta.de> | 2019-05-08 22:58:46 +0300 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2019-05-09 20:34:33 -0700 |
commit | 89158b7eadf311cc5202a06128e7d5db5a7147b4 (patch) | |
tree | 4171d06d570ad0a1cbf13402a975473fe123320f /meta-multimedia | |
parent | b5fce8b53f0e951ee562e49ee6d4e86c54d4cece (diff) | |
download | meta-openembedded-89158b7eadf311cc5202a06128e7d5db5a7147b4.tar.gz |
caps: Upgrade 0.9.24 -> 0.9.26
Remove patches applied upstream.
Signed-off-by: Adrian Bunk <bunk@stusta.de>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-multimedia')
-rw-r--r-- | meta-multimedia/recipes-multimedia/caps/caps/0001-Do-not-use-obsolete-pow10f-function.patch | 50 | ||||
-rw-r--r-- | meta-multimedia/recipes-multimedia/caps/caps/Avoid-ambiguity-in-div-invocation.patch | 32 | ||||
-rw-r--r-- | meta-multimedia/recipes-multimedia/caps/caps_0.9.26.bb (renamed from meta-multimedia/recipes-multimedia/caps/caps_0.9.24.bb) | 6 |
3 files changed, 2 insertions, 86 deletions
diff --git a/meta-multimedia/recipes-multimedia/caps/caps/0001-Do-not-use-obsolete-pow10f-function.patch b/meta-multimedia/recipes-multimedia/caps/caps/0001-Do-not-use-obsolete-pow10f-function.patch deleted file mode 100644 index bd5e1b603..000000000 --- a/meta-multimedia/recipes-multimedia/caps/caps/0001-Do-not-use-obsolete-pow10f-function.patch +++ /dev/null | |||
@@ -1,50 +0,0 @@ | |||
1 | From 0cc7362e171616dcfeb93c6e1576362761bf14e5 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Wed, 31 Jan 2018 18:37:16 -0800 | ||
4 | Subject: [PATCH] Do not use obsolete pow10f() function | ||
5 | |||
6 | exp10 name is standardized in TS 18661-4 and its | ||
7 | available in glibc since version 2.1 | ||
8 | it has been now removed from glibc 2.27+ | ||
9 | |||
10 | Upstream-Status: Pending | ||
11 | |||
12 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
13 | --- | ||
14 | dsp/v4f_IIR2.h | 6 +++--- | ||
15 | 1 file changed, 3 insertions(+), 3 deletions(-) | ||
16 | |||
17 | diff --git a/dsp/v4f_IIR2.h b/dsp/v4f_IIR2.h | ||
18 | index a68ecf5..ebd1234 100644 | ||
19 | --- a/dsp/v4f_IIR2.h | ||
20 | +++ b/dsp/v4f_IIR2.h | ||
21 | @@ -33,7 +33,7 @@ | ||
22 | namespace DSP { | ||
23 | |||
24 | #ifdef __APPLE__ | ||
25 | -inline float pow10f(float f) {return pow(10,f);} | ||
26 | +inline float exp10f(float f) {return __exp10f(f);} | ||
27 | #endif | ||
28 | |||
29 | class RBJv4 | ||
30 | @@ -142,7 +142,7 @@ class IIR2v4 | ||
31 | /* A = pow (10, gain / 40) */ | ||
32 | v4f_t A = (v4f_t) {.025,.025,.025,.025}; | ||
33 | A *= gain; | ||
34 | - A = v4f_map<pow10f> (A); | ||
35 | + A = v4f_map<exp10f> (A); | ||
36 | |||
37 | RBJv4 p (f, Q); | ||
38 | |||
39 | @@ -429,7 +429,7 @@ class IIR2v4Bank | ||
40 | /* A = pow (10, gain / 40) */ | ||
41 | v4f_t A = (v4f_t) {.025,.025,.025,.025}; | ||
42 | A *= gain[i]; | ||
43 | - A = v4f_map<pow10f> (A); | ||
44 | + A = v4f_map<exp10f> (A); | ||
45 | |||
46 | RBJv4 p (f[i], Q[i]); | ||
47 | |||
48 | -- | ||
49 | 2.16.1 | ||
50 | |||
diff --git a/meta-multimedia/recipes-multimedia/caps/caps/Avoid-ambiguity-in-div-invocation.patch b/meta-multimedia/recipes-multimedia/caps/caps/Avoid-ambiguity-in-div-invocation.patch deleted file mode 100644 index 1a050af91..000000000 --- a/meta-multimedia/recipes-multimedia/caps/caps/Avoid-ambiguity-in-div-invocation.patch +++ /dev/null | |||
@@ -1,32 +0,0 @@ | |||
1 | From 1ea09653692efdd6443fb6770e8523bf6c9e49b9 Mon Sep 17 00:00:00 2001 | ||
2 | From: Fabio Berton <fabio.berton@ossystems.com.br> | ||
3 | Date: Thu, 6 Oct 2016 11:54:07 -0300 | ||
4 | Subject: Avoid ambiguity in div invocation | ||
5 | Organization: O.S. Systems Software LTDA. | ||
6 | |||
7 | Patch from: | ||
8 | https://anonscm.debian.org/cgit/pkg-multimedia/caps.git/commit/?id=9a99c225fb813ae69f146e3d90f7b47bdbd97708 | ||
9 | |||
10 | Upstream-Status: Pending | ||
11 | |||
12 | Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br> | ||
13 | --- | ||
14 | AutoFilter.cc | 2 +- | ||
15 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
16 | |||
17 | diff --git a/AutoFilter.cc b/AutoFilter.cc | ||
18 | index fc087d0..bd6b12f 100644 | ||
19 | --- a/AutoFilter.cc | ||
20 | +++ b/AutoFilter.cc | ||
21 | @@ -69,7 +69,7 @@ AutoFilter::activate() | ||
22 | void | ||
23 | AutoFilter::cycle (uint frames) | ||
24 | { | ||
25 | - div_t qr = div (frames, blocksize); | ||
26 | + div_t qr = div ((int)frames, (int)blocksize); | ||
27 | int blocks = qr.quot; | ||
28 | if (qr.rem) ++blocks; | ||
29 | double over_blocks = 1./blocks; | ||
30 | -- | ||
31 | 2.1.4 | ||
32 | |||
diff --git a/meta-multimedia/recipes-multimedia/caps/caps_0.9.24.bb b/meta-multimedia/recipes-multimedia/caps/caps_0.9.26.bb index 0404bd515..46bcf6c6a 100644 --- a/meta-multimedia/recipes-multimedia/caps/caps_0.9.24.bb +++ b/meta-multimedia/recipes-multimedia/caps/caps_0.9.26.bb | |||
@@ -4,14 +4,12 @@ LICENSE = "GPL-3" | |||
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" | 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" |
5 | 5 | ||
6 | SRC_URI = "http://quitte.de/dsp/${BPN}_${PV}.tar.bz2 \ | 6 | SRC_URI = "http://quitte.de/dsp/${BPN}_${PV}.tar.bz2 \ |
7 | file://Avoid-ambiguity-in-div-invocation.patch \ | ||
8 | file://0001-basic.h-Use-c99-supported-stdint-types.patch \ | 7 | file://0001-basic.h-Use-c99-supported-stdint-types.patch \ |
9 | file://append_ldflags.patch \ | 8 | file://append_ldflags.patch \ |
10 | file://0001-Do-not-use-obsolete-pow10f-function.patch \ | ||
11 | " | 9 | " |
12 | 10 | ||
13 | SRC_URI[md5sum] = "c1d634038dcb54702306c0e30cb1c626" | 11 | SRC_URI[md5sum] = "36b30c7c7db2d2bc5f4f54077e97b5ee" |
14 | SRC_URI[sha256sum] = "f746feba57af316b159f0169de5d78b4fd1064c2c0c8017cb5856b2f22e83f20" | 12 | SRC_URI[sha256sum] = "e7496c5bce05abebe3dcb635926153bbb58a9337a6e423f048d3b61d8a4f98c9" |
15 | 13 | ||
16 | EXTRA_OEMAKE = " \ | 14 | EXTRA_OEMAKE = " \ |
17 | CC='${CXX}' \ | 15 | CC='${CXX}' \ |