summaryrefslogtreecommitdiffstats
path: root/meta-multimedia
diff options
context:
space:
mode:
authorMarkus Volk <f_l_k@t-online.de>2023-05-23 10:49:28 +0200
committerKhem Raj <raj.khem@gmail.com>2023-05-23 15:04:38 -0700
commit6377780e8aa8ecfb4b2b8e6276d215b563908593 (patch)
treec2e2cfbbaf08849dd1cd9c81ea3282f54daedb48 /meta-multimedia
parent9cf8bab2f30bc6248b5be5d4e69eea4557a272b4 (diff)
downloadmeta-openembedded-6377780e8aa8ecfb4b2b8e6276d215b563908593.tar.gz
fluidsynth: update 2.2.6 -> 2.3.2
-remove unneeded patch -remove fluidsynth-native as it seems to be unneeded -remove STAGING_LIBDIR from target files -add more packageconfig options Signed-off-by: Markus Volk <f_l_k@t-online.de> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-multimedia')
-rw-r--r--meta-multimedia/recipes-multimedia/fluidsynth/fluidsynth-native_git.bb10
-rw-r--r--meta-multimedia/recipes-multimedia/fluidsynth/fluidsynth.inc12
-rw-r--r--meta-multimedia/recipes-multimedia/fluidsynth/fluidsynth/0001-Do-not-build-gentables-helper-we-have-to-use-native-.patch49
-rw-r--r--meta-multimedia/recipes-multimedia/fluidsynth/fluidsynth_git.bb33
4 files changed, 25 insertions, 79 deletions
diff --git a/meta-multimedia/recipes-multimedia/fluidsynth/fluidsynth-native_git.bb b/meta-multimedia/recipes-multimedia/fluidsynth/fluidsynth-native_git.bb
deleted file mode 100644
index a95c4c42a..000000000
--- a/meta-multimedia/recipes-multimedia/fluidsynth/fluidsynth-native_git.bb
+++ /dev/null
@@ -1,10 +0,0 @@
1require ${BPN}.inc
2
3inherit native
4
5OECMAKE_SOURCEPATH = "${S}/src/gentables"
6
7do_install() {
8 install -d ${D}/${bindir}
9 install -m 755 ${B}/make_tables.exe ${D}/${bindir}/
10}
diff --git a/meta-multimedia/recipes-multimedia/fluidsynth/fluidsynth.inc b/meta-multimedia/recipes-multimedia/fluidsynth/fluidsynth.inc
deleted file mode 100644
index a4590d61a..000000000
--- a/meta-multimedia/recipes-multimedia/fluidsynth/fluidsynth.inc
+++ /dev/null
@@ -1,12 +0,0 @@
1SUMMARY = "Fluidsynth is a software synthesizer"
2HOMEPAGE = "http://www.fluidsynth.org/"
3SECTION = "libs/multimedia"
4LICENSE = "LGPL-2.1-only"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=fc178bcd425090939a8b634d1d6a9594"
6
7SRC_URI = "git://github.com/FluidSynth/fluidsynth.git;branch=master;protocol=https"
8SRCREV = "8b00644751578ba67b709a827cbe5133d849d339"
9S = "${WORKDIR}/git"
10PV = "2.2.6"
11
12inherit cmake pkgconfig lib_package
diff --git a/meta-multimedia/recipes-multimedia/fluidsynth/fluidsynth/0001-Do-not-build-gentables-helper-we-have-to-use-native-.patch b/meta-multimedia/recipes-multimedia/fluidsynth/fluidsynth/0001-Do-not-build-gentables-helper-we-have-to-use-native-.patch
deleted file mode 100644
index cc73bdb1d..000000000
--- a/meta-multimedia/recipes-multimedia/fluidsynth/fluidsynth/0001-Do-not-build-gentables-helper-we-have-to-use-native-.patch
+++ /dev/null
@@ -1,49 +0,0 @@
1From 81ea820b155e887b13ea5986c3407cf93b2737f6 Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@gmail.com>
3Date: Wed, 2 Jan 2019 18:42:46 +0100
4Subject: [PATCH] Do not build gentables helper - we have to use native variant
5MIME-Version: 1.0
6Content-Type: text/plain; charset=UTF-8
7Content-Transfer-Encoding: 8bit
8
9Upstream-Status: Inappropriate [embedded specific]
10
11Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
12---
13 src/CMakeLists.txt | 23 +----------------------
14 1 file changed, 1 insertion(+), 22 deletions(-)
15
16diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
17index 356bb734..58ff7635 100644
18--- a/src/CMakeLists.txt
19+++ b/src/CMakeLists.txt
20@@ -399,25 +399,4 @@ else ( MACOSX_FRAMEWORK )
21 install ( FILES ${public_main_HEADER} DESTINATION ${INCLUDE_INSTALL_DIR} )
22 endif ( MACOSX_FRAMEWORK )
23
24-# ******* Auto Generated Lookup Tables ******
25-
26-include(ExternalProject)
27-
28-set (GENTAB_SDIR ${CMAKE_CURRENT_SOURCE_DIR}/gentables)
29-set (GENTAB_BDIR ${CMAKE_CURRENT_BINARY_DIR}/gentables)
30-
31-# Use external project to ensure that cmake uses the host compiler when building make_tables.exe
32-# To fix cross-compiling fluidsynth from Win32 to ARM (using vcpkg), we need to pass the current generator
33-# on to the external project, otherwise (for some unknown reason) the target compiler will be used rather
34-# than the host compiler.
35-ExternalProject_Add(gentables
36- DOWNLOAD_COMMAND ""
37- SOURCE_DIR ${GENTAB_SDIR}
38- BINARY_DIR ${GENTAB_BDIR}
39- CONFIGURE_COMMAND
40- "${CMAKE_COMMAND}" -DCMAKE_VERBOSE_MAKEFILE=${CMAKE_VERBOSE_MAKEFILE} -G "${CMAKE_GENERATOR}" -B "${GENTAB_BDIR}" "${GENTAB_SDIR}"
41- BUILD_COMMAND
42- "${CMAKE_COMMAND}" --build "${GENTAB_BDIR}"
43- INSTALL_COMMAND ${GENTAB_BDIR}/make_tables.exe "${CMAKE_BINARY_DIR}/"
44-)
45-add_dependencies(libfluidsynth-OBJ gentables)
46+
47--
482.21.1
49
diff --git a/meta-multimedia/recipes-multimedia/fluidsynth/fluidsynth_git.bb b/meta-multimedia/recipes-multimedia/fluidsynth/fluidsynth_git.bb
index 984f37b75..a1083af56 100644
--- a/meta-multimedia/recipes-multimedia/fluidsynth/fluidsynth_git.bb
+++ b/meta-multimedia/recipes-multimedia/fluidsynth/fluidsynth_git.bb
@@ -1,23 +1,40 @@
1require ${BPN}.inc 1SUMMARY = "Fluidsynth is a software synthesizer"
2HOMEPAGE = "http://www.fluidsynth.org/"
3SECTION = "libs/multimedia"
4LICENSE = "LGPL-2.1-only"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=fc178bcd425090939a8b634d1d6a9594"
2 6
3DEPENDS = "${BPN}-native alsa-lib ncurses glib-2.0" 7SRC_URI = "git://github.com/FluidSynth/fluidsynth.git;branch=master;protocol=https"
8SRCREV = "4d8fe638e1a48660a4c843d493f69a86579e12f0"
9S = "${WORKDIR}/git"
10PV = "2.3.2"
11
12inherit cmake pkgconfig lib_package
13
14DEPENDS = "glib-2.0"
4 15
5SRC_URI += " \ 16SRC_URI += " \
6 file://0001-Do-not-build-gentables-helper-we-have-to-use-native-.patch \
7 file://0002-fluid_synth_nwrite_float-Allow-zero-pointer-for-left.patch \ 17 file://0002-fluid_synth_nwrite_float-Allow-zero-pointer-for-left.patch \
8 file://0003-Use-ARM-NEON-accelaration-for-float-multithreaded-se.patch \ 18 file://0003-Use-ARM-NEON-accelaration-for-float-multithreaded-se.patch \
9" 19"
10 20
11EXTRA_OECMAKE = "-Denable-floats=ON -DLIB_SUFFIX=${@d.getVar('baselib').replace('lib', '')}" 21EXTRA_OECMAKE = "-Denable-floats=ON -DLIB_SUFFIX=${@d.getVar('baselib').replace('lib', '')}"
12 22
13do_configure:append() { 23do_install:append() {
14 make_tables.exe ${B}/ 24 sed -i -e 's|${STAGING_LIBDIR}|${libdir}|g' ${D}${libdir}/pkgconfig/fluidsynth.pc
25 sed -i -e 's|${STAGING_LIBDIR}|${libdir}|g' ${D}${libdir}/cmake/fluidsynth/FluidSynthTargets.cmake
15} 26}
16 27
17PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'pulseaudio', d)}" 28PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'pulseaudio pipewire systemd alsa dbus', d)}"
18PACKAGECONFIG[sndfile] = "-Denable-libsndfile=ON,-Denable-libsndfile=OFF,libsndfile1" 29PACKAGECONFIG[alsa] = "-Denable-alsa=ON,-Denable-alsa=OFF,alsa-lib"
30PACKAGECONFIG[dbus] = "-Denable-dbus=ON,-Denable-dbus=OFF,dbus"
19PACKAGECONFIG[jack] = "-Denable-jack=ON,-Denable-jack=OFF,jack" 31PACKAGECONFIG[jack] = "-Denable-jack=ON,-Denable-jack=OFF,jack"
20PACKAGECONFIG[pulseaudio] = "-Denable-pulseaudio=ON,-Denable-pulseaudio=OFF,pulseaudio" 32PACKAGECONFIG[oss] = "-Denable-oss=ON,-Denable-oss=OFF"
33PACKAGECONFIG[pipewire] = "-Denable-pipewire=ON,-Denable-pipewire=OFF,pipewire"
21PACKAGECONFIG[portaudio] = "-Denable-portaudio=ON,-Denable-portaudio=OFF,portaudio-v19" 34PACKAGECONFIG[portaudio] = "-Denable-portaudio=ON,-Denable-portaudio=OFF,portaudio-v19"
22PACKAGECONFIG[profiling] = "-Denable-profiling=ON,-Denable-profiling=OFF" 35PACKAGECONFIG[profiling] = "-Denable-profiling=ON,-Denable-profiling=OFF"
36PACKAGECONFIG[pulseaudio] = "-Denable-pulseaudio=ON,-Denable-pulseaudio=OFF,pulseaudio"
23PACKAGECONFIG[readline] = "-Denable-readline=ON,-Denable-readline=OFF,readline" 37PACKAGECONFIG[readline] = "-Denable-readline=ON,-Denable-readline=OFF,readline"
38PACKAGECONFIG[sdl] = "-Denable-sdl2=ON,-Denable-sdl2=OFF,libsdl2"
39PACKAGECONFIG[sndfile] = "-Denable-libsndfile=ON,-Denable-libsndfile=OFF,libsndfile1"
40PACKAGECONFIG[systemd] = "-Denable-systemd=ON,-Denable-systemd=OFF,systemd"