diff options
author | Stefan Agner <stefan.agner@toradex.com> | 2016-03-24 16:26:56 -0700 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2016-04-01 15:33:51 +0200 |
commit | 6132a35f8cf3906acef4ba54b7d8819a82e05be0 (patch) | |
tree | 968a7d122077b4e4384f9608fd1363f47854a9b2 /meta-multimedia | |
parent | 44f0e74954628d6a3d04fa5249dbe0c94f6dff59 (diff) | |
download | meta-openembedded-6132a35f8cf3906acef4ba54b7d8819a82e05be0.tar.gz |
gstreamer: fix argument parsing when using Bison 3
Remove the argument fix patch and add a patch which fixes the
grammer.y Bison input file. YYLEX_PARAM seems to be no longer
supported and has been replaced with %parse-param which has
been introduced already in 2003.
This fixes a segmentation fault when launching gst-launch-0.10.
Signed-off-by: Stefan Agner <stefan.agner@toradex.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-multimedia')
3 files changed, 36 insertions, 34 deletions
diff --git a/meta-multimedia/recipes-multimedia/gstreamer-0.10/gstreamer-0.10.36/0001-parse-make-grammar.y-work-with-Bison-3.patch b/meta-multimedia/recipes-multimedia/gstreamer-0.10/gstreamer-0.10.36/0001-parse-make-grammar.y-work-with-Bison-3.patch new file mode 100644 index 000000000..dc2d60612 --- /dev/null +++ b/meta-multimedia/recipes-multimedia/gstreamer-0.10/gstreamer-0.10.36/0001-parse-make-grammar.y-work-with-Bison-3.patch | |||
@@ -0,0 +1,35 @@ | |||
1 | From 60516f4798894f958fc53b470e1283318d0f8706 Mon Sep 17 00:00:00 2001 | ||
2 | From: Kerrick Staley <kerrick@kerrickstaley.com> | ||
3 | Date: Tue, 20 Aug 2013 23:59:29 -0700 | ||
4 | Subject: [PATCH 1/2] parse: make grammar.y work with Bison 3 | ||
5 | |||
6 | YYLEX_PARAM is no longer supported in Bison 3. | ||
7 | |||
8 | https://bugzilla.gnome.org/show_bug.cgi?id=706462 | ||
9 | --- | ||
10 | gst/parse/grammar.y | 2 +- | ||
11 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
12 | |||
13 | diff --git a/gst/parse/grammar.y b/gst/parse/grammar.y | ||
14 | index 24fc87b..7f9dd16 100644 | ||
15 | --- a/gst/parse/grammar.y | ||
16 | +++ b/gst/parse/grammar.y | ||
17 | @@ -26,7 +26,6 @@ | ||
18 | */ | ||
19 | |||
20 | #define YYERROR_VERBOSE 1 | ||
21 | -#define YYLEX_PARAM scanner | ||
22 | |||
23 | #define YYENABLE_NLS 0 | ||
24 | |||
25 | @@ -648,6 +647,7 @@ static int yyerror (void *scanner, graph_t *graph, const char *s); | ||
26 | %right '.' | ||
27 | %left '!' '=' | ||
28 | |||
29 | +%lex-param { void *scanner } | ||
30 | %parse-param { void *scanner } | ||
31 | %parse-param { graph_t *graph } | ||
32 | %pure-parser | ||
33 | -- | ||
34 | 2.7.2 | ||
35 | |||
diff --git a/meta-multimedia/recipes-multimedia/gstreamer-0.10/gstreamer-0.10.36/gstreamer-change-priv_gst_parse_yylex-arguments.patch b/meta-multimedia/recipes-multimedia/gstreamer-0.10/gstreamer-0.10.36/gstreamer-change-priv_gst_parse_yylex-arguments.patch deleted file mode 100644 index bf93cb219..000000000 --- a/meta-multimedia/recipes-multimedia/gstreamer-0.10/gstreamer-0.10.36/gstreamer-change-priv_gst_parse_yylex-arguments.patch +++ /dev/null | |||
@@ -1,33 +0,0 @@ | |||
1 | gstreamer: change priv_gst_parse_yylex arguments | ||
2 | |||
3 | Change priv_gst_parse_yylex to fit new bison version, else we will | ||
4 | get following error: | ||
5 | |||
6 | | grammar.tab.c: In function 'priv_gst_parse_yyparse': | ||
7 | | grammar.tab.c:67:25: error: too few arguments to function 'priv_gst_parse_yylex' | ||
8 | | #define yylex priv_gst_parse_yylex | ||
9 | | ^ | ||
10 | |||
11 | Upstream-Status: Pending | ||
12 | |||
13 | Signed-off-by: Chong Lu <Chong.Lu@windriver.com> | ||
14 | --- | ||
15 | gst/parse/grammar.y | 2 +- | ||
16 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
17 | |||
18 | diff --git a/gst/parse/grammar.y b/gst/parse/grammar.y | ||
19 | index 24fc87b..24fe906 100644 | ||
20 | --- a/gst/parse/grammar.y | ||
21 | +++ b/gst/parse/grammar.y | ||
22 | @@ -36,7 +36,7 @@ | ||
23 | |||
24 | typedef void* yyscan_t; | ||
25 | |||
26 | -int priv_gst_parse_yylex (void * yylval_param , yyscan_t yyscanner); | ||
27 | +int priv_gst_parse_yylex (yyscan_t yyscanner); | ||
28 | int priv_gst_parse_yylex_init (yyscan_t scanner); | ||
29 | int priv_gst_parse_yylex_destroy (yyscan_t scanner); | ||
30 | struct yy_buffer_state * priv_gst_parse_yy_scan_string (char* , yyscan_t); | ||
31 | -- | ||
32 | 1.9.1 | ||
33 | |||
diff --git a/meta-multimedia/recipes-multimedia/gstreamer-0.10/gstreamer_0.10.36.bb b/meta-multimedia/recipes-multimedia/gstreamer-0.10/gstreamer_0.10.36.bb index 34445113b..f61a41092 100644 --- a/meta-multimedia/recipes-multimedia/gstreamer-0.10/gstreamer_0.10.36.bb +++ b/meta-multimedia/recipes-multimedia/gstreamer-0.10/gstreamer_0.10.36.bb | |||
@@ -15,7 +15,7 @@ SRC_URI = "http://gstreamer.freedesktop.org/src/gstreamer/gstreamer-${PV}.tar.bz | |||
15 | file://check_fix.patch \ | 15 | file://check_fix.patch \ |
16 | file://gst-inspect-check-error.patch \ | 16 | file://gst-inspect-check-error.patch \ |
17 | file://0001-baseparse-Fix-self-comparison-always-evaluates-to-tr.patch \ | 17 | file://0001-baseparse-Fix-self-comparison-always-evaluates-to-tr.patch \ |
18 | file://gstreamer-change-priv_gst_parse_yylex-arguments.patch \ | 18 | file://0001-parse-make-grammar.y-work-with-Bison-3.patch \ |
19 | " | 19 | " |
20 | 20 | ||
21 | SRC_URI[md5sum] = "a0cf7d6877f694a1a2ad2b4d1ecb890b" | 21 | SRC_URI[md5sum] = "a0cf7d6877f694a1a2ad2b4d1ecb890b" |