summaryrefslogtreecommitdiffstats
path: root/meta-multimedia
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-05-09 00:57:11 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2017-05-23 15:49:38 +0200
commitecf010966c8bbc3192011c96d5d721c21a2edd71 (patch)
tree61217d72f21731b3b2d24338354cb52d1a9afe87 /meta-multimedia
parentc9a07b63e3268e4b8d04c6917d8cd131e019e65c (diff)
downloadmeta-openembedded-ecf010966c8bbc3192011c96d5d721c21a2edd71.tar.gz
kodi: Fix build when x11 is disabled
Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-multimedia')
-rw-r--r--meta-multimedia/recipes-mediacenter/kodi/kodi-17/0001-change-order-of-detecting-libegl-and-libgles2.patch32
-rw-r--r--meta-multimedia/recipes-mediacenter/kodi/kodi_17.bb10
2 files changed, 38 insertions, 4 deletions
diff --git a/meta-multimedia/recipes-mediacenter/kodi/kodi-17/0001-change-order-of-detecting-libegl-and-libgles2.patch b/meta-multimedia/recipes-mediacenter/kodi/kodi-17/0001-change-order-of-detecting-libegl-and-libgles2.patch
new file mode 100644
index 000000000..12a6c06e8
--- /dev/null
+++ b/meta-multimedia/recipes-mediacenter/kodi/kodi-17/0001-change-order-of-detecting-libegl-and-libgles2.patch
@@ -0,0 +1,32 @@
1From 21524598110e7a55113205dda4bc1a6d5987111c Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Tue, 9 May 2017 06:41:33 +0000
4Subject: [PATCH] change order of detecting libegl and libgles2
5
6This actually helps building it on rpi/userland
7where libEGL depends on few functions from libGLESv2
8see
9https://www.raspberrypi.org/forums/viewtopic.php?t=7090
10
11Signed-off-by: Khem Raj <raj.khem@gmail.com>
12---
13 configure.ac | 2 +-
14 1 file changed, 1 insertion(+), 1 deletion(-)
15
16diff --git a/configure.ac b/configure.ac
17index b9e4240..1ca0297 100644
18--- a/configure.ac
19+++ b/configure.ac
20@@ -951,8 +951,8 @@ if test "$use_gles" = "yes"; then
21 AC_MSG_RESULT(== WARNING: OpenGLES support is assumed.)
22 LIBS="$LIBS -lEGL -lGLESv2 -lbcm_host -lvcos -lvchiq_arm -lmmal -lmmal_core -lmmal_util -lvcsm"
23 else
24- AC_CHECK_LIB([EGL], [main],, AC_MSG_ERROR($missing_library))
25 AC_CHECK_LIB([GLESv2],[main],, AC_MSG_ERROR($missing_library))
26+ AC_CHECK_LIB([EGL], [main],, AC_MSG_ERROR($missing_library))
27 fi
28 fi
29 else
30--
311.9.1
32
diff --git a/meta-multimedia/recipes-mediacenter/kodi/kodi_17.bb b/meta-multimedia/recipes-mediacenter/kodi/kodi_17.bb
index 8f75bb48d..23f09af51 100644
--- a/meta-multimedia/recipes-mediacenter/kodi/kodi_17.bb
+++ b/meta-multimedia/recipes-mediacenter/kodi/kodi_17.bb
@@ -77,6 +77,7 @@ SRC_URI = "git://github.com/xbmc/xbmc.git;branch=Krypton \
77 file://0010-RssReader-Fix-compiler-warning-comparing-pointer-to-.patch \ 77 file://0010-RssReader-Fix-compiler-warning-comparing-pointer-to-.patch \
78 file://0011-Let-configure-pass-on-unknown-architectures-setting-.patch \ 78 file://0011-Let-configure-pass-on-unknown-architectures-setting-.patch \
79 file://0012-Revert-droid-fix-builds-with-AML-disabled.patch \ 79 file://0012-Revert-droid-fix-builds-with-AML-disabled.patch \
80 file://0001-change-order-of-detecting-libegl-and-libgles2.patch \
80" 81"
81 82
82SRC_URI_append_libc-musl = " \ 83SRC_URI_append_libc-musl = " \
@@ -86,7 +87,9 @@ SRC_URI_append_libc-musl = " \
86SRC_URI[addons.md5sum] = "719614fa764011a18665d08af5c8c92f" 87SRC_URI[addons.md5sum] = "719614fa764011a18665d08af5c8c92f"
87SRC_URI[addons.sha256sum] = "350da57408c27473eaf40e7f544bc94841bf101dc4346085260c5c4af0adac97" 88SRC_URI[addons.sha256sum] = "350da57408c27473eaf40e7f544bc94841bf101dc4346085260c5c4af0adac97"
88 89
89inherit autotools-brokensep gettext pythonnative 90inherit autotools-brokensep gettext pythonnative distro_features_check
91
92REQUIRED_DISTRO_FEATURES += "opengl"
90 93
91S = "${WORKDIR}/git" 94S = "${WORKDIR}/git"
92 95
@@ -97,9 +100,8 @@ ACCEL ?= ""
97ACCEL_x86 = "vaapi vdpau" 100ACCEL_x86 = "vaapi vdpau"
98ACCEL_x86-64 = "vaapi vdpau" 101ACCEL_x86-64 = "vaapi vdpau"
99 102
100PACKAGECONFIG ??= "${ACCEL}" 103PACKAGECONFIG ??= "${ACCEL} opengl"
101PACKAGECONFIG_append = " ${@bb.utils.contains('DISTRO_FEATURES', 'x11', ' x11', '', d)}" 104PACKAGECONFIG_append = " ${@bb.utils.contains('DISTRO_FEATURES', 'x11', ' x11', ' openglesv2', d)}"
102PACKAGECONFIG_append = " ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', ' opengl', ' openglesv2', d)}"
103 105
104PACKAGECONFIG[opengl] = "--enable-gl,--enable-gles," 106PACKAGECONFIG[opengl] = "--enable-gl,--enable-gles,"
105PACKAGECONFIG[openglesv2] = "--enable-gles,--enable-gl,virtual/egl" 107PACKAGECONFIG[openglesv2] = "--enable-gles,--enable-gl,virtual/egl"