summaryrefslogtreecommitdiffstats
path: root/meta-multimedia
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-07-01 14:33:09 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2017-07-14 23:44:30 +0200
commit5e9f83d11aede7113782f41400299582c7750bea (patch)
tree00045acf7df8c5e208c8019ed387e8494042a2da /meta-multimedia
parent23a1d7accaf7c71559944a83cdb8622eb2be6d05 (diff)
downloadmeta-openembedded-5e9f83d11aede7113782f41400299582c7750bea.tar.gz
crossguid: Add recipe
Needed by kodi Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-multimedia')
-rw-r--r--meta-multimedia/recipes-support/crossguid/crossguid.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-multimedia/recipes-support/crossguid/crossguid.bb b/meta-multimedia/recipes-support/crossguid/crossguid.bb
new file mode 100644
index 000000000..228b8b654
--- /dev/null
+++ b/meta-multimedia/recipes-support/crossguid/crossguid.bb
@@ -0,0 +1,25 @@
1# Copyright (C) 2017 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4DESCRIPTION = "Lightweight cross platform C++ GUID/UUID library"
5HOMEPAGE = "https://github.com/graeme-hill/crossguid"
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=1373274bc8d8001edc54933919f36f68"
8DEPENDS += "util-linux"
9
10PV = "0.0+git${SRCPV}"
11
12SRCREV = "b56957ac453575e91ca1b63a80c0077c2b0d011a"
13SRC_URI = "git://github.com/graeme-hill/crossguid;protocol=https"
14
15S = "${WORKDIR}/git"
16
17do_compile() {
18 ${CXX} -c guid.cpp -o guid.o ${CXXFLAGS} -std=c++11 -DGUID_LIBUUID
19 ${AR} rvs libcrossguid.a guid.o
20}
21
22do_install() {
23 install -D -m 0644 ${B}/libcrossguid.a ${D}${libdir}/libcrossguid.a
24 install -D -m 0644 ${S}/guid.h ${D}${includedir}/guid.h
25}