summaryrefslogtreecommitdiffstats
path: root/meta-multimedia
diff options
context:
space:
mode:
authorCarlos Rodriguez <carlos.rodriguez@ridgerun.com>2018-02-19 14:14:10 -0600
committerArmin Kuster <akuster808@gmail.com>2018-03-01 16:12:55 -0800
commit03f79a311c79c7b43f8e47eba4c5bbe6ab532fa1 (patch)
treef9657c1611e1e52e452c93df27bbd797eae0f5f9 /meta-multimedia
parent74880c14647f3d875e18ea4eea4081419f82e021 (diff)
downloadmeta-openembedded-03f79a311c79c7b43f8e47eba4c5bbe6ab532fa1.tar.gz
gstd: Add Gst-Deamon recipe
GStreamer Daemon, also called gstd, is a GStreamer framework for controlling audio and video streaming using TCP connection messages. Qt applications, web interfaces, and GStreamer element test suites show different ways the framework can be utilized. GStreamer Daemon is gst-launch on steroids where you can create a GStreamer pipeline, play, pause, change speed, skip around, and even change element parameter settings all while the pipeline is active. Signed-off-by: Carlos Rodriguez <carlos.rodriguez@ridgerun.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-multimedia')
-rw-r--r--meta-multimedia/recipes-multimedia/gstreamer-1.0/gstd.inc25
-rw-r--r--meta-multimedia/recipes-multimedia/gstreamer-1.0/gstd/0001-gstd-yocto-compatibility.patch63
-rw-r--r--meta-multimedia/recipes-multimedia/gstreamer-1.0/gstd_1.0.bb3
3 files changed, 91 insertions, 0 deletions
diff --git a/meta-multimedia/recipes-multimedia/gstreamer-1.0/gstd.inc b/meta-multimedia/recipes-multimedia/gstreamer-1.0/gstd.inc
new file mode 100644
index 000000000..10ee5bcb2
--- /dev/null
+++ b/meta-multimedia/recipes-multimedia/gstreamer-1.0/gstd.inc
@@ -0,0 +1,25 @@
1DESCRIPTION = "Gstreamer Daemon 1.0"
2SUMMARY = "GStreamer framework for controlling audio and video streaming using TCP connection messages"
3HOMEPAGE = "https://developer.ridgerun.com/wiki/index.php?title=Gstd-1.0"
4SECTION = "multimedia"
5LICENSE = "GPLv2+"
6
7DEPENDS = "gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad gstreamer1.0-rtsp-server json-glib libdaemon"
8
9SRCBRANCH ?= "master"
10SRCREV = "097a086a8606dcb368c7d38c7ec4fefc2497401b"
11SRC_URI = "git://git@github.com/RidgeRun/gstd-1.x.git;protocol=https;branch=${SRCBRANCH} \
12 file://0001-gstd-yocto-compatibility.patch"
13
14S = "${WORKDIR}/git"
15
16PACKAGECONFIG_CONFARGS = " \
17 --disable-gtk-doc \
18"
19
20inherit autotools pkgconfig gettext
21
22do_configure() {
23${S}/autogen.sh
24oe_runconf
25}
diff --git a/meta-multimedia/recipes-multimedia/gstreamer-1.0/gstd/0001-gstd-yocto-compatibility.patch b/meta-multimedia/recipes-multimedia/gstreamer-1.0/gstd/0001-gstd-yocto-compatibility.patch
new file mode 100644
index 000000000..ddc183193
--- /dev/null
+++ b/meta-multimedia/recipes-multimedia/gstreamer-1.0/gstd/0001-gstd-yocto-compatibility.patch
@@ -0,0 +1,63 @@
1From eaf51d6420c63713f62025583681007c3502d387 Mon Sep 17 00:00:00 2001
2From: Carlos <carlos.rodriguez@ridgerun.com>
3Date: Fri, 15 Dec 2017 10:14:05 -0600
4Subject: [PATCH] gstd:yocto compatibility
5
6---
7 autogen.sh | 8 +++++++-
8 docs/reference/gstd/Makefile.am | 2 +-
9 gstd/Makefile.am | 2 +-
10 3 files changed, 9 insertions(+), 3 deletions(-)
11
12diff --git a/autogen.sh b/autogen.sh
13index 66dbd42..793ee2f 100755
14--- a/autogen.sh
15+++ b/autogen.sh
16@@ -21,7 +21,11 @@
17 # ACLOCAL, AUTOPOINT and/or LIBTOOLIZE to the right versions, or leave them
18 # unset and get the defaults
19
20-gtkdocize || exit 1
21+test -n "$srcdir" || srcdir=`dirname "$0"`
22+test -n "$srcdir" || srcdir=.
23+
24+olddir=`pwd`
25+cd "$srcdir"
26
27 autoreconf --verbose --force --install || {
28 echo 'autogen.sh failed';
29@@ -31,3 +35,5 @@ autoreconf --verbose --force --install || {
30 echo
31 echo "Now run './configure' with your system settings followed by 'make' to compile this module."
32 echo
33+
34+cd "$olddir"
35diff --git a/docs/reference/gstd/Makefile.am b/docs/reference/gstd/Makefile.am
36index f860fa1..153a13b 100644
37--- a/docs/reference/gstd/Makefile.am
38+++ b/docs/reference/gstd/Makefile.am
39@@ -66,7 +66,7 @@ GTKDOC_LIBS=$(top_builddir)/gstd/libgstd-core.la
40
41
42 # This includes the standard gtk-doc make rules, copied by gtkdocize.
43-include $(top_srcdir)/docs/gtk-doc.make
44+# include $(top_srcdir)/docs/gtk-doc.make
45
46 # Comment this out if you want 'make check' to test you doc status
47 # and run some sanity checks
48diff --git a/gstd/Makefile.am b/gstd/Makefile.am
49index 13c551d..11fe202 100644
50--- a/gstd/Makefile.am
51+++ b/gstd/Makefile.am
52@@ -49,7 +49,7 @@ bin_PROGRAMS = gstd
53
54 gstd_SOURCES = gstd.c
55 gstd_CFLAGS = $(GST_CFLAGS) $(GIO_CFLAGS) $(GJSON_CFLAGS)
56-gstd_LDFLAGS = $(GST_LIBS) $(GIO_LIBS) $(GJSON_LIBS) -Wl,-rpath -Wl,$(libdir)
57+gstd_LDFLAGS = $(GST_LIBS) $(GIO_LIBS) $(GJSON_LIBS)
58 gstd_LDADD = libgstd-core.la
59
60 gstdincludedir = $(includedir)/gstd
61--
621.9.1
63
diff --git a/meta-multimedia/recipes-multimedia/gstreamer-1.0/gstd_1.0.bb b/meta-multimedia/recipes-multimedia/gstreamer-1.0/gstd_1.0.bb
new file mode 100644
index 000000000..94f6b575b
--- /dev/null
+++ b/meta-multimedia/recipes-multimedia/gstreamer-1.0/gstd_1.0.bb
@@ -0,0 +1,3 @@
1require gstd.inc
2
3LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"