summaryrefslogtreecommitdiffstats
path: root/meta-multimedia
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-06-30 05:59:42 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2017-07-14 23:43:20 +0200
commit9847dfaa54c7a33b8fdbfce839f6d1b74bf5e553 (patch)
tree7404db6bd7647a3c51147891d78b37d753eb0ef8 /meta-multimedia
parent66b88f7729d24ef2e3469fcaca172f420c4d54be (diff)
downloadmeta-openembedded-9847dfaa54c7a33b8fdbfce839f6d1b74bf5e553.tar.gz
gst-plugins-gl_0.10.3.bb: Fix build on rpi/userland
see https://www.raspberrypi.org/forums/viewtopic.php?t=7090 Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-multimedia')
-rw-r--r--meta-multimedia/recipes-multimedia/gstreamer-0.10/gst-plugins-gl/rpi-egl-gles2-dep.patch22
-rw-r--r--meta-multimedia/recipes-multimedia/gstreamer-0.10/gst-plugins-gl_0.10.3.bb4
2 files changed, 25 insertions, 1 deletions
diff --git a/meta-multimedia/recipes-multimedia/gstreamer-0.10/gst-plugins-gl/rpi-egl-gles2-dep.patch b/meta-multimedia/recipes-multimedia/gstreamer-0.10/gst-plugins-gl/rpi-egl-gles2-dep.patch
new file mode 100644
index 000000000..7db1c5afc
--- /dev/null
+++ b/meta-multimedia/recipes-multimedia/gstreamer-0.10/gst-plugins-gl/rpi-egl-gles2-dep.patch
@@ -0,0 +1,22 @@
1Check for header and library separately and check for GLESv2 before egl
2this is to overcome an annoying issue with rpi/userland where egl depends
3on sysmbols from libGLESv2
4
5-Khem
6Index: gst-plugins-gl-0.10.3/configure.ac
7===================================================================
8--- gst-plugins-gl-0.10.3.orig/configure.ac
9+++ gst-plugins-gl-0.10.3/configure.ac
10@@ -183,8 +183,10 @@ case $host in
11 else
12 AC_CHECK_HEADERS([EGL/egl.h], [HAVE_EGL=yes], [HAVE_EGL=no])
13 if test "x$HAVE_EGL" = "xyes"; then
14- AG_GST_CHECK_LIBHEADER(EGL, EGL, eglGetError,, EGL/egl.h,, AC_MSG_ERROR([EGL is required]))
15- AG_GST_CHECK_LIBHEADER(GLES2, GLESv2, glTexImage2D,, GLES2/gl2.h,, AC_MSG_ERROR([OpenGLES2 is required]))
16+ AC_CHECK_HEADERS([GLES2/gl2.h],, AC_MSG_ERROR([OpenGLES2 is required]))
17+ AC_CHECK_LIB(GLESv2,[glTexImage2D],, AC_MSG_ERROR([OpenGLES2 is required]))
18+ AC_CHECK_HEADERS([EGL/egl.h],, AC_MSG_ERROR([EGL is required]))
19+ AC_CHECK_LIB(EGL,[eglGetError],, AC_MSG_ERROR([EGL is required]))
20 GL_LIBS="$LIBS $X_LIBS -lEGL -lGLESv2"
21 GL_BACKEND=x11ES2
22 GL_TYPE=gles
diff --git a/meta-multimedia/recipes-multimedia/gstreamer-0.10/gst-plugins-gl_0.10.3.bb b/meta-multimedia/recipes-multimedia/gstreamer-0.10/gst-plugins-gl_0.10.3.bb
index 6859f338e..bb69bfe9f 100644
--- a/meta-multimedia/recipes-multimedia/gstreamer-0.10/gst-plugins-gl_0.10.3.bb
+++ b/meta-multimedia/recipes-multimedia/gstreamer-0.10/gst-plugins-gl_0.10.3.bb
@@ -6,7 +6,9 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=55ca817ccb7d5b5b66355690e9abc605"
6SRC_URI[md5sum] = "ac70ede13f79978d56eaed8abaa3c938" 6SRC_URI[md5sum] = "ac70ede13f79978d56eaed8abaa3c938"
7SRC_URI[sha256sum] = "48340b6a4b8abce16344a7bc33e74a94fdcce4f57ef6342cdf2f941c429bf210" 7SRC_URI[sha256sum] = "48340b6a4b8abce16344a7bc33e74a94fdcce4f57ef6342cdf2f941c429bf210"
8 8
9SRC_URI += " file://0001-conditional-gl-framebuffer-undefined-use.patch" 9SRC_URI += " file://0001-conditional-gl-framebuffer-undefined-use.patch \
10 file://rpi-egl-gles2-dep.patch \
11"
10 12
11DEPENDS += "gst-plugins-base virtual/libgles2 virtual/egl jpeg libpng glew" 13DEPENDS += "gst-plugins-base virtual/libgles2 virtual/egl jpeg libpng glew"
12 14