summaryrefslogtreecommitdiffstats
path: root/meta-multimedia
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-06-30 05:59:50 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2017-07-14 23:43:21 +0200
commit69d7273a599265ecc8e128b20701f1c036609b4c (patch)
tree78ab37ed0b4ba192f1cd202ca288832bddac35f3 /meta-multimedia
parent8d5d0663eb37e35aefa79f78938a385f4c31d520 (diff)
downloadmeta-openembedded-69d7273a599265ecc8e128b20701f1c036609b4c.tar.gz
libsrtp: Fix build on mips
Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-multimedia')
-rw-r--r--meta-multimedia/recipes-support/libsrtp/libsrtp/0001-Rename-conflicting-variable-mips.patch73
-rw-r--r--meta-multimedia/recipes-support/libsrtp/libsrtp_1.5.2.bb4
2 files changed, 76 insertions, 1 deletions
diff --git a/meta-multimedia/recipes-support/libsrtp/libsrtp/0001-Rename-conflicting-variable-mips.patch b/meta-multimedia/recipes-support/libsrtp/libsrtp/0001-Rename-conflicting-variable-mips.patch
new file mode 100644
index 000000000..b56c78959
--- /dev/null
+++ b/meta-multimedia/recipes-support/libsrtp/libsrtp/0001-Rename-conflicting-variable-mips.patch
@@ -0,0 +1,73 @@
1From 3dc8a678a844247d0afcf7e30fb3cbd5ccbd828f Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Thu, 29 Jun 2017 14:05:06 -0700
4Subject: [PATCH] Rename conflicting variable 'mips'
5
6Fixes
7test/srtp_driver.c:344:12: error: expected identifier or '(' before numeric constant
8 double mips = mips_estimate(1000000000, &ignore);
9
10Signed-off-by: Khem Raj <raj.khem@gmail.com>
11---
12 test/srtp_driver.c | 20 ++++++++++----------
13 1 file changed, 10 insertions(+), 10 deletions(-)
14
15diff --git a/test/srtp_driver.c b/test/srtp_driver.c
16index 8872971..d38ea19 100644
17--- a/test/srtp_driver.c
18+++ b/test/srtp_driver.c
19@@ -341,7 +341,7 @@ main (int argc, char *argv[]) {
20 if (do_codec_timing) {
21 srtp_policy_t policy;
22 int ignore;
23- double mips = mips_estimate(1000000000, &ignore);
24+ double est = mips_estimate(1000000000, &ignore);
25
26 crypto_policy_set_rtp_default(&policy.rtp);
27 crypto_policy_set_rtcp_default(&policy.rtcp);
28@@ -353,33 +353,33 @@ main (int argc, char *argv[]) {
29 policy.allow_repeat_tx = 0;
30 policy.next = NULL;
31
32- printf("mips estimate: %e\n", mips);
33+ printf("mips estimate: %e\n", est);
34
35 printf("testing srtp processing time for voice codecs:\n");
36 printf("codec\t\tlength (octets)\t\tsrtp instructions/second\n");
37 printf("G.711\t\t%d\t\t\t%e\n", 80,
38- (double) mips * (80 * 8) /
39+ (double) est * (80 * 8) /
40 srtp_bits_per_second(80, &policy) / .01 );
41 printf("G.711\t\t%d\t\t\t%e\n", 160,
42- (double) mips * (160 * 8) /
43+ (double) est * (160 * 8) /
44 srtp_bits_per_second(160, &policy) / .02);
45 printf("G.726-32\t%d\t\t\t%e\n", 40,
46- (double) mips * (40 * 8) /
47+ (double) est * (40 * 8) /
48 srtp_bits_per_second(40, &policy) / .01 );
49 printf("G.726-32\t%d\t\t\t%e\n", 80,
50- (double) mips * (80 * 8) /
51+ (double) est * (80 * 8) /
52 srtp_bits_per_second(80, &policy) / .02);
53 printf("G.729\t\t%d\t\t\t%e\n", 10,
54- (double) mips * (10 * 8) /
55+ (double) est * (10 * 8) /
56 srtp_bits_per_second(10, &policy) / .01 );
57 printf("G.729\t\t%d\t\t\t%e\n", 20,
58- (double) mips * (20 * 8) /
59+ (double) est * (20 * 8) /
60 srtp_bits_per_second(20, &policy) / .02 );
61 printf("Wideband\t%d\t\t\t%e\n", 320,
62- (double) mips * (320 * 8) /
63+ (double) est * (320 * 8) /
64 srtp_bits_per_second(320, &policy) / .01 );
65 printf("Wideband\t%d\t\t\t%e\n", 640,
66- (double) mips * (640 * 8) /
67+ (double) est * (640 * 8) /
68 srtp_bits_per_second(640, &policy) / .02 );
69 }
70
71--
722.13.2
73
diff --git a/meta-multimedia/recipes-support/libsrtp/libsrtp_1.5.2.bb b/meta-multimedia/recipes-support/libsrtp/libsrtp_1.5.2.bb
index 324982843..8abaa1284 100644
--- a/meta-multimedia/recipes-support/libsrtp/libsrtp_1.5.2.bb
+++ b/meta-multimedia/recipes-support/libsrtp/libsrtp_1.5.2.bb
@@ -5,7 +5,9 @@ SECTION = "libs"
5LICENSE = "BSD-3-Clause" 5LICENSE = "BSD-3-Clause"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=15bc16b9d2e305974dde47e733883714" 6LIC_FILES_CHKSUM = "file://LICENSE;md5=15bc16b9d2e305974dde47e733883714"
7 7
8SRC_URI = "https://github.com/cisco/libsrtp/archive/v${PV}.tar.gz;downloadfilename=${BP}.tar.gz" 8SRC_URI = "https://github.com/cisco/libsrtp/archive/v${PV}.tar.gz;downloadfilename=${BP}.tar.gz \
9 file://0001-Rename-conflicting-variable-mips.patch \
10 "
9SRC_URI[md5sum] = "2309aa6027992810a4285b042c71e644" 11SRC_URI[md5sum] = "2309aa6027992810a4285b042c71e644"
10SRC_URI[sha256sum] = "86e1efe353397c0751f6bdd709794143bd1b76494412860f16ff2b6d9c304eda" 12SRC_URI[sha256sum] = "86e1efe353397c0751f6bdd709794143bd1b76494412860f16ff2b6d9c304eda"
11 13