summaryrefslogtreecommitdiffstats
path: root/meta-multimedia
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-04-01 08:02:00 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2017-04-06 13:00:10 +0200
commit401fbd9e50e06e8253135ca783adebebbdad44b1 (patch)
tree7786015fbb14018d9413443aa39acf6cde4bf2d1 /meta-multimedia
parent2ae91ddd68e1b621873baa319eaa05080719dfd1 (diff)
downloadmeta-openembedded-401fbd9e50e06e8253135ca783adebebbdad44b1.tar.gz
vorbis-tools: Fix build with security flags
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-multimedia')
-rw-r--r--meta-multimedia/recipes-multimedia/vorbis-tools/vorbis-tools/0004-Fix-format-error-blocking-compilation-with-hardening.patch26
-rw-r--r--meta-multimedia/recipes-multimedia/vorbis-tools/vorbis-tools_1.4.0.bb1
2 files changed, 27 insertions, 0 deletions
diff --git a/meta-multimedia/recipes-multimedia/vorbis-tools/vorbis-tools/0004-Fix-format-error-blocking-compilation-with-hardening.patch b/meta-multimedia/recipes-multimedia/vorbis-tools/vorbis-tools/0004-Fix-format-error-blocking-compilation-with-hardening.patch
new file mode 100644
index 000000000..111e98ac1
--- /dev/null
+++ b/meta-multimedia/recipes-multimedia/vorbis-tools/vorbis-tools/0004-Fix-format-error-blocking-compilation-with-hardening.patch
@@ -0,0 +1,26 @@
1From: Petter Reinholdtsen <pere@hungry.com>
2Date: Wed, 22 Oct 2014 13:25:21 +0200
3Subject: Fix format error blocking compilation with hardening
4
5Last-Update: 2014-10-22
6Forwarded: no
7
8Enabling hardening refuses to compile code with sprintf() calls
9with no formatting string. Adjust the code to work with hardening.
10---
11 ogg123/status.c | 2 +-
12 1 file changed, 1 insertion(+), 1 deletion(-)
13
14diff --git a/ogg123/status.c b/ogg123/status.c
15index 92b8ff1..ccec389 100644
16--- a/ogg123/status.c
17+++ b/ogg123/status.c
18@@ -148,7 +148,7 @@ int print_statistics_line (stat_format_t stats[])
19
20 switch (stats->type) {
21 case stat_noarg:
22- len += sprintf(str+len, stats->formatstr);
23+ len += sprintf(str+len, "%s", stats->formatstr);
24 break;
25 case stat_intarg:
26 len += sprintf(str+len, stats->formatstr, stats->arg.intarg);
diff --git a/meta-multimedia/recipes-multimedia/vorbis-tools/vorbis-tools_1.4.0.bb b/meta-multimedia/recipes-multimedia/vorbis-tools/vorbis-tools_1.4.0.bb
index 2683555f1..e43cb4032 100644
--- a/meta-multimedia/recipes-multimedia/vorbis-tools/vorbis-tools_1.4.0.bb
+++ b/meta-multimedia/recipes-multimedia/vorbis-tools/vorbis-tools_1.4.0.bb
@@ -12,6 +12,7 @@ DEPENDS = "libogg libvorbis curl libao"
12 12
13SRC_URI = "http://downloads.xiph.org/releases/vorbis/${BP}.tar.gz \ 13SRC_URI = "http://downloads.xiph.org/releases/vorbis/${BP}.tar.gz \
14 file://0001-oggenc-Fix-large-alloca-on-bad-AIFF-input.patch \ 14 file://0001-oggenc-Fix-large-alloca-on-bad-AIFF-input.patch \
15 file://0004-Fix-format-error-blocking-compilation-with-hardening.patch \
15 " 16 "
16 17
17SRC_URI[md5sum] = "567e0fb8d321b2cd7124f8208b8b90e6" 18SRC_URI[md5sum] = "567e0fb8d321b2cd7124f8208b8b90e6"