summaryrefslogtreecommitdiffstats
path: root/meta-multimedia
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-03-22 11:57:26 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2017-04-05 19:31:06 +0200
commit2af18f934cd6764ef87977c8b23a924a5cb7fbf7 (patch)
tree305ad2b200e278cdcefaea02221c997f22cccf36 /meta-multimedia
parent61d1d45d2f34dc57b144300663e8880ac67a01fd (diff)
downloadmeta-openembedded-2af18f934cd6764ef87977c8b23a924a5cb7fbf7.tar.gz
caps: Use c99 int types
Fixes build with musl Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-multimedia')
-rw-r--r--meta-multimedia/recipes-multimedia/caps/caps/0001-basic.h-Use-c99-supported-stdint-types.patch46
-rw-r--r--meta-multimedia/recipes-multimedia/caps/caps_0.9.24.bb8
2 files changed, 50 insertions, 4 deletions
diff --git a/meta-multimedia/recipes-multimedia/caps/caps/0001-basic.h-Use-c99-supported-stdint-types.patch b/meta-multimedia/recipes-multimedia/caps/caps/0001-basic.h-Use-c99-supported-stdint-types.patch
new file mode 100644
index 000000000..1087b0e79
--- /dev/null
+++ b/meta-multimedia/recipes-multimedia/caps/caps/0001-basic.h-Use-c99-supported-stdint-types.patch
@@ -0,0 +1,46 @@
1From a5cea22294a9acb6eed955bd415f562a6cc36482 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Wed, 22 Mar 2017 11:54:23 -0700
4Subject: [PATCH] basic.h: Use c99 supported stdint types
5
6include stdint.h for getting the definitions for int types
7
8Signed-off-by: Khem Raj <raj.khem@gmail.com>
9---
10 basics.h | 17 +++++++++--------
11 1 file changed, 9 insertions(+), 8 deletions(-)
12
13diff --git a/basics.h b/basics.h
14index 643d96e..1dc2fa7 100644
15--- a/basics.h
16+++ b/basics.h
17@@ -46,17 +46,18 @@
18
19 #include <assert.h>
20 #include <stdio.h>
21+#include <stdint.h>
22
23 #include "ladspa.h"
24
25-typedef __int8_t int8;
26-typedef __uint8_t uint8;
27-typedef __int16_t int16;
28-typedef __uint16_t uint16;
29-typedef __int32_t int32;
30-typedef __uint32_t uint32;
31-typedef __int64_t int64;
32-typedef __uint64_t uint64;
33+typedef int8_t int8;
34+typedef uint8_t uint8;
35+typedef int16_t int16;
36+typedef uint16_t uint16;
37+typedef int32_t int32;
38+typedef uint32_t uint32;
39+typedef int64_t int64;
40+typedef uint64_t uint64;
41
42 #define MIN_GAIN 1e-6 /* -120 dB */
43 /* smallest non-denormal 32 bit IEEE float is 1.18e-38 */
44--
452.12.0
46
diff --git a/meta-multimedia/recipes-multimedia/caps/caps_0.9.24.bb b/meta-multimedia/recipes-multimedia/caps/caps_0.9.24.bb
index 3e409e6eb..90a28360c 100644
--- a/meta-multimedia/recipes-multimedia/caps/caps_0.9.24.bb
+++ b/meta-multimedia/recipes-multimedia/caps/caps_0.9.24.bb
@@ -3,10 +3,10 @@ HOMEPAGE = "http://quitte.de/dsp/caps.html"
3LICENSE = "GPL-3" 3LICENSE = "GPL-3"
4LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" 4LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
5 5
6SRC_URI = " \ 6SRC_URI = "http://quitte.de/dsp/${PN}_${PV}.tar.bz2 \
7 http://quitte.de/dsp/${PN}_${PV}.tar.bz2 \ 7 file://Avoid-ambiguity-in-div-invocation.patch \
8 file://Avoid-ambiguity-in-div-invocation.patch \ 8 file://0001-basic.h-Use-c99-supported-stdint-types.patch \
9" 9 "
10 10
11SRC_URI[md5sum] = "c1d634038dcb54702306c0e30cb1c626" 11SRC_URI[md5sum] = "c1d634038dcb54702306c0e30cb1c626"
12SRC_URI[sha256sum] = "f746feba57af316b159f0169de5d78b4fd1064c2c0c8017cb5856b2f22e83f20" 12SRC_URI[sha256sum] = "f746feba57af316b159f0169de5d78b4fd1064c2c0c8017cb5856b2f22e83f20"