diff options
author | Khem Raj <raj.khem@gmail.com> | 2022-08-14 18:51:16 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2022-08-14 18:52:57 -0700 |
commit | fdad7782b92653399b6d459165fb00bcad80e98a (patch) | |
tree | f5274f4622be1fa2c40e15ca06b510125f34ee2a /meta-multimedia | |
parent | c1d5aa46109995c733e29dc6c9fa9efb57749ec0 (diff) | |
download | meta-openembedded-fdad7782b92653399b6d459165fb00bcad80e98a.tar.gz |
libmpd: Fix function returns and casts
Fixes build with clang-15
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-multimedia')
5 files changed, 83 insertions, 12 deletions
diff --git a/meta-multimedia/recipes-multimedia/musicpd/libmpd-11.8.17/glibc-2.20.patch b/meta-multimedia/recipes-multimedia/musicpd/libmpd-11.8.17/glibc-2.20.patch deleted file mode 100644 index 4a2b25cdd..000000000 --- a/meta-multimedia/recipes-multimedia/musicpd/libmpd-11.8.17/glibc-2.20.patch +++ /dev/null | |||
@@ -1,10 +0,0 @@ | |||
1 | --- libmpd-11.8.17/src/libmpd-internal.h.orig 2014-09-30 04:08:50.963292427 +0200 | ||
2 | +++ libmpd-11.8.17/src/libmpd-internal.h 2014-09-30 04:08:30.595292223 +0200 | ||
3 | @@ -21,6 +21,7 @@ | ||
4 | #define __MPD_INTERNAL_LIB_ | ||
5 | |||
6 | #include "libmpdclient.h" | ||
7 | +#include "config.h" | ||
8 | struct _MpdData_real; | ||
9 | |||
10 | typedef struct _MpdData_real { | ||
diff --git a/meta-multimedia/recipes-multimedia/musicpd/libmpd/0001-fix-return-makes-integer-from-pointer-without-a-cast.patch b/meta-multimedia/recipes-multimedia/musicpd/libmpd/0001-fix-return-makes-integer-from-pointer-without-a-cast.patch new file mode 100644 index 000000000..dd50a71f7 --- /dev/null +++ b/meta-multimedia/recipes-multimedia/musicpd/libmpd/0001-fix-return-makes-integer-from-pointer-without-a-cast.patch | |||
@@ -0,0 +1,27 @@ | |||
1 | From f0f8cc5ac6f1fa9cb5c98cb0b3688f44c64fa8ee Mon Sep 17 00:00:00 2001 | ||
2 | From: Christian Hesse <mail@eworm.de> | ||
3 | Date: Wed, 19 Jul 2017 14:22:48 +0200 | ||
4 | Subject: [PATCH 1/3] fix return makes integer from pointer without a cast | ||
5 | |||
6 | Upstream-Status: Pending [https://github.com/archlinux/svntogit-packages/tree/packages/libmpd/trunk] | ||
7 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
8 | --- | ||
9 | src/libmpd-playlist.c | 2 +- | ||
10 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
11 | |||
12 | diff --git a/src/libmpd-playlist.c b/src/libmpd-playlist.c | ||
13 | index c3c30ec..64c64ea 100644 | ||
14 | --- a/src/libmpd-playlist.c | ||
15 | +++ b/src/libmpd-playlist.c | ||
16 | @@ -780,7 +780,7 @@ int mpd_playlist_load(MpdObj *mi, const char *path) | ||
17 | if(mpd_lock_conn(mi)) | ||
18 | { | ||
19 | debug_printf(DEBUG_ERROR,"lock failed\n"); | ||
20 | - return NULL; | ||
21 | + return MPD_LOCK_FAILED; | ||
22 | } | ||
23 | mpd_sendLoadCommand(mi->connection,path); | ||
24 | mpd_finishCommand(mi->connection); | ||
25 | -- | ||
26 | 2.37.2 | ||
27 | |||
diff --git a/meta-multimedia/recipes-multimedia/musicpd/libmpd/0002-fix-comparison-between-pointer-and-zero-character-co.patch b/meta-multimedia/recipes-multimedia/musicpd/libmpd/0002-fix-comparison-between-pointer-and-zero-character-co.patch new file mode 100644 index 000000000..66d921ed6 --- /dev/null +++ b/meta-multimedia/recipes-multimedia/musicpd/libmpd/0002-fix-comparison-between-pointer-and-zero-character-co.patch | |||
@@ -0,0 +1,27 @@ | |||
1 | From fa3b3b3759986171a85230ba8b53764beafdb37f Mon Sep 17 00:00:00 2001 | ||
2 | From: Christian Hesse <mail@eworm.de> | ||
3 | Date: Wed, 19 Jul 2017 14:40:00 +0200 | ||
4 | Subject: [PATCH 2/3] fix comparison between pointer and zero character constant | ||
5 | |||
6 | Upstream-Status: Pending [https://github.com/archlinux/svntogit-packages/tree/packages/libmpd/trunk] | ||
7 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
8 | --- | ||
9 | src/libmpd-database.c | 2 +- | ||
10 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
11 | |||
12 | diff --git a/src/libmpd-database.c b/src/libmpd-database.c | ||
13 | index 2480d5e..edafc0a 100644 | ||
14 | --- a/src/libmpd-database.c | ||
15 | +++ b/src/libmpd-database.c | ||
16 | @@ -961,7 +961,7 @@ MpdData * mpd_database_get_directory_recursive(MpdObj *mi, const char *path) | ||
17 | debug_printf(DEBUG_WARNING,"not connected\n"); | ||
18 | return NULL; | ||
19 | } | ||
20 | - if(path == '\0' || path[0] == '\0') | ||
21 | + if(path == NULL || path[0] == '\0') | ||
22 | { | ||
23 | debug_printf(DEBUG_ERROR, "argumant invalid\n"); | ||
24 | return NULL; | ||
25 | -- | ||
26 | 2.37.2 | ||
27 | |||
diff --git a/meta-multimedia/recipes-multimedia/musicpd/libmpd/0003-include-config.h.patch b/meta-multimedia/recipes-multimedia/musicpd/libmpd/0003-include-config.h.patch new file mode 100644 index 000000000..805204c0b --- /dev/null +++ b/meta-multimedia/recipes-multimedia/musicpd/libmpd/0003-include-config.h.patch | |||
@@ -0,0 +1,26 @@ | |||
1 | From 67eae4f20af9aaaf693025d95a05527a2c1fed1a Mon Sep 17 00:00:00 2001 | ||
2 | From: Christian Hesse <mail@eworm.de> | ||
3 | Date: Wed, 19 Jul 2017 14:38:43 +0200 | ||
4 | Subject: [PATCH 3/3] include config.h | ||
5 | |||
6 | Upstream-Status: Pending [https://github.com/archlinux/svntogit-packages/tree/packages/libmpd/trunk] | ||
7 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
8 | --- | ||
9 | src/libmpd-strfsong.c | 1 + | ||
10 | 1 file changed, 1 insertion(+) | ||
11 | |||
12 | diff --git a/src/libmpd-strfsong.c b/src/libmpd-strfsong.c | ||
13 | index 7d47bed..76fa3ff 100644 | ||
14 | --- a/src/libmpd-strfsong.c | ||
15 | +++ b/src/libmpd-strfsong.c | ||
16 | @@ -28,6 +28,7 @@ | ||
17 | #include <unistd.h> | ||
18 | #include <string.h> | ||
19 | #include <glib.h> | ||
20 | +#include <config.h> | ||
21 | #include "libmpd.h" | ||
22 | #include "libmpd-internal.h" | ||
23 | |||
24 | -- | ||
25 | 2.37.2 | ||
26 | |||
diff --git a/meta-multimedia/recipes-multimedia/musicpd/libmpd_11.8.17.bb b/meta-multimedia/recipes-multimedia/musicpd/libmpd_11.8.17.bb index d5ee395af..3a4b3aa1a 100644 --- a/meta-multimedia/recipes-multimedia/musicpd/libmpd_11.8.17.bb +++ b/meta-multimedia/recipes-multimedia/musicpd/libmpd_11.8.17.bb | |||
@@ -5,9 +5,10 @@ HOMEPAGE ="http://sourceforge.net/projects/musicpd" | |||
5 | DEPENDS = "glib-2.0" | 5 | DEPENDS = "glib-2.0" |
6 | 6 | ||
7 | SRC_URI = "http://www.musicpd.org/download/${BPN}/${PV}/${BP}.tar.gz \ | 7 | SRC_URI = "http://www.musicpd.org/download/${BPN}/${PV}/${BP}.tar.gz \ |
8 | file://glibc-2.20.patch \ | 8 | file://0001-fix-return-makes-integer-from-pointer-without-a-cast.patch \ |
9 | file://0002-fix-comparison-between-pointer-and-zero-character-co.patch \ | ||
10 | file://0003-include-config.h.patch \ | ||
9 | " | 11 | " |
10 | SRC_URI[md5sum] = "5ae3d87467d52aef3345407adb0a2488" | ||
11 | SRC_URI[sha256sum] = "fe20326b0d10641f71c4673fae637bf9222a96e1712f71f170fca2fc34bf7a83" | 12 | SRC_URI[sha256sum] = "fe20326b0d10641f71c4673fae637bf9222a96e1712f71f170fca2fc34bf7a83" |
12 | 13 | ||
13 | inherit autotools pkgconfig | 14 | inherit autotools pkgconfig |