diff options
author | Martin Jansa <Martin.Jansa@gmail.com> | 2017-04-05 19:35:16 +0200 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2017-04-05 19:36:45 +0200 |
commit | cdb428e7c49899675ee7b7a43f6cecdb5b4c2546 (patch) | |
tree | 42c4f0752df5a0bae2c3aeec8362faa029adc792 /meta-multimedia | |
parent | 2af18f934cd6764ef87977c8b23a924a5cb7fbf7 (diff) | |
download | meta-openembedded-cdb428e7c49899675ee7b7a43f6cecdb5b4c2546.tar.gz |
recipes: add removal date to PNBLACKLIST messages
* based on discussion in pndeprecated thread:
https://patchwork.openembedded.org/patch/137573/
update the messages to warn possible users that the
recipe will be removed before the end of the next development
cycle (before Yocto 2.4 is released).
* updated with:
sed -i 's/^\(PNBLACKLIST.*".*\)"/\1 - the recipe will be removed on 2017-09-01 unless the issue is fixed"/g' `git grep PNBLACKLIST | sed 's/:.*//g' | sort -u | xargs`
* then noticed couple recipes being blacklisted only based on
DISTRO_FEATURES, so removed those:
meta-networking/recipes-support/lksctp-tools/lksctp-tools_1.0.17.bb
meta-oe/recipes-connectivity/bluez/bluez-hcidump_2.5.bb
meta-oe/recipes-connectivity/bluez/bluez4_4.101.bb
meta-oe/recipes-connectivity/bluez/gst-plugin-bluetooth_4.101.bb
meta-oe/recipes-navigation/foxtrotgps/foxtrotgps_1.1.1.bb
meta-oe/recipes-navigation/gypsy/gypsy.inc
meta-oe/recipes-navigation/navit/navit.inc
meta-oe/recipes-support/opensync/libsyncml_0.5.4.bb
* if it isn't fixed by this date, it's fair game to be removed
whenever someone gets around to i
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-multimedia')
13 files changed, 14 insertions, 14 deletions
diff --git a/meta-multimedia/recipes-connectivity/gupnp/gupnp-igd_0.2.2.bb b/meta-multimedia/recipes-connectivity/gupnp/gupnp-igd_0.2.2.bb index 97680bf39..440e8262d 100644 --- a/meta-multimedia/recipes-connectivity/gupnp/gupnp-igd_0.2.2.bb +++ b/meta-multimedia/recipes-connectivity/gupnp/gupnp-igd_0.2.2.bb | |||
@@ -13,4 +13,4 @@ inherit autotools pkgconfig gtk-doc gobject-introspection | |||
13 | 13 | ||
14 | EXTRA_OECONF = "--disable-python" | 14 | EXTRA_OECONF = "--disable-python" |
15 | 15 | ||
16 | PNBLACKLIST[gupnp-igd] ?= "Fails to build with RSS http://errors.yoctoproject.org/Errors/Details/130645/" | 16 | PNBLACKLIST[gupnp-igd] ?= "Fails to build with RSS http://errors.yoctoproject.org/Errors/Details/130645/ - the recipe will be removed on 2017-09-01 unless the issue is fixed" |
diff --git a/meta-multimedia/recipes-connectivity/gupnp/gupnp-tools_0.8.10.bb b/meta-multimedia/recipes-connectivity/gupnp/gupnp-tools_0.8.10.bb index d42e3ff9c..ba7f8257f 100644 --- a/meta-multimedia/recipes-connectivity/gupnp/gupnp-tools_0.8.10.bb +++ b/meta-multimedia/recipes-connectivity/gupnp/gupnp-tools_0.8.10.bb | |||
@@ -11,4 +11,4 @@ SRC_URI[sha256sum] = "592c53289ff1cd70e676405c56ca87b28d2da37a385d34a3bb9b944ba9 | |||
11 | 11 | ||
12 | inherit autotools pkgconfig | 12 | inherit autotools pkgconfig |
13 | 13 | ||
14 | PNBLACKLIST[gupnp-tools] ?= "Fails to build with RSS http://errors.yoctoproject.org/Errors/Details/130670/" | 14 | PNBLACKLIST[gupnp-tools] ?= "Fails to build with RSS http://errors.yoctoproject.org/Errors/Details/130670/ - the recipe will be removed on 2017-09-01 unless the issue is fixed" |
diff --git a/meta-multimedia/recipes-dvb/dvb-apps/dvb-apps_1.1.1.bb b/meta-multimedia/recipes-dvb/dvb-apps/dvb-apps_1.1.1.bb index 29e739675..4a7ed9a6e 100644 --- a/meta-multimedia/recipes-dvb/dvb-apps/dvb-apps_1.1.1.bb +++ b/meta-multimedia/recipes-dvb/dvb-apps/dvb-apps_1.1.1.bb | |||
@@ -133,4 +133,4 @@ RDEPENDS_dvb-apps =+ "libdvbapi libdvbcfg libdvbsec libdvben50221 libucsi" | |||
133 | RDEPENDS_dvb-femon =+ "libdvbapi" | 133 | RDEPENDS_dvb-femon =+ "libdvbapi" |
134 | RDEPENDS_dvbnet =+ "libdvbapi" | 134 | RDEPENDS_dvbnet =+ "libdvbapi" |
135 | 135 | ||
136 | PNBLACKLIST[dvb-apps] ?= "Fails to build with RSS http://errors.yoctoproject.org/Errors/Details/130603/" | 136 | PNBLACKLIST[dvb-apps] ?= "Fails to build with RSS http://errors.yoctoproject.org/Errors/Details/130603/ - the recipe will be removed on 2017-09-01 unless the issue is fixed" |
diff --git a/meta-multimedia/recipes-dvb/tvheadend/tvheadend_git.bb b/meta-multimedia/recipes-dvb/tvheadend/tvheadend_git.bb index 06dbce324..3b73549d2 100644 --- a/meta-multimedia/recipes-dvb/tvheadend/tvheadend_git.bb +++ b/meta-multimedia/recipes-dvb/tvheadend/tvheadend_git.bb | |||
@@ -40,4 +40,4 @@ FILES_${PN} += "${datadir}/${BPN}" | |||
40 | 40 | ||
41 | RDEPENDS_${PN} += "libdvben50221 libucsi libdvbapi" | 41 | RDEPENDS_${PN} += "libdvben50221 libucsi libdvbapi" |
42 | 42 | ||
43 | PNBLACKLIST[tvheadend] ?= "Depends on blacklisted dvb-apps" | 43 | PNBLACKLIST[tvheadend] ?= "Depends on blacklisted dvb-apps - the recipe will be removed on 2017-09-01 unless the issue is fixed" |
diff --git a/meta-multimedia/recipes-mediacenter/kodi/kodi-addon-pvr-hts_git.bb b/meta-multimedia/recipes-mediacenter/kodi/kodi-addon-pvr-hts_git.bb index adff73bb9..7cafebfa2 100644 --- a/meta-multimedia/recipes-mediacenter/kodi/kodi-addon-pvr-hts_git.bb +++ b/meta-multimedia/recipes-mediacenter/kodi/kodi-addon-pvr-hts_git.bb | |||
@@ -54,4 +54,4 @@ INSANE_SKIP_${PN} = "dev-so" | |||
54 | FILES_${PN} += "${datadir}/kodi" | 54 | FILES_${PN} += "${datadir}/kodi" |
55 | FILES_${PN}-dbg += "${datadir}/kodi/addons/*/.debug/" | 55 | FILES_${PN}-dbg += "${datadir}/kodi/addons/*/.debug/" |
56 | 56 | ||
57 | PNBLACKLIST[kodi-addon-pvr-hts] ?= "Depends on blacklisted kodi" | 57 | PNBLACKLIST[kodi-addon-pvr-hts] ?= "Depends on blacklisted kodi - the recipe will be removed on 2017-09-01 unless the issue is fixed" |
diff --git a/meta-multimedia/recipes-mediacenter/kodi/kodi-platform_git.bb b/meta-multimedia/recipes-mediacenter/kodi/kodi-platform_git.bb index ea739c2d2..0b554ef6a 100644 --- a/meta-multimedia/recipes-mediacenter/kodi/kodi-platform_git.bb +++ b/meta-multimedia/recipes-mediacenter/kodi/kodi-platform_git.bb | |||
@@ -36,4 +36,4 @@ do_compile_prepend() { | |||
36 | RPROVIDES_${PN} += "libkodiplatform" | 36 | RPROVIDES_${PN} += "libkodiplatform" |
37 | FILES_${PN}-dev += "${libdir}/*platform" | 37 | FILES_${PN}-dev += "${libdir}/*platform" |
38 | 38 | ||
39 | PNBLACKLIST[kodi-platform] ?= "Depends on blacklisted kodi" | 39 | PNBLACKLIST[kodi-platform] ?= "Depends on blacklisted kodi - the recipe will be removed on 2017-09-01 unless the issue is fixed" |
diff --git a/meta-multimedia/recipes-mediacenter/kodi/kodi-startup.bb b/meta-multimedia/recipes-mediacenter/kodi/kodi-startup.bb index 49e0b4dc8..47e8f38e9 100644 --- a/meta-multimedia/recipes-mediacenter/kodi/kodi-startup.bb +++ b/meta-multimedia/recipes-mediacenter/kodi/kodi-startup.bb | |||
@@ -19,6 +19,6 @@ SYSTEMD_SERVICE_${PN} = "kodi.service" | |||
19 | 19 | ||
20 | RDEPENDS_${PN} += "xinit kodi" | 20 | RDEPENDS_${PN} += "xinit kodi" |
21 | 21 | ||
22 | PNBLACKLIST[kodi-startup] ?= "Runtime depends on blacklisted kodi" | 22 | PNBLACKLIST[kodi-startup] ?= "Runtime depends on blacklisted kodi - the recipe will be removed on 2017-09-01 unless the issue is fixed" |
23 | 23 | ||
24 | PNBLACKLIST[kodi-startup] ?= "Runtime depends on blacklisted kodi-startup-dev" | 24 | PNBLACKLIST[kodi-startup] ?= "Runtime depends on blacklisted kodi-startup-dev - the recipe will be removed on 2017-09-01 unless the issue is fixed" |
diff --git a/meta-multimedia/recipes-mediacenter/kodi/kodi_17.bb b/meta-multimedia/recipes-mediacenter/kodi/kodi_17.bb index e3a117e7a..d6e19617d 100644 --- a/meta-multimedia/recipes-mediacenter/kodi/kodi_17.bb +++ b/meta-multimedia/recipes-mediacenter/kodi/kodi_17.bb | |||
@@ -193,4 +193,4 @@ RPROVIDES_${PN} += "xbmc" | |||
193 | TOOLCHAIN = "gcc" | 193 | TOOLCHAIN = "gcc" |
194 | 194 | ||
195 | 195 | ||
196 | PNBLACKLIST[kodi] ?= "Depends on blacklisted libsdl-mixer" | 196 | PNBLACKLIST[kodi] ?= "Depends on blacklisted libsdl-mixer - the recipe will be removed on 2017-09-01 unless the issue is fixed" |
diff --git a/meta-multimedia/recipes-mkv/mkvtoolnix/mkvtoolnix_git.bb b/meta-multimedia/recipes-mkv/mkvtoolnix/mkvtoolnix_git.bb index fe44ccf24..8a142645c 100644 --- a/meta-multimedia/recipes-mkv/mkvtoolnix/mkvtoolnix_git.bb +++ b/meta-multimedia/recipes-mkv/mkvtoolnix/mkvtoolnix_git.bb | |||
@@ -54,4 +54,4 @@ do_install() { | |||
54 | # | src/common/../../lib/boost/utf8_codecvt_facet/utf8_codecvt_facet.cpp:174:5: error: 'int mtx::utf8_codecvt_facet::do_length' is not a static data member of 'struct mtx::utf8_codecvt_facet' | 54 | # | src/common/../../lib/boost/utf8_codecvt_facet/utf8_codecvt_facet.cpp:174:5: error: 'int mtx::utf8_codecvt_facet::do_length' is not a static data member of 'struct mtx::utf8_codecvt_facet' |
55 | # | BOOST_CODECVT_DO_LENGTH_CONST std::mbstate_t &, | 55 | # | BOOST_CODECVT_DO_LENGTH_CONST std::mbstate_t &, |
56 | # | ^ | 56 | # | ^ |
57 | PNBLACKLIST[mkvtoolnix] ?= "BROKEN: Failx to build with gcc-5" | 57 | PNBLACKLIST[mkvtoolnix] ?= "BROKEN: Failx to build with gcc-5 - the recipe will be removed on 2017-09-01 unless the issue is fixed" |
diff --git a/meta-multimedia/recipes-multimedia/coriander/coriander_2.0.2.bb b/meta-multimedia/recipes-multimedia/coriander/coriander_2.0.2.bb index a9f52cadb..1ddd9aab6 100755 --- a/meta-multimedia/recipes-multimedia/coriander/coriander_2.0.2.bb +++ b/meta-multimedia/recipes-multimedia/coriander/coriander_2.0.2.bb | |||
@@ -5,7 +5,7 @@ LICENSE = "GPL-3.0" | |||
5 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" | 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" |
6 | DEPENDS = "gtk+ libgnomeui libraw1394 libdc1394 libxv tiff" | 6 | DEPENDS = "gtk+ libgnomeui libraw1394 libdc1394 libxv tiff" |
7 | 7 | ||
8 | PNBLACKLIST[coriander] ?= "BROKEN: fails to use SDL probably because libsdl-config was removed, error: unknown type name 'SDL_Overlay'" | 8 | PNBLACKLIST[coriander] ?= "BROKEN: fails to use SDL probably because libsdl-config was removed, error: unknown type name 'SDL_Overlay' - the recipe will be removed on 2017-09-01 unless the issue is fixed" |
9 | 9 | ||
10 | SRC_URI = "${SOURCEFORGE_MIRROR}/project/${BPN}/coriander-2/${PV}/${BP}.tar.gz \ | 10 | SRC_URI = "${SOURCEFORGE_MIRROR}/project/${BPN}/coriander-2/${PV}/${BP}.tar.gz \ |
11 | file://cross-compile.patch \ | 11 | file://cross-compile.patch \ |
diff --git a/meta-multimedia/recipes-multimedia/dleyna/renderer-service-upnp_0.3.0.bb b/meta-multimedia/recipes-multimedia/dleyna/renderer-service-upnp_0.3.0.bb index 68d59faca..4d06d2c68 100644 --- a/meta-multimedia/recipes-multimedia/dleyna/renderer-service-upnp_0.3.0.bb +++ b/meta-multimedia/recipes-multimedia/dleyna/renderer-service-upnp_0.3.0.bb | |||
@@ -5,7 +5,7 @@ LICENSE = "LGPLv2.1" | |||
5 | LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c \ | 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c \ |
6 | file://src/renderer-service-upnp.c;beginline=1;endline=21;md5=c25c3082684eb4ca87474b7528c6dc15" | 6 | file://src/renderer-service-upnp.c;beginline=1;endline=21;md5=c25c3082684eb4ca87474b7528c6dc15" |
7 | 7 | ||
8 | PNBLACKLIST[renderer-service-upnp] ?= "BROKEN: doesn't build with B!=S (trying to install rendererconsole.py from ${B} instead of ${S})" | 8 | PNBLACKLIST[renderer-service-upnp] ?= "BROKEN: doesn't build with B!=S (trying to install rendererconsole.py from ${B} instead of ${S}) - the recipe will be removed on 2017-09-01 unless the issue is fixed" |
9 | 9 | ||
10 | DEPENDS = "dbus glib-2.0 gssdp gupnp gupnp-av gupnp-dlna libsoup-2.4" | 10 | DEPENDS = "dbus glib-2.0 gssdp gupnp gupnp-av gupnp-dlna libsoup-2.4" |
11 | 11 | ||
diff --git a/meta-multimedia/recipes-multimedia/gstreamer-0.10/gst-ffmpeg_0.10.13.bb b/meta-multimedia/recipes-multimedia/gstreamer-0.10/gst-ffmpeg_0.10.13.bb index 891b10ca4..ca19fd69b 100644 --- a/meta-multimedia/recipes-multimedia/gstreamer-0.10/gst-ffmpeg_0.10.13.bb +++ b/meta-multimedia/recipes-multimedia/gstreamer-0.10/gst-ffmpeg_0.10.13.bb | |||
@@ -100,4 +100,4 @@ FILES_${PN}-dev += "${libdir}/gstreamer-0.10/*.la" | |||
100 | FILES_${PN}-staticdev += "${libdir}/gstreamer-0.10/*.a" | 100 | FILES_${PN}-staticdev += "${libdir}/gstreamer-0.10/*.a" |
101 | 101 | ||
102 | # http://errors.yoctoproject.org/Errors/Details/40736/ | 102 | # http://errors.yoctoproject.org/Errors/Details/40736/ |
103 | PNBLACKLIST[gst-ffmpeg] ?= "Not compatible with currently used ffmpeg 3" | 103 | PNBLACKLIST[gst-ffmpeg] ?= "Not compatible with currently used ffmpeg 3 - the recipe will be removed on 2017-09-01 unless the issue is fixed" |
diff --git a/meta-multimedia/recipes-multimedia/gstreamer/gst123_0.3.1.bb b/meta-multimedia/recipes-multimedia/gstreamer/gst123_0.3.1.bb index 47f1d9f7b..9fe1bc6b6 100644 --- a/meta-multimedia/recipes-multimedia/gstreamer/gst123_0.3.1.bb +++ b/meta-multimedia/recipes-multimedia/gstreamer/gst123_0.3.1.bb | |||
@@ -14,4 +14,4 @@ SRC_URI[sha256sum] = "89d1de025eca0466c125dcd6a11b64341bdf98ee4c03c3e5a12321d77c | |||
14 | 14 | ||
15 | inherit autotools | 15 | inherit autotools |
16 | 16 | ||
17 | PNBLACKLIST[gst123] ?= "gst123 is still "sometimes" using wrong sysroot" | 17 | PNBLACKLIST[gst123] ?= "gst123 is still "sometimes" using wrong sysroot - the recipe will be removed on 2017-09-01 unless the issue is fixed" |