diff options
author | Khem Raj <raj.khem@gmail.com> | 2023-11-11 10:49:55 -0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2023-11-11 10:54:01 -0800 |
commit | 28de6640a37837e75d4e4b56e74d93347113d2d5 (patch) | |
tree | 3b21ff8a88a446fdb86d0b1f666dd6c2cf14dc57 /meta-multimedia | |
parent | d52dc5b9f33d952d4a9728308dab4df74f1eb873 (diff) | |
download | meta-openembedded-28de6640a37837e75d4e4b56e74d93347113d2d5.tar.gz |
rygel: Upgrade to 0.40.4 -> 0.42.4
Switch to using libsoup-3 and meson for build system
Disable media-export plugin, since it fails to build
rygel-media-export-dvd-parser.vala:91.27-91.39: error: The name `uri_copy' does not exist in the context of `Soup' (libsoup-3.0)
| 91 | var new_uri = Soup.uri_copy(file_uri,
| | ^~~~~~~~~~~~~
| libsoup-3.0.vapi:4.1-4.14: note: `Soup' was declared here
| 4 | namespace Soup {
| | ^~~~~~~~~~~~~~
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-multimedia')
-rw-r--r-- | meta-multimedia/recipes-connectivity/rygel/rygel_0.42.4.bb (renamed from meta-multimedia/recipes-connectivity/rygel/rygel_0.40.4.bb) | 10 |
1 files changed, 5 insertions, 5 deletions
diff --git a/meta-multimedia/recipes-connectivity/rygel/rygel_0.40.4.bb b/meta-multimedia/recipes-connectivity/rygel/rygel_0.42.4.bb index a5df37637..966229639 100644 --- a/meta-multimedia/recipes-connectivity/rygel/rygel_0.40.4.bb +++ b/meta-multimedia/recipes-connectivity/rygel/rygel_0.42.4.bb | |||
@@ -9,18 +9,18 @@ LICENSE = "LGPL-2.1-only" | |||
9 | LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c" | 9 | LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c" |
10 | 10 | ||
11 | DEPENDS = "libxml2 glib-2.0 gssdp gupnp gupnp-av gupnp-dlna gstreamer1.0 \ | 11 | DEPENDS = "libxml2 glib-2.0 gssdp gupnp gupnp-av gupnp-dlna gstreamer1.0 \ |
12 | gstreamer1.0-plugins-base libgee libsoup-2.4 libmediaart-2.0 \ | 12 | gstreamer1.0-plugins-base libgee libsoup libmediaart-2.0 \ |
13 | libunistring sqlite3 intltool-native gst-editing-services" | 13 | libunistring sqlite3 intltool-native gst-editing-services" |
14 | 14 | ||
15 | RDEPENDS:${PN} = "gstreamer1.0-plugins-base-playback shared-mime-info" | 15 | RDEPENDS:${PN} = "gstreamer1.0-plugins-base-playback shared-mime-info" |
16 | RRECOMMENDS:${PN} = "rygel-plugin-media-export" | 16 | RRECOMMENDS:${PN} = "rygel-plugin-media-export" |
17 | 17 | ||
18 | inherit gnomebase features_check vala gobject-introspection gettext systemd meson | 18 | inherit gnomebase features_check vala gobject-introspection gettext systemd |
19 | 19 | ||
20 | # gobject-introspection is mandatory for libmediaart-2.0 and cannot be configured | 20 | # gobject-introspection is mandatory for libmediaart-2.0 and cannot be configured |
21 | REQUIRED_DISTRO_FEATURES = "gobject-introspection-data" | 21 | REQUIRED_DISTRO_FEATURES = "gobject-introspection-data" |
22 | 22 | ||
23 | SRC_URI[archive.sha256sum] = "736d8adbe8615f6cbc8fcfff9845dc985fd10e16629da236b4b52dbedf0a348b" | 23 | SRC_URI[archive.sha256sum] = "6310dfaa2d332b66119b9b020fad6a4bd27d9bc61faf780ca5ca0b62813303f7" |
24 | 24 | ||
25 | GIR_MESON_ENABLE_FLAG = 'enabled' | 25 | GIR_MESON_ENABLE_FLAG = 'enabled' |
26 | GIR_MESON_DISABLE_FLAG = 'disabled' | 26 | GIR_MESON_DISABLE_FLAG = 'disabled' |
@@ -28,7 +28,7 @@ GIR_MESON_DISABLE_FLAG = 'disabled' | |||
28 | EXTRA_OEMESON = "-Dengines=gstreamer -Dplugins=${@strip_comma('${RYGEL_PLUGINS}')}" | 28 | EXTRA_OEMESON = "-Dengines=gstreamer -Dplugins=${@strip_comma('${RYGEL_PLUGINS}')}" |
29 | PACKAGECONFIG:append = "${@bb.utils.contains("DISTRO_FEATURES", "x11", " gtk+3", "", d)}" | 29 | PACKAGECONFIG:append = "${@bb.utils.contains("DISTRO_FEATURES", "x11", " gtk+3", "", d)}" |
30 | 30 | ||
31 | PACKAGECONFIG ?= "external mpris ruih media-export gst-launch" | 31 | PACKAGECONFIG ?= "external mpris ruih gst-launch" |
32 | 32 | ||
33 | PACKAGECONFIG[external] = "" | 33 | PACKAGECONFIG[external] = "" |
34 | PACKAGECONFIG[mpris] = "" | 34 | PACKAGECONFIG[mpris] = "" |
@@ -49,7 +49,7 @@ RYGEL_PLUGINS:append ="${@bb.utils.contains('PACKAGECONFIG', 'media-export', ',m | |||
49 | RYGEL_PLUGINS:append ="${@bb.utils.contains('PACKAGECONFIG', 'tracker3', ',tracker3', '', d)}" | 49 | RYGEL_PLUGINS:append ="${@bb.utils.contains('PACKAGECONFIG', 'tracker3', ',tracker3', '', d)}" |
50 | RYGEL_PLUGINS:append ="${@bb.utils.contains('PACKAGECONFIG', 'playbin', ',playbin', '', d)}" | 50 | RYGEL_PLUGINS:append ="${@bb.utils.contains('PACKAGECONFIG', 'playbin', ',playbin', '', d)}" |
51 | 51 | ||
52 | LIBV = "2.6" | 52 | LIBV = "2.8" |
53 | 53 | ||
54 | CFLAGS:append:toolchain-clang = " -Wno-error=int-conversion" | 54 | CFLAGS:append:toolchain-clang = " -Wno-error=int-conversion" |
55 | 55 | ||