diff options
author | Markus Volk <f_l_k@t-online.de> | 2022-12-26 07:14:24 +0100 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2022-12-27 09:55:18 -0800 |
commit | 26b9c29fb86b5aa98cab2c2d5015c5210876f1da (patch) | |
tree | 8295b86372ba83541c3d58d41984ce24fb49af28 /meta-multimedia | |
parent | 4a3313094a07f57019b6a1eb7776eeec4690a05f (diff) | |
download | meta-openembedded-26b9c29fb86b5aa98cab2c2d5015c5210876f1da.tar.gz |
wireplumber: update 0.4.12 -> 0.4.13
- add PACKAGECONFIG option to enable dbus support
Release 0.4.13
Additions:
Added bluetooth SCO (HSP/HFP) hardware offload support, together with an example script that enables this functionality on the PinePhone
Encoded audio (mp3, aac, etc...) can now be passed through, if this mode is supported by both the application and the device
The v4l2 monitor now also respects the node.disabled and device.disabled properties inside rules
Added "Firefox Developer Edition" to the list of apps that are allowed to trigger a bluetooth profile auto-switch (#381)
Added support in the portal access script to allow newly plugged cameras to be immediately visible to the portal apps
Fixes:
Worked around an issue that would prevent streams from properly linking when using effects software like EasyEffects and JamesDSP (!450)
Fixed destroying pavucontrol-qt monitor streams after the node that was being monitored is destroyed (#388)
Fixed a crash in the alsa.lua monitor that could happen when a disabled device was removed and re-added (#361)
Fixed a rare crash in the metadata object (#382)
Fixed a bug where a restored node target would override the node target set by the application on the node's properties (#335)
Packaging:
Added build options to compile wireplumber's library, daemon and tools independently
Added a build option to disable unit tests that require the dbus daemon
Stopped using fakesink/fakesrc in the unit tests to be able to run them on default pipewire installations. Compiling the spa test plugin is no longer necessary
Added pkg-config and header information in the gir file
Signed-off-by: Markus Volk <f_l_k@t-online.de>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-multimedia')
-rw-r--r-- | meta-multimedia/recipes-multimedia/wireplumber/wireplumber_0.4.13.bb (renamed from meta-multimedia/recipes-multimedia/wireplumber/wireplumber_0.4.12.bb) | 18 |
1 files changed, 10 insertions, 8 deletions
diff --git a/meta-multimedia/recipes-multimedia/wireplumber/wireplumber_0.4.12.bb b/meta-multimedia/recipes-multimedia/wireplumber/wireplumber_0.4.13.bb index d80d9348a..5277626fa 100644 --- a/meta-multimedia/recipes-multimedia/wireplumber/wireplumber_0.4.12.bb +++ b/meta-multimedia/recipes-multimedia/wireplumber/wireplumber_0.4.13.bb | |||
@@ -11,10 +11,11 @@ DEPENDS = "glib-2.0 glib-2.0-native lua pipewire \ | |||
11 | ${@bb.utils.contains("DISTRO_FEATURES", "gobject-introspection-data", "python3-native python3-lxml-native doxygen-native", "", d)} \ | 11 | ${@bb.utils.contains("DISTRO_FEATURES", "gobject-introspection-data", "python3-native python3-lxml-native doxygen-native", "", d)} \ |
12 | " | 12 | " |
13 | 13 | ||
14 | SRCREV = "6f6e5df9c1b223907efa8dcbfcd538821d0dabc4" | 14 | SRCREV = "7cb1b8b92e96ebd1b7e632cda32715fed713d333" |
15 | SRC_URI = "git://gitlab.freedesktop.org/pipewire/wireplumber.git;branch=master;protocol=https \ | 15 | SRC_URI = " \ |
16 | file://90-OE-disable-session-dbus-dependent-features.lua \ | 16 | git://gitlab.freedesktop.org/pipewire/wireplumber.git;branch=master;protocol=https \ |
17 | " | 17 | file://90-OE-disable-session-dbus-dependent-features.lua \ |
18 | " | ||
18 | 19 | ||
19 | S = "${WORKDIR}/git" | 20 | S = "${WORKDIR}/git" |
20 | 21 | ||
@@ -45,18 +46,19 @@ PACKAGECONFIG[systemd-system-service] = "-Dsystemd-system-service=true,-Dsystemd | |||
45 | # files to rootfs but not enable them as systemd.bbclass | 46 | # files to rootfs but not enable them as systemd.bbclass |
46 | # currently lacks the feature of enabling user services. | 47 | # currently lacks the feature of enabling user services. |
47 | PACKAGECONFIG[systemd-user-service] = "-Dsystemd-user-service=true,-Dsystemd-user-service=false,systemd" | 48 | PACKAGECONFIG[systemd-user-service] = "-Dsystemd-user-service=true,-Dsystemd-user-service=false,systemd" |
49 | PACKAGECONFIG[dbus] = "" | ||
48 | 50 | ||
49 | PACKAGESPLITFUNCS:prepend = " split_dynamic_packages " | 51 | PACKAGESPLITFUNCS:prepend = " split_dynamic_packages " |
50 | PACKAGESPLITFUNCS:append = " set_dynamic_metapkg_rdepends " | 52 | PACKAGESPLITFUNCS:append = " set_dynamic_metapkg_rdepends " |
51 | 53 | ||
52 | WP_MODULE_SUBDIR = "wireplumber-0.4" | 54 | WP_MODULE_SUBDIR = "wireplumber-0.4" |
53 | 55 | ||
54 | add_custom_lua_config_scripts() { | 56 | do_install:append() { |
55 | install -m 0644 ${WORKDIR}/90-OE-disable-session-dbus-dependent-features.lua ${D}${datadir}/wireplumber/main.lua.d | 57 | if ${@bb.utils.contains('PACKAGECONFIG', 'dbus', 'false', 'true', d)}; then |
58 | install -m 0644 ${WORKDIR}/90-OE-disable-session-dbus-dependent-features.lua ${D}${datadir}/wireplumber/main.lua.d | ||
59 | fi | ||
56 | } | 60 | } |
57 | 61 | ||
58 | do_install[postfuncs] += "add_custom_lua_config_scripts" | ||
59 | |||
60 | python split_dynamic_packages () { | 62 | python split_dynamic_packages () { |
61 | # Create packages for each WirePlumber module. | 63 | # Create packages for each WirePlumber module. |
62 | wp_module_libdir = d.expand('${libdir}/${WP_MODULE_SUBDIR}') | 64 | wp_module_libdir = d.expand('${libdir}/${WP_MODULE_SUBDIR}') |