summaryrefslogtreecommitdiffstats
path: root/meta-multimedia
diff options
context:
space:
mode:
authorJose Quaresma <quaresma.jose@gmail.com>2020-11-14 15:04:43 +0000
committerKhem Raj <raj.khem@gmail.com>2020-11-15 12:25:18 -0800
commit23343cb8e9497981e4ef14d5eeae5df9bf891624 (patch)
tree0554995e56555087f0cc125f6d526907b89b79ed /meta-multimedia
parent291e48127e36170df7cec36633d3d0d6547c13e1 (diff)
downloadmeta-openembedded-23343cb8e9497981e4ef14d5eeae5df9bf891624.tar.gz
srt: add receipe
Secure Reliable Transport (SRT) Protocol Secure Reliable Transport (SRT) is an open source transport technology that optimizes streaming performance across unpredictable networks, such as the Internet. SRT is applied to contribution and distribution endpoints as part of a video stream workflow to deliver the best quality and lowest latency video at all times. As audio/video packets are streamed from a source to a destination device, SRT detects and adapts to the real-time network conditions between the two endpoints. SRT helps compensate for jitter and bandwidth fluctuations due to congestion over noisy networks, such as the Internet. Its error recovery mechanism minimizes the packet loss typical of Internet connections. And SRT supports AES encryption for end-to-end security, keeping your streams safe from prying eyes. * 0001-don-t-install-srt-ffplay.patch Upstream-Status: Pending Signed-off-by: Jose Quaresma <quaresma.jose@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-multimedia')
-rw-r--r--meta-multimedia/recipes-support/srt/srt/0001-don-t-install-srt-ffplay.patch28
-rw-r--r--meta-multimedia/recipes-support/srt/srt_1.4.2.bb27
2 files changed, 55 insertions, 0 deletions
diff --git a/meta-multimedia/recipes-support/srt/srt/0001-don-t-install-srt-ffplay.patch b/meta-multimedia/recipes-support/srt/srt/0001-don-t-install-srt-ffplay.patch
new file mode 100644
index 000000000..5b76b1632
--- /dev/null
+++ b/meta-multimedia/recipes-support/srt/srt/0001-don-t-install-srt-ffplay.patch
@@ -0,0 +1,28 @@
1From a45b43a2acd4c29bc8a204f51a3fa5e7b9815613 Mon Sep 17 00:00:00 2001
2From: Jose Quaresma <quaresma.jose@gmail.com>
3Date: Sat, 14 Nov 2020 12:29:56 +0000
4Subject: [PATCH] don't install srt-ffplay
5
6srt-ffplay is a simple bash scripts that pipes the output of srt-live-transmit to ffplay.
7It need ffmpeg as dependencie and requeire that libsrt is builded with -DENABLE_APPS=ON.
8So remove it because there are no option to disable the instalation.
9
10Upstream-Status: Pending
11
12Signed-off-by: Jose Quaresma <quaresma.jose@gmail.com>
13---
14 CMakeLists.txt | 1 -
15 1 file changed, 1 deletion(-)
16
17diff --git a/CMakeLists.txt b/CMakeLists.txt
18index ed6e603..ef53dc5 100644
19--- a/CMakeLists.txt
20+++ b/CMakeLists.txt
21@@ -1224,7 +1224,6 @@ if (ENABLE_UNITTESTS AND ENABLE_CXX11)
22 endif()
23
24
25-install(PROGRAMS scripts/srt-ffplay DESTINATION ${CMAKE_INSTALL_BINDIR})
26
27
28 if (DEFINED SRT_EXTRA_APPS_INC)
diff --git a/meta-multimedia/recipes-support/srt/srt_1.4.2.bb b/meta-multimedia/recipes-support/srt/srt_1.4.2.bb
new file mode 100644
index 000000000..567ea68ed
--- /dev/null
+++ b/meta-multimedia/recipes-support/srt/srt_1.4.2.bb
@@ -0,0 +1,27 @@
1SUMMARY = "Secure Reliable Transport (SRT) Protocol"
2DESCRIPTION = "Secure Reliable Transport (SRT) is an open source transport technology \
3that optimizes streaming performance across unpredictable networks, such as the Internet."
4SECTION = "libs"
5HOMEPAGE = "https://github.com/Haivision/srt"
6LICENSE = "MPL-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=815ca599c9df247a0c7f619bab123dad"
8
9SRCREV = "50b7af06f3a0a456c172b4cb3aceafa8a5cc0036"
10SRC_URI = "git://github.com/Haivision/srt;protocol=https \
11 file://0001-don-t-install-srt-ffplay.patch \
12 "
13UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>\d+(\.\d+)+)"
14S = "${WORKDIR}/git"
15
16inherit cmake pkgconfig
17
18EXTRA_OECMAKE = "-DCMAKE_BUILD_TYPE=Release -DENABLE_UNITTESTS=OFF"
19
20PACKAGECONFIG ??= "crypt"
21PACKAGECONFIG[debug] = "-DENABLE_DEBUG=1,,"
22PACKAGECONFIG[crypt] = "-DENABLE_ENCRYPTION=ON,-DENABLE_ENCRYPTION=OFF,openssl"
23PACKAGECONFIG[utils] = "-DENABLE_APPS=ON,-DENABLE_APPS=OFF,"
24
25PACKAGES += "${@bb.utils.contains('PACKAGECONFIG', 'utils', '${PN}-utils', '', d)}"
26FILES_${PN}-utils += "${bindir}"
27RDEPENDS_${PN}-utils += "${PN}"