summaryrefslogtreecommitdiffstats
path: root/meta-multimedia
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2016-02-22 19:23:14 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2016-03-14 12:15:28 +0100
commit1ec074eca0165de351ee45f173321f14408e3862 (patch)
tree162137aa4c4ec85bcf78dc994cb69f2e04b8e487 /meta-multimedia
parente687341653b0276d9d9c5868ac3da0b0da119f47 (diff)
downloadmeta-openembedded-1ec074eca0165de351ee45f173321f14408e3862.tar.gz
python-gst: remove the 0.10 recipe
It depends on pygobject 2.x which has been update to 3.x in oe-core Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com>
Diffstat (limited to 'meta-multimedia')
-rw-r--r--meta-multimedia/recipes-multimedia/gstreamer-0.10/python-gst/python-path.patch28
-rw-r--r--meta-multimedia/recipes-multimedia/gstreamer-0.10/python-gst_0.10.22.bb29
2 files changed, 0 insertions, 57 deletions
diff --git a/meta-multimedia/recipes-multimedia/gstreamer-0.10/python-gst/python-path.patch b/meta-multimedia/recipes-multimedia/gstreamer-0.10/python-gst/python-path.patch
deleted file mode 100644
index 21b5bbfcf..000000000
--- a/meta-multimedia/recipes-multimedia/gstreamer-0.10/python-gst/python-path.patch
+++ /dev/null
@@ -1,28 +0,0 @@
1Upstream-Status:Pending
2
3Index: gst-python-0.10.19/acinclude.m4
4===================================================================
5--- gst-python-0.10.19.orig/acinclude.m4 2010-04-21 15:23:44.000000000 -0700
6+++ gst-python-0.10.19/acinclude.m4 2010-11-15 14:43:00.642994001 -0800
7@@ -43,6 +43,13 @@
8 [AC_REQUIRE([AM_PATH_PYTHON])
9 AC_MSG_CHECKING(for headers required to compile python extensions)
10 dnl deduce PYTHON_INCLUDES
11+
12+AC_ARG_WITH(python-includes,
13+ [ --with-python-includes=DIR path to Python includes], py_exec_prefix=$withval)
14+if test x$py_exec_prefix != x; then
15+PYTHON_INCLUDES="-I${py_exec_prefix}/include/python${PYTHON_VERSION}"
16+py_prefix="${py_exec_prefix}"
17+else
18 py_prefix=`$PYTHON -c "import sys; print sys.prefix"`
19 py_exec_prefix=`$PYTHON -c "import sys; print sys.exec_prefix"`
20 if $PYTHON-config --help 2>/dev/null; then
21@@ -53,6 +60,7 @@
22 PYTHON_INCLUDES="$PYTHON_INCLUDES -I${py_exec_prefix}/include/python${PYTHON_VERSION}"
23 fi
24 fi
25+fi
26 AC_SUBST(PYTHON_INCLUDES)
27 dnl check if the headers exist:
28 save_CPPFLAGS="$CPPFLAGS"
diff --git a/meta-multimedia/recipes-multimedia/gstreamer-0.10/python-gst_0.10.22.bb b/meta-multimedia/recipes-multimedia/gstreamer-0.10/python-gst_0.10.22.bb
deleted file mode 100644
index 2a5f2b323..000000000
--- a/meta-multimedia/recipes-multimedia/gstreamer-0.10/python-gst_0.10.22.bb
+++ /dev/null
@@ -1,29 +0,0 @@
1SUMMARY = "Python bindings for the GStreamer multimedia framework"
2SECTION = "devel/python"
3LICENSE = "LGPLv2.1"
4DEPENDS = "gstreamer gst-plugins-base python-pygobject"
5RDEPENDS_${PN} += "python-pygtk"
6PR = "r2"
7
8SRC_URI = "http://gstreamer.freedesktop.org/src/gst-python/gst-python-${PV}.tar.bz2 \
9 file://python-path.patch"
10
11SRC_URI[md5sum] = "937152fe896241f827689f4b53e79b22"
12SRC_URI[sha256sum] = "8f26f519a5bccd770864317e098e5e307fc5ad1201eb96329634b6508b253178"
13S = "${WORKDIR}/gst-python-${PV}"
14
15LIC_FILES_CHKSUM = "file://COPYING;md5=39ff67e932b7bdfa9b78bad67151690b"
16
17inherit autotools distutils-base pkgconfig
18
19EXTRA_OECONF += "--with-python-includes=${STAGING_INCDIR}/../"
20
21FILES_${PN} += "${datadir}/gst-python"
22FILES_${PN}-dev += "${datadir}/gst-python/0.10/defs"
23FILES_${PN}-dbg += "${libdir}/${PYTHON_DIR}/site-packages/gst-0.10/gst/.debug/ ${libdir}/gstreamer-0.10/.debug/"
24
25do_configure_prepend() {
26 if [ `find ${STAGING_LIBDIR} -name libpython*.so` ]; then
27 ln -sf ${STAGING_LIBDIR}/libpython*.so `find ${STAGING_LIBDIR} -name libpython*.a -exec dirname {} \;`
28 fi
29}