summaryrefslogtreecommitdiffstats
path: root/meta-multimedia
diff options
context:
space:
mode:
authorTim Orling <TicoTimo@gmail.com>2015-08-02 17:39:07 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2015-08-18 11:52:29 +0200
commit9fee5145d7bf011df948fb82aca14b488c7c38c2 (patch)
treecf5aa4617008eaf52542dda0810566ae24dfb786 /meta-multimedia
parent2262233da0fe1deae6d35988ab405bc0aedcad5b (diff)
downloadmeta-openembedded-9fee5145d7bf011df948fb82aca14b488c7c38c2.tar.gz
vlc: update to 2.2.1
* add several pkg configs and libsamplerate0 dependency to vlc.inc * update patches 0003 and 0004 * add patch to use tremor's libvorbisidec rather than libvorbisdec * add patch to fix luaL_checkint and luaL_optint (deprecated in lua 5.3) Signed-off-by: Tim Orling <TicoTimo@gmail.com>
Diffstat (limited to 'meta-multimedia')
-rw-r--r--meta-multimedia/recipes-multimedia/vlc/vlc.inc6
-rw-r--r--meta-multimedia/recipes-multimedia/vlc/vlc/0003-use-am-path-libgcrypt.patch12
-rw-r--r--meta-multimedia/recipes-multimedia/vlc/vlc/0004-modules-gui-qt4-out-of-tree-build.patch24
-rw-r--r--meta-multimedia/recipes-multimedia/vlc/vlc/0007-use-vorbisidec.patch19
-rw-r--r--meta-multimedia/recipes-multimedia/vlc/vlc/0008-fix-luaL-checkint.patch279
-rw-r--r--meta-multimedia/recipes-multimedia/vlc/vlc_2.2.1.bb (renamed from meta-multimedia/recipes-multimedia/vlc/vlc_2.1.4.bb)6
6 files changed, 325 insertions, 21 deletions
diff --git a/meta-multimedia/recipes-multimedia/vlc/vlc.inc b/meta-multimedia/recipes-multimedia/vlc/vlc.inc
index 0362f3919..bf7ce0c88 100644
--- a/meta-multimedia/recipes-multimedia/vlc/vlc.inc
+++ b/meta-multimedia/recipes-multimedia/vlc/vlc.inc
@@ -10,7 +10,7 @@ DEPENDS = "libfribidi libtool libgcrypt libgcrypt-native gst-plugins-bad \
10 tremor faad2 ffmpeg flac libxpm libxinerama fluidsynth alsa-lib \ 10 tremor faad2 ffmpeg flac libxpm libxinerama fluidsynth alsa-lib \
11 libdvdcss libdvdread lua-native lua libidn libnotify gtk+ gnome-vfs \ 11 libdvdcss libdvdread lua-native lua libidn libnotify gtk+ gnome-vfs \
12 libdc1394 libraw1394 avahi libjpeg-turbo xz libmodplug mpeg2dec \ 12 libdc1394 libraw1394 avahi libjpeg-turbo xz libmodplug mpeg2dec \
13 libmtp libopus orc libusb1 schroedinger taglib \ 13 libmtp libopus orc libsamplerate0 libusb1 schroedinger taglib \
14 tiff xcb-util-keysyms samba" 14 tiff xcb-util-keysyms samba"
15 15
16SRC_URI = "http://download.videolan.org/pub/videolan/${BPN}/${PV}/${BP}.tar.xz" 16SRC_URI = "http://download.videolan.org/pub/videolan/${BPN}/${PV}/${BP}.tar.xz"
@@ -36,7 +36,6 @@ EXTRA_OECONF = "\
36 --enable-dbus \ 36 --enable-dbus \
37 --without-contrib \ 37 --without-contrib \
38 --without-kde-solid \ 38 --without-kde-solid \
39 --disable-glx \
40 --enable-realrtsp \ 39 --enable-realrtsp \
41 --disable-libtar \ 40 --disable-libtar \
42 ac_cv_path_MOC=${STAGING_BINDIR_NATIVE}/moc4 \ 41 ac_cv_path_MOC=${STAGING_BINDIR_NATIVE}/moc4 \
@@ -54,6 +53,9 @@ PACKAGECONFIG[mkv] = "--enable-mkv,--disable-mkv,libmatroska libebml"
54PACKAGECONFIG[postproc] = "--enable-postproc,--disable-postproc,libpostproc" 53PACKAGECONFIG[postproc] = "--enable-postproc,--disable-postproc,libpostproc"
55PACKAGECONFIG[opencv] = "--enable-opencv,--disable-opencv,opencv" 54PACKAGECONFIG[opencv] = "--enable-opencv,--disable-opencv,opencv"
56PACKAGECONFIG[libva] = "--enable-libva --enable-avcodec,--disable-libva --disable-avcodec,libva libav" 55PACKAGECONFIG[libva] = "--enable-libva --enable-avcodec,--disable-libva --disable-avcodec,libva libav"
56PACKAGECONFIG[speex] = "--enable-speex,--disable-speex,speex"
57PACKAGECONFIG[gstreamer] = "--enable-gst-decode,--disable-gst-decode,gstreamer1.0 gstreamer1.0-plugins-base"
58PACKAGECONFIG[vpx] = "--enable-vpx,--disable-vpx, libvpx"
57 59
58do_configure_prepend() { 60do_configure_prepend() {
59 cp ${STAGING_DATADIR}/libtool/config.* ${S}/autotools/ || true 61 cp ${STAGING_DATADIR}/libtool/config.* ${S}/autotools/ || true
diff --git a/meta-multimedia/recipes-multimedia/vlc/vlc/0003-use-am-path-libgcrypt.patch b/meta-multimedia/recipes-multimedia/vlc/vlc/0003-use-am-path-libgcrypt.patch
index ae80745d2..8e881d093 100644
--- a/meta-multimedia/recipes-multimedia/vlc/vlc/0003-use-am-path-libgcrypt.patch
+++ b/meta-multimedia/recipes-multimedia/vlc/vlc/0003-use-am-path-libgcrypt.patch
@@ -5,11 +5,11 @@
5 5
6Upstream status: Pending 6Upstream status: Pending
7 7
8Index: vlc-2.1.4/configure.ac 8Index: vlc-2.2.1/configure.ac
9=================================================================== 9===================================================================
10--- vlc-2.1.4.orig/configure.ac 10--- vlc-2.2.1.orig/configure.ac
11+++ vlc-2.1.4/configure.ac 11+++ vlc-2.2.1/configure.ac
12@@ -3940,25 +3940,19 @@ PKG_ENABLE_MODULES_VLC([LIBXML2], [xml], 12@@ -4017,25 +4017,19 @@ PKG_ENABLE_MODULES_VLC([LIBXML2], [xml],
13 dnl 13 dnl
14 dnl libgcrypt 14 dnl libgcrypt
15 dnl 15 dnl
@@ -26,10 +26,10 @@ Index: vlc-2.1.4/configure.ac
26- GCRYPT_CFLAGS="`libgcrypt-config --cflags`" 26- GCRYPT_CFLAGS="`libgcrypt-config --cflags`"
27- GCRYPT_LIBS="`libgcrypt-config --libs`" 27- GCRYPT_LIBS="`libgcrypt-config --libs`"
28- ], [ 28- ], [
29- AC_MSG_ERROR([libgcrypt not found. Install libgcrypt or use --disable-libgcrypt. Have a nice day.]) 29- AC_MSG_ERROR([libgcrypt not found. Install libgcrypt or pass --disable-libgcrypt.])
30- ], [`libgcrypt-config --libs`]) 30- ], [`libgcrypt-config --libs`])
31- ], [ 31- ], [
32- AC_MSG_ERROR([libgcrypt version 1.1.94 or higher not found. Install libgcrypt or use --disable-libgcrypt. Have a nice day.]) 32- AC_MSG_ERROR([libgcrypt version 1.1.94 or higher not found. Install libgcrypt or pass --disable-libgcrypt.])
33- ], [#include <gcrypt.h>] 33- ], [#include <gcrypt.h>]
34- ) 34- )
35+ AM_PATH_LIBGCRYPT($GCRYPT_LIBVER:$GCRYPT_REQ, 35+ AM_PATH_LIBGCRYPT($GCRYPT_LIBVER:$GCRYPT_REQ,
diff --git a/meta-multimedia/recipes-multimedia/vlc/vlc/0004-modules-gui-qt4-out-of-tree-build.patch b/meta-multimedia/recipes-multimedia/vlc/vlc/0004-modules-gui-qt4-out-of-tree-build.patch
index 3dadb237e..53df1c6eb 100644
--- a/meta-multimedia/recipes-multimedia/vlc/vlc/0004-modules-gui-qt4-out-of-tree-build.patch
+++ b/meta-multimedia/recipes-multimedia/vlc/vlc/0004-modules-gui-qt4-out-of-tree-build.patch
@@ -1,17 +1,19 @@
1* modules/gui/qt4/Modules.am not B!=S friendly 1* modules/gui/qt4/Makefile.am not B!=S friendly
2* Simple solution to missing directories in ${B} 2* Simple solution to missing directories in ${B}
3 3
4Upstream status: Pending 4Upstream status: Pending
5 5
6Index: vlc-2.1.4/modules/gui/qt4/Modules.am 6Signed-off-by: Tim Orling <TicoTimo@gmail.com>
7
8Index: vlc-2.2.1/modules/gui/qt4/Makefile.am
7=================================================================== 9===================================================================
8--- vlc-2.1.4.orig/modules/gui/qt4/Modules.am 10--- vlc-2.2.1.orig/modules/gui/qt4/Makefile.am
9+++ vlc-2.1.4/modules/gui/qt4/Modules.am 11+++ vlc-2.2.1/modules/gui/qt4/Makefile.am
10@@ -261,6 +261,7 @@ else 12@@ -127,6 +127,7 @@ moc_verbose_0 = @echo " MOC " $@;
11 if HAVE_WIN32 13 moc_verbose__0 = $(moc_verbose_0)
12 $(moc_verbose)$(MOC) -D_WIN32 $(DEFS) -I$(top_srcdir)/include -I$(top_builddir)/include -I$(top_builddir) $(CPPFLAGS_qt4) -o $@ $< 14
13 else 15 .hpp.moc.cpp:
14+ [ -d $(dir $@) ] || mkdir -p $(dir $@) 16+ [ -d $(dir $@) ] || mkdir -p $(dir $@)
15 $(moc_verbose)$(MOC) $(DEFS) -I$(top_srcdir)/include -I$(top_builddir)/include -I$(top_builddir) $(CPPFLAGS_qt4) -o $@ $< 17 $(moc_verbose)$(MOC) $(MOC_CPPFLAGS) -o $@ $<
16 endif 18
17 endif 19 # These MOC files depend on the configure settings:
diff --git a/meta-multimedia/recipes-multimedia/vlc/vlc/0007-use-vorbisidec.patch b/meta-multimedia/recipes-multimedia/vlc/vlc/0007-use-vorbisidec.patch
new file mode 100644
index 000000000..d05cf02b7
--- /dev/null
+++ b/meta-multimedia/recipes-multimedia/vlc/vlc/0007-use-vorbisidec.patch
@@ -0,0 +1,19 @@
1* tremor provides libvorbisidec, use it instead of libvorbisdec
2
3Upstream-status: Pending
4
5Signed-off-by: Tim Orling <TicoTimo@gmail.com>
6
7Index: vlc-2.2.1/modules/codec/Makefile.am
8===================================================================
9--- vlc-2.2.1.orig/modules/codec/Makefile.am
10+++ vlc-2.2.1/modules/codec/Makefile.am
11@@ -234,7 +234,7 @@ codec_LTLIBRARIES += $(LTLIBtheora)
12 libtremor_plugin_la_SOURCES = codec/vorbis.c
13 libtremor_plugin_la_CPPFLAGS = $(AM_CPPFLAGS) -DMODULE_NAME_IS_tremor
14 libtremor_plugin_la_LDFLAGS = $(AM_LDFLAGS) -rpath '$(codecdir)'
15-libtremor_plugin_la_LIBADD = -lvorbisdec -logg
16+libtremor_plugin_la_LIBADD = -lvorbisidec -logg
17 EXTRA_LTLIBRARIES += libtremor_plugin.la
18 codec_LTLIBRARIES += $(LTLIBtremor)
19
diff --git a/meta-multimedia/recipes-multimedia/vlc/vlc/0008-fix-luaL-checkint.patch b/meta-multimedia/recipes-multimedia/vlc/vlc/0008-fix-luaL-checkint.patch
new file mode 100644
index 000000000..145e1ab82
--- /dev/null
+++ b/meta-multimedia/recipes-multimedia/vlc/vlc/0008-fix-luaL-checkint.patch
@@ -0,0 +1,279 @@
1* luaL_checkint and luaL_optint were deprecated in lua 5.3
2* replacement functions are luaL_checkinteger and luaL_optinteger
3
4Upstream-status: Pending
5
6Signed-off-by: Tim Orling <TicoTimo@gmail.com>
7
8Index: vlc-2.2.1/modules/lua/demux.c
9===================================================================
10--- vlc-2.2.1.orig/modules/lua/demux.c
11+++ vlc-2.2.1/modules/lua/demux.c
12@@ -52,7 +52,7 @@ struct demux_sys_t
13 static int vlclua_demux_peek( lua_State *L )
14 {
15 demux_t *p_demux = (demux_t *)vlclua_get_this( L );
16- int n = luaL_checkint( L, 1 );
17+ int n = luaL_checkinteger( L, 1 );
18 const uint8_t *p_peek;
19
20 int i_peek = stream_Peek( p_demux->s, &p_peek, n );
21@@ -67,7 +67,7 @@ static int vlclua_demux_read( lua_State
22 {
23 demux_t *p_demux = (demux_t *)vlclua_get_this( L );
24 const uint8_t *p_read;
25- int n = luaL_checkint( L, 1 );
26+ int n = luaL_checkinteger( L, 1 );
27 int i_read = stream_Peek( p_demux->s, &p_read, n );
28
29 if( i_read > 0 )
30Index: vlc-2.2.1/modules/lua/libs/configuration.c
31===================================================================
32--- vlc-2.2.1.orig/modules/lua/libs/configuration.c
33+++ vlc-2.2.1/modules/lua/libs/configuration.c
34@@ -84,7 +84,7 @@ static int vlclua_config_set( lua_State
35 break;
36
37 case VLC_VAR_INTEGER:
38- config_PutInt( p_this, psz_name, luaL_checkint( L, 2 ) );
39+ config_PutInt( p_this, psz_name, luaL_checkinteger( L, 2 ) );
40 break;
41
42 case VLC_VAR_BOOL:
43Index: vlc-2.2.1/modules/lua/libs/net.c
44===================================================================
45--- vlc-2.2.1.orig/modules/lua/libs/net.c
46+++ vlc-2.2.1/modules/lua/libs/net.c
47@@ -202,7 +202,7 @@ static int vlclua_net_listen_tcp( lua_St
48 {
49 vlc_object_t *p_this = vlclua_get_this( L );
50 const char *psz_host = luaL_checkstring( L, 1 );
51- int i_port = luaL_checkint( L, 2 );
52+ int i_port = luaL_checkinteger( L, 2 );
53 int *pi_fd = net_ListenTCP( p_this, psz_host, i_port );
54 if( pi_fd == NULL )
55 return luaL_error( L, "Cannot listen on %s:%d", psz_host, i_port );
56@@ -274,7 +274,7 @@ static int vlclua_net_connect_tcp( lua_S
57 {
58 vlc_object_t *p_this = vlclua_get_this( L );
59 const char *psz_host = luaL_checkstring( L, 1 );
60- int i_port = luaL_checkint( L, 2 );
61+ int i_port = luaL_checkinteger( L, 2 );
62 int i_fd = net_Connect( p_this, psz_host, i_port, SOCK_STREAM, IPPROTO_TCP );
63 lua_pushinteger( L, vlclua_fd_map_safe( L, i_fd ) );
64 return 1;
65@@ -282,26 +282,26 @@ static int vlclua_net_connect_tcp( lua_S
66
67 static int vlclua_net_close( lua_State *L )
68 {
69- int i_fd = luaL_checkint( L, 1 );
70+ int i_fd = luaL_checkinteger( L, 1 );
71 vlclua_fd_unmap_safe( L, i_fd );
72 return 0;
73 }
74
75 static int vlclua_net_send( lua_State *L )
76 {
77- int fd = vlclua_fd_get( L, luaL_checkint( L, 1 ) );
78+ int fd = vlclua_fd_get( L, luaL_checkinteger( L, 1 ) );
79 size_t i_len;
80 const char *psz_buffer = luaL_checklstring( L, 2, &i_len );
81
82- i_len = luaL_optint( L, 3, i_len );
83+ i_len = luaL_optinteger( L, 3, i_len );
84 lua_pushinteger( L, (fd != -1) ? send( fd, psz_buffer, i_len, 0 ) : -1 );
85 return 1;
86 }
87
88 static int vlclua_net_recv( lua_State *L )
89 {
90- int fd = vlclua_fd_get( L, luaL_checkint( L, 1 ) );
91- size_t i_len = luaL_optint( L, 2, 1 );
92+ int fd = vlclua_fd_get( L, luaL_checkinteger( L, 1 ) );
93+ size_t i_len = luaL_optinteger( L, 2, 1 );
94 char psz_buffer[i_len];
95
96 ssize_t i_ret = (fd != -1) ? recv( fd, psz_buffer, i_len, 0 ) : -1;
97@@ -382,19 +382,19 @@ static int vlclua_fd_open( lua_State *L
98 #ifndef _WIN32
99 static int vlclua_fd_write( lua_State *L )
100 {
101- int fd = vlclua_fd_get( L, luaL_checkint( L, 1 ) );
102+ int fd = vlclua_fd_get( L, luaL_checkinteger( L, 1 ) );
103 size_t i_len;
104 const char *psz_buffer = luaL_checklstring( L, 2, &i_len );
105
106- i_len = luaL_optint( L, 3, i_len );
107+ i_len = luaL_optinteger( L, 3, i_len );
108 lua_pushinteger( L, (fd != -1) ? write( fd, psz_buffer, i_len ) : -1 );
109 return 1;
110 }
111
112 static int vlclua_fd_read( lua_State *L )
113 {
114- int fd = vlclua_fd_get( L, luaL_checkint( L, 1 ) );
115- size_t i_len = luaL_optint( L, 2, 1 );
116+ int fd = vlclua_fd_get( L, luaL_checkinteger( L, 1 ) );
117+ size_t i_len = luaL_optinteger( L, 2, 1 );
118 char psz_buffer[i_len];
119
120 ssize_t i_ret = (fd != -1) ? read( fd, psz_buffer, i_len ) : -1;
121Index: vlc-2.2.1/modules/lua/libs/osd.c
122===================================================================
123--- vlc-2.2.1.orig/modules/lua/libs/osd.c
124+++ vlc-2.2.1/modules/lua/libs/osd.c
125@@ -67,7 +67,7 @@ static int vlclua_osd_icon( lua_State *L
126 {
127 const char *psz_icon = luaL_checkstring( L, 1 );
128 int i_icon = vlc_osd_icon_from_string( psz_icon );
129- int i_chan = luaL_optint( L, 2, SPU_DEFAULT_CHANNEL );
130+ int i_chan = luaL_optinteger( L, 2, SPU_DEFAULT_CHANNEL );
131 if( !i_icon )
132 return luaL_error( L, "\"%s\" is not a valid osd icon.", psz_icon );
133
134@@ -114,9 +114,9 @@ static int vlc_osd_position_from_string(
135 static int vlclua_osd_message( lua_State *L )
136 {
137 const char *psz_message = luaL_checkstring( L, 1 );
138- int i_chan = luaL_optint( L, 2, SPU_DEFAULT_CHANNEL );
139+ int i_chan = luaL_optinteger( L, 2, SPU_DEFAULT_CHANNEL );
140 const char *psz_position = luaL_optstring( L, 3, "top-right" );
141- mtime_t duration = luaL_optint( L, 4, 1000000 );
142+ mtime_t duration = luaL_optinteger( L, 4, 1000000 );
143
144 input_thread_t *p_input = vlclua_get_input_internal( L );
145 if( p_input )
146@@ -154,10 +154,10 @@ static int vlc_osd_slider_type_from_stri
147
148 static int vlclua_osd_slider( lua_State *L )
149 {
150- int i_position = luaL_checkint( L, 1 );
151+ int i_position = luaL_checkinteger( L, 1 );
152 const char *psz_type = luaL_checkstring( L, 2 );
153 int i_type = vlc_osd_slider_type_from_string( psz_type );
154- int i_chan = luaL_optint( L, 3, SPU_DEFAULT_CHANNEL );
155+ int i_chan = luaL_optinteger( L, 3, SPU_DEFAULT_CHANNEL );
156 if( !i_type )
157 return luaL_error( L, "\"%s\" is not a valid slider type.",
158 psz_type );
159@@ -198,7 +198,7 @@ static int vlclua_spu_channel_register(
160
161 static int vlclua_spu_channel_clear( lua_State *L )
162 {
163- int i_chan = luaL_checkint( L, 1 );
164+ int i_chan = luaL_checkinteger( L, 1 );
165 input_thread_t *p_input = vlclua_get_input_internal( L );
166 if( !p_input )
167 return luaL_error( L, "Unable to find input." );
168Index: vlc-2.2.1/modules/lua/libs/playlist.c
169===================================================================
170--- vlc-2.2.1.orig/modules/lua/libs/playlist.c
171+++ vlc-2.2.1/modules/lua/libs/playlist.c
172@@ -69,7 +69,7 @@ static int vlclua_playlist_next( lua_Sta
173
174 static int vlclua_playlist_skip( lua_State * L )
175 {
176- int i_skip = luaL_checkint( L, 1 );
177+ int i_skip = luaL_checkinteger( L, 1 );
178 playlist_t *p_playlist = vlclua_get_playlist_internal( L );
179 playlist_Skip( p_playlist, i_skip );
180 return 0;
181@@ -127,7 +127,7 @@ static int vlclua_playlist_random( lua_S
182
183 static int vlclua_playlist_gotoitem( lua_State * L )
184 {
185- int i_id = luaL_checkint( L, 1 );
186+ int i_id = luaL_checkinteger( L, 1 );
187 playlist_t *p_playlist = vlclua_get_playlist_internal( L );
188 PL_LOCK;
189 int i_ret = playlist_Control( p_playlist, PLAYLIST_VIEWPLAY,
190@@ -139,7 +139,7 @@ static int vlclua_playlist_gotoitem( lua
191
192 static int vlclua_playlist_delete( lua_State * L )
193 {
194- int i_id = luaL_checkint( L, 1 );
195+ int i_id = luaL_checkinteger( L, 1 );
196 playlist_t *p_playlist = vlclua_get_playlist_internal( L );
197 PL_LOCK;
198 playlist_item_t *p_item = playlist_ItemGetById( p_playlist, i_id );
199@@ -155,8 +155,8 @@ static int vlclua_playlist_delete( lua_S
200
201 static int vlclua_playlist_move( lua_State * L )
202 {
203- int i_item = luaL_checkint( L, 1 );
204- int i_target = luaL_checkint( L, 2 );
205+ int i_item = luaL_checkinteger( L, 1 );
206+ int i_target = luaL_checkinteger( L, 2 );
207 playlist_t *p_playlist = vlclua_get_playlist_internal( L );
208 PL_LOCK;
209 playlist_item_t *p_item = playlist_ItemGetById( p_playlist, i_item );
210Index: vlc-2.2.1/modules/lua/libs/stream.c
211===================================================================
212--- vlc-2.2.1.orig/modules/lua/libs/stream.c
213+++ vlc-2.2.1/modules/lua/libs/stream.c
214@@ -101,7 +101,7 @@ static int vlclua_stream_read( lua_State
215 {
216 int i_read;
217 stream_t **pp_stream = (stream_t **)luaL_checkudata( L, 1, "stream" );
218- int n = luaL_checkint( L, 2 );
219+ int n = luaL_checkinteger( L, 2 );
220 uint8_t *p_read = malloc( n );
221 if( !p_read ) return vlclua_error( L );
222
223Index: vlc-2.2.1/modules/lua/libs/variables.c
224===================================================================
225--- vlc-2.2.1.orig/modules/lua/libs/variables.c
226+++ vlc-2.2.1/modules/lua/libs/variables.c
227@@ -103,7 +103,7 @@ static int vlclua_tovalue( lua_State *L,
228 val->b_bool = luaL_checkboolean( L, -1 );
229 break;
230 case VLC_VAR_INTEGER:
231- val->i_int = luaL_checkint( L, -1 );
232+ val->i_int = luaL_checkinteger( L, -1 );
233 break;
234 case VLC_VAR_STRING:
235 val->psz_string = (char*)luaL_checkstring( L, -1 ); /* XXX: Beware, this only stays valid as long as (L,-1) stays in the stack */
236Index: vlc-2.2.1/modules/lua/libs/volume.c
237===================================================================
238--- vlc-2.2.1.orig/modules/lua/libs/volume.c
239+++ vlc-2.2.1/modules/lua/libs/volume.c
240@@ -48,7 +48,7 @@
241 static int vlclua_volume_set( lua_State *L )
242 {
243 playlist_t *p_this = vlclua_get_playlist_internal( L );
244- int i_volume = luaL_checkint( L, 1 );
245+ int i_volume = luaL_checkinteger( L, 1 );
246 if( i_volume < 0 )
247 i_volume = 0;
248 int i_ret = playlist_VolumeSet( p_this, i_volume/(float)AOUT_VOLUME_DEFAULT );
249@@ -68,7 +68,7 @@ static int vlclua_volume_up( lua_State *
250 playlist_t *p_this = vlclua_get_playlist_internal( L );
251 float volume;
252
253- playlist_VolumeUp( p_this, luaL_optint( L, 1, 1 ), &volume );
254+ playlist_VolumeUp( p_this, luaL_optinteger( L, 1, 1 ), &volume );
255 lua_pushnumber( L, lroundf(volume * AOUT_VOLUME_DEFAULT) );
256 return 1;
257 }
258@@ -78,7 +78,7 @@ static int vlclua_volume_down( lua_State
259 playlist_t *p_this = vlclua_get_playlist_internal( L );
260 float volume;
261
262- playlist_VolumeDown( p_this, luaL_optint( L, 1, 1 ), &volume );
263+ playlist_VolumeDown( p_this, luaL_optinteger( L, 1, 1 ), &volume );
264 lua_pushnumber( L, lroundf(volume * AOUT_VOLUME_DEFAULT) );
265 return 1;
266 }
267Index: vlc-2.2.1/modules/lua/libs/win.c
268===================================================================
269--- vlc-2.2.1.orig/modules/lua/libs/win.c
270+++ vlc-2.2.1/modules/lua/libs/win.c
271@@ -123,7 +123,7 @@ static int vlclua_console_init( lua_Stat
272
273 static int vlclua_console_wait( lua_State *L )
274 {
275- int i_timeout = luaL_optint( L, 1, 0 );
276+ int i_timeout = luaL_optinteger( L, 1, 0 );
277 DWORD status = WaitForSingleObject( GetConsole( L ), i_timeout );
278 lua_pushboolean( L, status == WAIT_OBJECT_0 );
279 return 1;
diff --git a/meta-multimedia/recipes-multimedia/vlc/vlc_2.1.4.bb b/meta-multimedia/recipes-multimedia/vlc/vlc_2.2.1.bb
index 418f77cfc..ba8ca4b5a 100644
--- a/meta-multimedia/recipes-multimedia/vlc/vlc_2.1.4.bb
+++ b/meta-multimedia/recipes-multimedia/vlc/vlc_2.2.1.bb
@@ -9,7 +9,9 @@ SRC_URI += "file://0001-enable-subdir-objects.patch \
9 file://0004-modules-gui-qt4-out-of-tree-build.patch \ 9 file://0004-modules-gui-qt4-out-of-tree-build.patch \
10 file://0005-libpostproc-header-check.patch \ 10 file://0005-libpostproc-header-check.patch \
11 file://0006-make-opencv-configurable.patch \ 11 file://0006-make-opencv-configurable.patch \
12 file://0007-use-vorbisidec.patch \
13 file://0008-fix-luaL-checkint.patch \
12" 14"
13 15
14SRC_URI[md5sum] = "7ed67d22f7425011078772bfc62ac222" 16SRC_URI[md5sum] = "42273945758b521c408fabc7fd6d9946"
15SRC_URI[sha256sum] = "3e566c7525478167e18cc53dc75d621e4af91eb40aabb6231e47db25d682d5d3" 17SRC_URI[sha256sum] = "543d9d7e378ec0fa1ee2e7f7f5acf8c456c7d0ecc32037171523197ef3cf1fcb"