summaryrefslogtreecommitdiffstats
path: root/meta-multimedia
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@gmail.com>2021-06-09 08:38:18 +0200
committerKhem Raj <raj.khem@gmail.com>2021-06-09 08:49:21 -0700
commitf670227fda0b78e9331145dbab89654b11d3dbb6 (patch)
treecf0d85884631125d641f08d899fd699bab90369b /meta-multimedia
parent9a6965b80e0b14e831f63ca0dcbe62d9610ee789 (diff)
downloadmeta-openembedded-f670227fda0b78e9331145dbab89654b11d3dbb6.tar.gz
gupnp: upgrade 1.2.6 -> 1.2.7
Hardening fix was applied 1.2.7 ===== - Fix build with -Wformat-security=error - Bump required GLib version to 2.66 - Fix some introspection annotations - Add missing varargs functions to vapi - Revert fix from 1.2.5 which causes managed control points to live too long Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-multimedia')
-rw-r--r--meta-multimedia/recipes-connectivity/gupnp/gupnp/0001-Fix-build-with-hardened-security-flags.patch61
-rw-r--r--meta-multimedia/recipes-connectivity/gupnp/gupnp_1.2.6.bb10
-rw-r--r--meta-multimedia/recipes-connectivity/gupnp/gupnp_1.2.7.bb7
3 files changed, 7 insertions, 71 deletions
diff --git a/meta-multimedia/recipes-connectivity/gupnp/gupnp/0001-Fix-build-with-hardened-security-flags.patch b/meta-multimedia/recipes-connectivity/gupnp/gupnp/0001-Fix-build-with-hardened-security-flags.patch
deleted file mode 100644
index ef0c945d0..000000000
--- a/meta-multimedia/recipes-connectivity/gupnp/gupnp/0001-Fix-build-with-hardened-security-flags.patch
+++ /dev/null
@@ -1,61 +0,0 @@
1From 6eba07bd195e0a1199a0fc62d7cc31ec376bc3dd Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@gmail.com>
3Date: Mon, 31 May 2021 17:44:29 +0200
4Subject: [PATCH] Fix build with hardened security flags
5MIME-Version: 1.0
6Content-Type: text/plain; charset=UTF-8
7Content-Transfer-Encoding: 8bit
8
9| ../gupnp-1.2.6/examples/get-volume.c: In function 'on_introspection':
10| ../gupnp-1.2.6/examples/get-volume.c:53:17: error: format not a string literal and no format arguments [-Werror=format-security]
11| 53 | g_critical (error->message);
12| | ^~~~~~~~~~
13| ../gupnp-1.2.6/examples/get-volume.c:114:17: error: format not a string literal and no format arguments [-Werror=format-security]
14| 114 | g_critical (error->message);
15| | ^~~~~~~~~~
16| ../gupnp-1.2.6/examples/get-volume.c: In function 'main':
17| ../gupnp-1.2.6/examples/get-volume.c:150:17: error: format not a string literal and no format arguments [-Werror=format-security]
18| 150 | g_error (error->message);
19| | ^~~~~~~
20
21Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
22
23Upstream-Status: Submitted [https://gitlab.gnome.org/GNOME/gupnp/-/merge_requests/17]
24---
25 examples/get-volume.c | 6 +++---
26 1 file changed, 3 insertions(+), 3 deletions(-)
27
28diff --git a/examples/get-volume.c b/examples/get-volume.c
29index 4601014..923581c 100644
30--- a/examples/get-volume.c
31+++ b/examples/get-volume.c
32@@ -50,7 +50,7 @@ on_introspection (GObject *object, GAsyncResult *res, gpointer user_data)
33 &error);
34
35 if (error != NULL) {
36- g_critical (error->message);
37+ g_critical ("%s", error->message);
38 g_clear_error (&error);
39 }
40
41@@ -111,7 +111,7 @@ on_introspection (GObject *object, GAsyncResult *res, gpointer user_data)
42 g_list_free (out_names);
43
44 if (error != NULL) {
45- g_critical (error->message);
46+ g_critical ("%s", error->message);
47 g_clear_error (&error);
48 } else {
49 g_print ("Current volume: %s\n",
50@@ -147,7 +147,7 @@ int main(int argc, char *argv[])
51 GUPnPContext *context = gupnp_context_new ("wlp3s0", 0, &error);
52
53 if (error != NULL) {
54- g_error (error->message);
55+ g_error ("%s", error->message);
56 }
57
58 GUPnPControlPoint *cp = gupnp_control_point_new (context, CONTENT_DIR);
59--
602.31.1
61
diff --git a/meta-multimedia/recipes-connectivity/gupnp/gupnp_1.2.6.bb b/meta-multimedia/recipes-connectivity/gupnp/gupnp_1.2.6.bb
deleted file mode 100644
index 294c361db..000000000
--- a/meta-multimedia/recipes-connectivity/gupnp/gupnp_1.2.6.bb
+++ /dev/null
@@ -1,10 +0,0 @@
1require gupnp.inc
2
3SRC_URI = " \
4 ${GNOME_MIRROR}/${BPN}/1.2/${BPN}-${PV}.tar.xz \
5 file://0001-Fix-build-with-hardened-security-flags.patch \
6"
7SRC_URI[sha256sum] = "00b20f1e478a72deac92c34723693a2ac55789ed1e4bb4eed99eb4d62092aafd"
8
9LIC_FILES_CHKSUM = "file://COPYING;md5=3bf50002aefd002f49e7bb854063f7e7 \
10 file://libgupnp/gupnp.h;beginline=1;endline=20;md5=d78a69d9b6e63ee2dc72e7b674d97520"
diff --git a/meta-multimedia/recipes-connectivity/gupnp/gupnp_1.2.7.bb b/meta-multimedia/recipes-connectivity/gupnp/gupnp_1.2.7.bb
new file mode 100644
index 000000000..7ad594f02
--- /dev/null
+++ b/meta-multimedia/recipes-connectivity/gupnp/gupnp_1.2.7.bb
@@ -0,0 +1,7 @@
1require gupnp.inc
2
3SRC_URI = "${GNOME_MIRROR}/${BPN}/1.2/${BPN}-${PV}.tar.xz"
4SRC_URI[sha256sum] = "8441276f1afd0176e6f595026a3a507eed1809abfa04026bad3f21622b3523ec"
5
6LIC_FILES_CHKSUM = "file://COPYING;md5=3bf50002aefd002f49e7bb854063f7e7 \
7 file://libgupnp/gupnp.h;beginline=1;endline=20;md5=d78a69d9b6e63ee2dc72e7b674d97520"