diff options
author | Alistair Francis <alistair.francis@wdc.com> | 2019-10-15 15:54:22 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2019-10-17 05:53:25 -0700 |
commit | d8e71b65a86d4a82fe7442477d06449a3d5f717b (patch) | |
tree | 1491a932e1a118dd55757af1b78be36bae4074d8 /meta-multimedia | |
parent | 74aa0be63710d99f30b6d69c67b033ffea3a08f8 (diff) | |
download | meta-openembedded-d8e71b65a86d4a82fe7442477d06449a3d5f717b.tar.gz |
mycroft: Run the files from /var
To avoid errors when running on a read only /lib/ file system copy the
files to /var and run mycroft from there.
Signed-off-by: Alistair Francis <alistair.francis@wdc.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-multimedia')
3 files changed, 6 insertions, 4 deletions
diff --git a/meta-multimedia/recipes-multimedia/mycroft/files/mycroft-setup.service b/meta-multimedia/recipes-multimedia/mycroft/files/mycroft-setup.service index 07598235e..4b4bcdd77 100644 --- a/meta-multimedia/recipes-multimedia/mycroft/files/mycroft-setup.service +++ b/meta-multimedia/recipes-multimedia/mycroft/files/mycroft-setup.service | |||
@@ -5,7 +5,8 @@ After=systemd-user-sessions.service | |||
5 | 5 | ||
6 | [Service] | 6 | [Service] |
7 | Type=oneshot | 7 | Type=oneshot |
8 | ExecStart=@LIBDIR@/mycroft/dev_setup.sh --allow-root | 8 | ExecStart=cp -rf @LIBDIR@/mycroft /var/ |
9 | ExecStart=/var/mycroft/dev_setup.sh --allow-root | ||
9 | 10 | ||
10 | [Install] | 11 | [Install] |
11 | WantedBy=multi-user.target | 12 | WantedBy=multi-user.target |
diff --git a/meta-multimedia/recipes-multimedia/mycroft/files/mycroft.service b/meta-multimedia/recipes-multimedia/mycroft/files/mycroft.service index 28729f6b1..c7f477f13 100644 --- a/meta-multimedia/recipes-multimedia/mycroft/files/mycroft.service +++ b/meta-multimedia/recipes-multimedia/mycroft/files/mycroft.service | |||
@@ -5,10 +5,10 @@ After=mycroft-setup.service | |||
5 | 5 | ||
6 | [Service] | 6 | [Service] |
7 | Type=forking | 7 | Type=forking |
8 | WorkingDirectory=@LIBDIR@/mycroft | 8 | WorkingDirectory=/var/mycroft |
9 | ExecStartPre=mkdir -p /var/log/mycroft | 9 | ExecStartPre=mkdir -p /var/log/mycroft |
10 | ExecStart=@LIBDIR@/mycroft/start-mycroft.sh all | 10 | ExecStart=/var/mycroft/start-mycroft.sh all |
11 | ExecStop=@LIBDIR@/mycroft/stop-mycroft.sh all | 11 | ExecStop=/var/mycroft/stop-mycroft.sh all |
12 | 12 | ||
13 | [Install] | 13 | [Install] |
14 | WantedBy=multi-user.target | 14 | WantedBy=multi-user.target |
diff --git a/meta-multimedia/recipes-multimedia/mycroft/mycroft_19.8.1.bb b/meta-multimedia/recipes-multimedia/mycroft/mycroft_19.8.1.bb index 54c06f5b6..d4ac4096b 100644 --- a/meta-multimedia/recipes-multimedia/mycroft/mycroft_19.8.1.bb +++ b/meta-multimedia/recipes-multimedia/mycroft/mycroft_19.8.1.bb | |||
@@ -24,6 +24,7 @@ inherit systemd | |||
24 | 24 | ||
25 | # Mycroft installs itself on the host | 25 | # Mycroft installs itself on the host |
26 | # Just copy the setup files to the rootfs | 26 | # Just copy the setup files to the rootfs |
27 | # The mycroft-setup service will copy the files to /var/ where we run them from | ||
27 | do_install() { | 28 | do_install() { |
28 | install -d ${D}${libdir}/ | 29 | install -d ${D}${libdir}/ |
29 | cp -r ${B} ${D}${libdir}/mycroft | 30 | cp -r ${B} ${D}${libdir}/mycroft |