summaryrefslogtreecommitdiffstats
path: root/meta-multimedia
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2014-09-29 11:01:30 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2014-10-06 01:07:52 +0200
commitaa084c38d1565ffd60406682792a382fa2d67940 (patch)
tree590396997b381924bf507f81a17a8dbfff87a847 /meta-multimedia
parent5e2948daadacaa95b4c6d81396a20efd5d0dbbdb (diff)
downloadmeta-openembedded-aa084c38d1565ffd60406682792a382fa2d67940.tar.gz
mpg123: Add audio output modules via PACKAGECONFIG
We added heavy dependency list, but lets make it configurable Change-Id: I8d9641fdbbf49c4601d8fbc1fe8ccfae2f6acf2c Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-multimedia')
-rw-r--r--meta-multimedia/recipes-multimedia/mpg123/mpg123_1.19.0.bb18
1 files changed, 17 insertions, 1 deletions
diff --git a/meta-multimedia/recipes-multimedia/mpg123/mpg123_1.19.0.bb b/meta-multimedia/recipes-multimedia/mpg123/mpg123_1.19.0.bb
index 9d9dc8429..e66944692 100644
--- a/meta-multimedia/recipes-multimedia/mpg123/mpg123_1.19.0.bb
+++ b/meta-multimedia/recipes-multimedia/mpg123/mpg123_1.19.0.bb
@@ -6,7 +6,7 @@ HOMEPAGE = "http://mpg123.de/"
6BUGTRACKER = "http://sourceforge.net/p/mpg123/bugs/" 6BUGTRACKER = "http://sourceforge.net/p/mpg123/bugs/"
7SECTION = "multimedia" 7SECTION = "multimedia"
8 8
9DEPENDS = "tslib libsdl jack openal-soft portaudio-v19 audiofile esound" 9DEPENDS = "tslib audiofile"
10 10
11# The options should be mutually exclusive for configuration script. 11# The options should be mutually exclusive for configuration script.
12# If both alsa and pulseaudio are specified (as in the default distro features) 12# If both alsa and pulseaudio are specified (as in the default distro features)
@@ -15,6 +15,21 @@ PACKAGECONFIG_ALSA = "${@base_contains('DISTRO_FEATURES', 'alsa', 'alsa', '', d)
15PACKAGECONFIG ??= "${@base_contains('DISTRO_FEATURES', 'pulseaudio', 'pulseaudio', '${PACKAGECONFIG_ALSA}', d)}" 15PACKAGECONFIG ??= "${@base_contains('DISTRO_FEATURES', 'pulseaudio', 'pulseaudio', '${PACKAGECONFIG_ALSA}', d)}"
16PACKAGECONFIG[pulseaudio] = "--with-default-audio=pulse,,pulseaudio" 16PACKAGECONFIG[pulseaudio] = "--with-default-audio=pulse,,pulseaudio"
17PACKAGECONFIG[alsa] = "--with-default-audio=alsa,,alsa-lib" 17PACKAGECONFIG[alsa] = "--with-default-audio=alsa,,alsa-lib"
18PACKAGECONFIG[sdl] = ",,libsdl"
19PACKAGECONFIG[openal] = ",,openal-soft"
20PACKAGECONFIG[jack] = ",,jack"
21PACKAGECONFIG[portaudio] = ",,portaudio-v19"
22PACKAGECONFIG[esd] = ",,esound"
23
24# Following are possible sound output modules
25#alsa tinyalsa oss coreaudio sndio sun win32 win32_wasapi os2 esd jack portaudio pulse sdl nas arts openal dummy
26AUDIOMODS += "${@base_contains('PACKAGECONFIG', 'alsa', 'alsa', '', d)}"
27AUDIOMODS += "${@base_contains('PACKAGECONFIG', 'pulseaudio', 'pulse', '', d)}"
28AUDIOMODS += "${@base_contains('PACKAGECONFIG', 'sdl', 'sdl', '', d)}"
29AUDIOMODS += "${@base_contains('PACKAGECONFIG', 'openal', 'openal', '', d)}"
30AUDIOMODS += "${@base_contains('PACKAGECONFIG', 'jack', 'jack', '', d)}"
31AUDIOMODS += "${@base_contains('PACKAGECONFIG', 'portaudio', 'portaudio', '', d)}"
32AUDIOMODS += "${@base_contains('PACKAGECONFIG', 'esd', 'esd', '', d)}"
18 33
19LICENSE = "LGPLv2.1" 34LICENSE = "LGPLv2.1"
20LICENSE_FLAGS = "commercial" 35LICENSE_FLAGS = "commercial"
@@ -28,6 +43,7 @@ inherit autotools pkgconfig
28 43
29EXTRA_OECONF = " \ 44EXTRA_OECONF = " \
30 --enable-shared \ 45 --enable-shared \
46 --with-audio='${AUDIOMODS}' \
31 --with-module-suffix=.so \ 47 --with-module-suffix=.so \
32 ${@bb.utils.contains('TUNE_FEATURES', 'neon', '--with-cpu=neon', '', d)} \ 48 ${@bb.utils.contains('TUNE_FEATURES', 'neon', '--with-cpu=neon', '', d)} \
33 ${@bb.utils.contains('TUNE_FEATURES', 'altivec', '--with-cpu=altivec', '', d)} \ 49 ${@bb.utils.contains('TUNE_FEATURES', 'altivec', '--with-cpu=altivec', '', d)} \