diff options
author | Martin Jansa <Martin.Jansa@gmail.com> | 2014-05-05 23:46:11 +0200 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2014-05-07 19:19:20 +0200 |
commit | 3182aa9a1eb76af61b52943507a43cef42ce41ee (patch) | |
tree | d1ece07c8583c04b72ccae6ed3d0de1ebe1da9fa /meta-multimedia | |
parent | 2c313ca01f12b333f1f7ed224627566fbfca336f (diff) | |
download | meta-openembedded-3182aa9a1eb76af61b52943507a43cef42ce41ee.tar.gz |
libmusicbrainz: add dependency on neon-native
* we're building separate native binary make-c-interface which is also checking
for neon with pkg-config, when it fails it's not fatal and configure continues
to configure target version (which finds neon correctly) but failed native
make-c-interface build resultsin this error:
-- Found PkgConfig: /OE/build/oe-core/tmp-eglibc/sysroots/x86_64-linux/usr/bin/pkg-config (found version "0.28")
-- checking for module 'neon'
-- found neon, version 0.30.0
CMake Error at /OE/build/oe-core/tmp-eglibc/sysroots/x86_64-linux/usr/share/cmake-2.8/Modules/FindPackageHandleStandardArgs.cmake:108 (message):
Could NOT find Neon (missing: NEON_LIBRARIES)
Call Stack (most recent call first):
/OE/build/oe-core/tmp-eglibc/sysroots/x86_64-linux/usr/share/cmake-2.8/Modules/FindPackageHandleStandardArgs.cmake:315 (_FPHSA_FAILURE_MESSAGE)
cmake/modules/FindNeon.cmake:19 (FIND_PACKAGE_HANDLE_STANDARD_ARGS)
CMakeLists.txt:22 (FIND_PACKAGE)
-- Configuring incomplete, errors occurred!
See also "/OE/build/oe-core/tmp-eglibc/work/i586-oe-linux/libmusicbrainz/5.0.1+gitAUTOINC+0749dd0a35-r1/git/build-native/CMakeFiles/CMakeOutput.log".
make: *** No rule to make target 'make-c-interface'. Stop.
...
-- Found PkgConfig: /OE/build/oe-core/tmp-eglibc/sysroots/x86_64-linux/usr/bin/pkg-config (found version "0.28")
-- checking for module 'neon'
-- found neon, version 0.30.0
-- Found Neon: /OE/build/oe-core/tmp-eglibc/sysroots/qemux86/usr/lib/libneon.so
CMake Error at src/CMakeLists.txt:19 (INCLUDE):
include could not find load file:
/OE/build/oe-core/tmp-eglibc/work/i586-oe-linux/libmusicbrainz/5.0.1+gitAUTOINC+0749dd0a35-r1/git/build-native/ImportExecutables.cmake
-- Configuring incomplete, errors occurred!
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-multimedia')
-rw-r--r-- | meta-multimedia/recipes-multimedia/musicbrainz/libmusicbrainz_git.bb | 3 |
1 files changed, 1 insertions, 2 deletions
diff --git a/meta-multimedia/recipes-multimedia/musicbrainz/libmusicbrainz_git.bb b/meta-multimedia/recipes-multimedia/musicbrainz/libmusicbrainz_git.bb index 4cc04b815b..a6a4f6a8a6 100644 --- a/meta-multimedia/recipes-multimedia/musicbrainz/libmusicbrainz_git.bb +++ b/meta-multimedia/recipes-multimedia/musicbrainz/libmusicbrainz_git.bb | |||
@@ -3,7 +3,7 @@ DESCRIPTION = "The MusicBrainz client is a library which can be built into other | |||
3 | HOMEPAGE = "http://musicbrainz.org" | 3 | HOMEPAGE = "http://musicbrainz.org" |
4 | LICENSE = "LGPLv2.1+" | 4 | LICENSE = "LGPLv2.1+" |
5 | LIC_FILES_CHKSUM = "file://COPYING.txt;md5=fbc093901857fcd118f065f900982c24" | 5 | LIC_FILES_CHKSUM = "file://COPYING.txt;md5=fbc093901857fcd118f065f900982c24" |
6 | DEPENDS = "expat neon" | 6 | DEPENDS = "expat neon neon-native" |
7 | 7 | ||
8 | PV = "5.0.1+git${SRCPV}" | 8 | PV = "5.0.1+git${SRCPV}" |
9 | PR = "r1" | 9 | PR = "r1" |
@@ -16,7 +16,6 @@ S = "${WORKDIR}/git" | |||
16 | 16 | ||
17 | LDFLAGS_prepend_libc-uclibc = " -lpthread " | 17 | LDFLAGS_prepend_libc-uclibc = " -lpthread " |
18 | 18 | ||
19 | |||
20 | inherit cmake pkgconfig | 19 | inherit cmake pkgconfig |
21 | 20 | ||
22 | do_configure_prepend() { | 21 | do_configure_prepend() { |