summaryrefslogtreecommitdiffstats
path: root/meta-multimedia
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2012-12-21 14:00:46 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-01-18 10:49:43 +0100
commitd3bcb21db84a04bfaaa239f287513ad51bd9f613 (patch)
tree1e8196ed2740b013c84bc97ecf7c0a94eb964e35 /meta-multimedia
parent38a5cf3fa06972992f473027658d5b0cffff3a33 (diff)
downloadmeta-openembedded-d3bcb21db84a04bfaaa239f287513ad51bd9f613.tar.gz
tvheadend: add git version
"Tvheadend is a TV streaming server for Linux supporting DVB-S, DVB-S2, DVB-C, DVB-T, ATSC, IPTV, and Analog video (V4L) as input sources." No startup scripts or config files are currently provided. Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-multimedia')
-rw-r--r--meta-multimedia/recipes-dvb/tvheadend/tvheadend/0001-Move-tvheadend-specific-LD-CFLAGS-into-a-helper-vari.patch92
-rw-r--r--meta-multimedia/recipes-dvb/tvheadend/tvheadend_git.bb30
2 files changed, 122 insertions, 0 deletions
diff --git a/meta-multimedia/recipes-dvb/tvheadend/tvheadend/0001-Move-tvheadend-specific-LD-CFLAGS-into-a-helper-vari.patch b/meta-multimedia/recipes-dvb/tvheadend/tvheadend/0001-Move-tvheadend-specific-LD-CFLAGS-into-a-helper-vari.patch
new file mode 100644
index 000000000..943e1026b
--- /dev/null
+++ b/meta-multimedia/recipes-dvb/tvheadend/tvheadend/0001-Move-tvheadend-specific-LD-CFLAGS-into-a-helper-vari.patch
@@ -0,0 +1,92 @@
1From 2ee64b359464b48f751683faa5ded3ee8200fe90 Mon Sep 17 00:00:00 2001
2From: Koen Kooi <koen@dominion.thruhere.net>
3Date: Fri, 21 Dec 2012 10:15:42 +0100
4Subject: [PATCH] Move tvheadend specific LD/CFLAGS into a helper variable to
5 avoid being overwritten
6
7Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
8
9Upstream-status: Inappropriate [OE specific]
10---
11 Makefile | 20 ++++++++++----------
12 support/configure.inc | 8 ++++----
13 2 files changed, 14 insertions(+), 14 deletions(-)
14
15diff --git a/Makefile b/Makefile
16index 8c6b293..daf5f14 100644
17--- a/Makefile
18+++ b/Makefile
19@@ -27,12 +27,12 @@ PROG = ${BUILDDIR}/tvheadend
20 # Common compiler flags
21 #
22
23-CFLAGS += -Wall -Werror -Wwrite-strings -Wno-deprecated-declarations
24-CFLAGS += -Wmissing-prototypes -fms-extensions
25-CFLAGS += -g -funsigned-char -O2
26-CFLAGS += -D_FILE_OFFSET_BITS=64
27-CFLAGS += -I${BUILDDIR} -I${CURDIR}/src -I${CURDIR}
28-LDFLAGS += -lrt -ldl -lpthread -lm
29+TVH_CFLAGS += -Wall -Werror -Wwrite-strings -Wno-deprecated-declarations
30+TVH_CFLAGS += -Wmissing-prototypes -fms-extensions
31+TVH_CFLAGS += -g -funsigned-char -O2
32+TVH_CFLAGS += -D_FILE_OFFSET_BITS=64
33+TVH_CFLAGS += -I${BUILDDIR} -I${CURDIR}/src -I${CURDIR}
34+TVH_LDFLAGS += -lrt -ldl -lpthread -lm
35
36 #
37 # Other config
38@@ -179,8 +179,8 @@ SRCS-${CONFIG_CWC} += src/ffdecsa/ffdecsa_interface.c \
39 src/ffdecsa/ffdecsa_int.c
40 SRCS-${CONFIG_MMX} += src/ffdecsa/ffdecsa_mmx.c
41 SRCS-${CONFIG_SSE2} += src/ffdecsa/ffdecsa_sse2.c
42-${BUILDDIR}/src/ffdecsa/ffdecsa_mmx.o : CFLAGS += -mmmx
43-${BUILDDIR}/src/ffdecsa/ffdecsa_sse2.o : CFLAGS += -msse2
44+${BUILDDIR}/src/ffdecsa/ffdecsa_mmx.o : TVH_CFLAGS += -mmmx
45+${BUILDDIR}/src/ffdecsa/ffdecsa_sse2.o : TVH_CFLAGS += -msse2
46 endif
47
48 # File bundles
49@@ -217,12 +217,12 @@ all: ${PROG}
50
51 # Binary
52 ${PROG}: $(OBJS) $(ALLDEPS)
53- $(CC) -o $@ $(OBJS) $(CFLAGS) $(LDFLAGS)
54+ $(CC) -o $@ $(OBJS) $(TVH_CFLAGS) $(TVH_LDFLAGS) $(CFLAGS) $(LDFLAGS)
55
56 # Object
57 ${BUILDDIR}/%.o: %.c
58 @mkdir -p $(dir $@)
59- $(CC) -MD -MP $(CFLAGS) -c -o $@ $(CURDIR)/$<
60+ $(CC) -MD -MP $(TVH_CFLAGS) $(CFLAGS) -c -o $@ $(CURDIR)/$<
61
62 # Add-on
63 ${BUILDDIR}/%.so: ${SRCS_EXTRA}
64diff --git a/support/configure.inc b/support/configure.inc
65index 0130880..332511e 100644
66--- a/support/configure.inc
67+++ b/support/configure.inc
68@@ -464,8 +464,8 @@ ifeq (\$(origin CC),default)
69 CC = ${CC}
70 endif
71 PYTHON ?= ${PYTHON}
72-CFLAGS += ${CFLAGS}
73-LDFLAGS += ${LDFLAGS}
74+TVH_CFLAGS += ${CFLAGS}
75+TVH_LDFLAGS += ${LDFLAGS}
76 prefix = ${prefix}
77 bindir = ${bindir}
78 mandir = ${mandir}
79@@ -482,8 +482,8 @@ EOF
80 # Add package config
81 for pkg in ${PACKAGES[*]}; do
82 cat >>${CONFIG_MK} <<EOF
83-LDFLAGS += $(pkg-config --libs $pkg)
84-CFLAGS += $(pkg-config --cflags $pkg)
85+TVH_LDFLAGS += $(pkg-config --libs $pkg)
86+TVH_CFLAGS += $(pkg-config --cflags $pkg)
87 EOF
88 done
89
90--
911.7.7.6
92
diff --git a/meta-multimedia/recipes-dvb/tvheadend/tvheadend_git.bb b/meta-multimedia/recipes-dvb/tvheadend/tvheadend_git.bb
new file mode 100644
index 000000000..212bca16e
--- /dev/null
+++ b/meta-multimedia/recipes-dvb/tvheadend/tvheadend_git.bb
@@ -0,0 +1,30 @@
1SUMMARY = "Tvheadend TV streaming server"
2HOMEPAGE = "https://www.lonelycoder.com/redmine/projects/tvheadend"
3
4DEPENDS = "avahi zlib openssl python-native"
5
6LICENSE = "GPLv3+"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=9eef91148a9b14ec7f9df333daebc746"
8
9SRC_URI = "git://github.com/tvheadend/tvheadend.git \
10 file://0001-Move-tvheadend-specific-LD-CFLAGS-into-a-helper-vari.patch \
11 "
12SRCREV = "a420c83a0e0d2c31c2c15d0fec6fedc3f5a36dfe"
13PV = "3.3"
14
15S = "${WORKDIR}/git"
16
17do_configure() {
18 ./configure --prefix=${prefix} \
19 --libdir=${libdir} \
20 --bindir=${bindir} \
21 --datadir=${datadir} \
22 --arch=${TARGET_ARCH} \
23 --disable-bundle
24}
25
26do_install() {
27 oe_runmake install DESTDIR=${D}
28}
29
30FILES_${PN} += "${datadir}/${BPN}"