summaryrefslogtreecommitdiffstats
path: root/meta-multimedia
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2012-10-11 21:46:02 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2012-10-16 09:59:08 +0200
commit7eb2c6f8459fdcad5eb0f0dc2d8ca17a327dc0f6 (patch)
tree0d9956cd5312c7007bc4571b20d7716676c03303 /meta-multimedia
parenta660f4a0289884f516ed85a75a25c722e31e88c9 (diff)
downloadmeta-openembedded-7eb2c6f8459fdcad5eb0f0dc2d8ca17a327dc0f6.tar.gz
xbmc: Fix serveral build errors and install missing dependencies
This allow the package to build fine. On the test board it didn't show anything in display but it seems to be hardware specific issue. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-multimedia')
-rw-r--r--meta-multimedia/recipes-mediacentre/xbmc/xbmc/configure.in-Avoid-running-code.patch32
-rw-r--r--meta-multimedia/recipes-mediacentre/xbmc/xbmc_git.bb28
2 files changed, 50 insertions, 10 deletions
diff --git a/meta-multimedia/recipes-mediacentre/xbmc/xbmc/configure.in-Avoid-running-code.patch b/meta-multimedia/recipes-mediacentre/xbmc/xbmc/configure.in-Avoid-running-code.patch
new file mode 100644
index 000000000..5c1405982
--- /dev/null
+++ b/meta-multimedia/recipes-mediacentre/xbmc/xbmc/configure.in-Avoid-running-code.patch
@@ -0,0 +1,32 @@
1From cfd851660a594801a591e80dc820c65cb7bd7836 Mon Sep 17 00:00:00 2001
2From: Otavio Salvador <otavio@ossystems.com.br>
3Date: Sat, 6 Oct 2012 06:40:03 -0300
4Subject: [PATCH] configure.in: Avoid running code or we break cross-compile
5
6Upstream-Status: Backport [similar change done for 12.0]
7
8Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
9---
10 configure.in | 6 +-----
11 1 files changed, 1 insertions(+), 5 deletions(-)
12
13diff --git a/configure.in b/configure.in
14index ef94683..d7efcb0 100755
15--- a/configure.in
16+++ b/configure.in
17@@ -1246,11 +1246,7 @@ if test "$use_external_ffmpeg" = "yes"; then
18 AC_DEFINE([USE_EXTERNAL_FFMPEG], [1], [Whether to use external FFmpeg libraries.])
19
20 # Disable vdpau support if external libavcodec doesn't have it
21- AC_RUN_IFELSE(
22- AC_LANG_PROGRAM([[#include <libavcodec/avcodec.h>]],
23- [[avcodec_register_all();
24- AVCodec *codec = avcodec_find_decoder_by_name("vc1_vdpau");
25- return (codec) ? 0 : 1;]]),,
26+ AC_CHECK_LIB([avcodec], [ff_vdpau_vc1_decode_picture],,
27 [if test "x$use_vdpau" = "xyes"; then
28 AC_MSG_ERROR($ffmpeg_vdpau_not_supported)
29 else
30--
311.7.2.5
32
diff --git a/meta-multimedia/recipes-mediacentre/xbmc/xbmc_git.bb b/meta-multimedia/recipes-mediacentre/xbmc/xbmc_git.bb
index f0ce7cf15..74bf71066 100644
--- a/meta-multimedia/recipes-mediacentre/xbmc/xbmc_git.bb
+++ b/meta-multimedia/recipes-mediacentre/xbmc/xbmc_git.bb
@@ -3,7 +3,7 @@ DESCRIPTION = "XBMC Media Center"
3LICENSE = "GPLv2" 3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://LICENSE.GPL;md5=6eb631b6da7fdb01508a80213ffc35ff" 4LIC_FILES_CHKSUM = "file://LICENSE.GPL;md5=6eb631b6da7fdb01508a80213ffc35ff"
5 5
6DEPENDS = "libusb1 libcec libplist expat yajl gperf-native libxmu fribidi mpeg2dec ffmpeg samba fontconfig curl python libass libmodplug libmicrohttpd wavpack libmms cmake-native libsdl-image libsdl-mixer virtual/egl mysql5 sqlite3 libmms faad2 libcdio libpcre boost lzo enca avahi libsamplerate0 libxinerama libxrandr libxtst bzip2 virtual/libsdl jasper zip-native zlib" 6DEPENDS = "libusb1 libcec libplist expat yajl gperf-native libxmu fribidi mpeg2dec ffmpeg samba fontconfig curl python libass libmodplug libmicrohttpd wavpack libmms cmake-native libsdl-image libsdl-mixer virtual/egl mysql5 sqlite3 libmms faad2 libcdio libpcre boost lzo enca avahi libsamplerate0 libxinerama libxrandr libxtst bzip2 virtual/libsdl jasper zip-native zlib libtinyxml"
7#require recipes/egl/egl.inc 7#require recipes/egl/egl.inc
8 8
9SRCREV = "82388d55dae79cbb2e486e307e23202e76a43efa" 9SRCREV = "82388d55dae79cbb2e486e307e23202e76a43efa"
@@ -15,12 +15,17 @@ SRC_URI = "git://github.com/xbmc/xbmc.git;branch=eden;protocol=git \
15 file://0001-configure-don-t-run-python-distutils-to-find-STAGING.patch \ 15 file://0001-configure-don-t-run-python-distutils-to-find-STAGING.patch \
16 file://0002-Revert-fixed-ios-Add-memory-barriers-to-atomic-Add-S.patch \ 16 file://0002-Revert-fixed-ios-Add-memory-barriers-to-atomic-Add-S.patch \
17 file://0003-Revert-fixed-ios-Add-memory-barriers-to-cas-assembly.patch \ 17 file://0003-Revert-fixed-ios-Add-memory-barriers-to-cas-assembly.patch \
18 file://configure.in-Avoid-running-code.patch \
18 " 19 "
19 20
20inherit autotools gettext python-dir 21inherit autotools gettext python-dir
21 22
22S = "${WORKDIR}/git" 23S = "${WORKDIR}/git"
23 24
25CACHED_CONFIGUREVARS += " \
26 ac_cv_path_PYTHON="${STAGING_BINDIR_NATIVE}/python-native/python" \
27"
28
24EXTRA_OECONF = " \ 29EXTRA_OECONF = " \
25 --disable-rpath \ 30 --disable-rpath \
26 --enable-gles \ 31 --enable-gles \
@@ -30,6 +35,11 @@ EXTRA_OECONF = " \
30 --enable-external-libraries \ 35 --enable-external-libraries \
31" 36"
32 37
38FULL_OPTIMIZATION_armv7a = "-fexpensive-optimizations -fomit-frame-pointer -O4 -ffast-math"
39BUILD_OPTIMIZATION = "${FULL_OPTIMIZATION}"
40
41EXTRA_OECONF_append_armv7a = "--cpu=cortex-a8"
42
33# for python modules 43# for python modules
34export HOST_SYS 44export HOST_SYS
35export BUILD_SYS 45export BUILD_SYS
@@ -45,19 +55,17 @@ do_configure() {
45PARALLEL_MAKE = "" 55PARALLEL_MAKE = ""
46 56
47do_compile_prepend() { 57do_compile_prepend() {
48
49 sed -i -e 's:-rpath \$(libdir)::g' lib/libid3tag/libid3tag/Makefile
50
51 for i in $(find . -name "Makefile") ; do 58 for i in $(find . -name "Makefile") ; do
52 sed -i -e 's:I/usr/include:I${STAGING_INCDIR}:g' -e 's:-rpath \$(libdir):-rpath ${STAGING_LIBDIR}:g' $i 59 sed -i -e 's:I/usr/include:I${STAGING_INCDIR}:g' $i
53 done 60 done
54 61
55 for i in $(find . -name "*.mak*") ; do 62 for i in $(find . -name "*.mak*" -o -name "Makefile") ; do
56 sed -i -e 's:I/usr/include:I${STAGING_INCDIR}:g' -e 's:-rpath \$(libdir)::g' $i 63 sed -i -e 's:I/usr/include:I${STAGING_INCDIR}:g' -e 's:-rpath \$(libdir):-rpath ${libdir}:g' $i
57 done 64 done
58 sed -i -e 's:I/usr/include:I${STAGING_INCDIR}:g' -e 's:-rpath \$(libdir)::g' ${S}/Makefile
59} 65}
60 66
67INSANE_SKIP_${PN} = "rpaths"
68
61# on ARM architectures xbmc will use GLES which will make the regular wrapper fail, so start it directly 69# on ARM architectures xbmc will use GLES which will make the regular wrapper fail, so start it directly
62do_install_append_arm() { 70do_install_append_arm() {
63 sed -i -e 's:Exec=xbmc:Exec=${libdir}/xbmc/xbmc.bin:g' ${D}${datadir}/applications/xbmc.desktop 71 sed -i -e 's:Exec=xbmc:Exec=${libdir}/xbmc/xbmc.bin:g' ${D}${datadir}/applications/xbmc.desktop
@@ -71,7 +79,7 @@ RRECOMMENDS_${PN}_append = " libcec \
71 python \ 79 python \
72 python-lang \ 80 python-lang \
73 python-re \ 81 python-re \
82 python-netclient \
83 libcurl \
74 " 84 "
75RRECOMMENDS_${PN}_append_libc-glibc = " glibc-charmap-ibm850 glibc-gconv-ibm850" 85RRECOMMENDS_${PN}_append_libc-glibc = " glibc-charmap-ibm850 glibc-gconv-ibm850"
76
77