summaryrefslogtreecommitdiffstats
path: root/meta-multimedia
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2013-05-02 06:04:20 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-05-03 16:12:03 +0200
commitc90d009eb40d0610583346c0ba19264377d50c5e (patch)
tree231b0d07923a286bbec6e2203ef14a7cb82f8ac2 /meta-multimedia
parent6dc8ea3a38dd13507a6558406e4aeebf1b048e76 (diff)
downloadmeta-openembedded-c90d009eb40d0610583346c0ba19264377d50c5e.tar.gz
xbmc: add patch to make 'ld-is-gold' work with configure
The custom XBMC XB_FIND_SONAME macro doesn't work with the gold linker, backport a patch to fix it Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-multimedia')
-rw-r--r--meta-multimedia/recipes-mediacentre/xbmc/xbmc/0004-configure-cope-with-ld-is-gold-DISTRO_FEATURE.patch43
-rw-r--r--meta-multimedia/recipes-mediacentre/xbmc/xbmc_git.bb4
2 files changed, 47 insertions, 0 deletions
diff --git a/meta-multimedia/recipes-mediacentre/xbmc/xbmc/0004-configure-cope-with-ld-is-gold-DISTRO_FEATURE.patch b/meta-multimedia/recipes-mediacentre/xbmc/xbmc/0004-configure-cope-with-ld-is-gold-DISTRO_FEATURE.patch
new file mode 100644
index 000000000..345e20ee1
--- /dev/null
+++ b/meta-multimedia/recipes-mediacentre/xbmc/xbmc/0004-configure-cope-with-ld-is-gold-DISTRO_FEATURE.patch
@@ -0,0 +1,43 @@
1From fd8f73826240aae543a41a2bfeea0056e2fe594d Mon Sep 17 00:00:00 2001
2From: Koen Kooi <koen@dominion.thruhere.net>
3Date: Mon, 11 Mar 2013 11:04:29 +0100
4Subject: [PATCH] configure: cope with ld-is-gold DISTRO_FEATURE
5
6Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
7---
8
9Upstream-Stature: backport
10
11 configure.in | 12 +++++++-----
12 1 files changed, 7 insertions(+), 5 deletions(-)
13
14diff --git a/configure.in b/configure.in
15index ef94683..c8b459b 100755
16--- a/configure.in
17+++ b/configure.in
18@@ -18,9 +18,14 @@ tolower(){
19 # check for library basenames
20 AC_DEFUN([XB_FIND_SONAME],
21 [
22+ #set -x
23 if [[ "$host_vendor" != "apple" ]]; then
24 AC_MSG_CHECKING([for lib$2 soname])
25 $1_FILENAME=$($CC -nostdlib -o /dev/null $LDFLAGS -l$2 -Wl,-M 2>/dev/null | grep "^LOAD.*$2" | awk '{V=2; print $V}')
26+ if [[ -z $$1_FILENAME ]]; then
27+ #try gold linker syntax
28+ $1_FILENAME=$($CC -nostdlib -o /dev/null $LDFLAGS -l$2 -Wl,-t 3>&1 1>&2 2>&3 | grep "$2")
29+ fi
30 if [[ ! -z $$1_FILENAME ]]; then
31 $1_SONAME=$(objdump -p $$1_FILENAME | grep "SONAME.*$2" | awk '{V=2; print $V}')
32 fi
33@@ -55,6 +60,7 @@ AC_DEFUN([XB_FIND_SONAME],
34 AC_MSG_RESULT([$$1_SONAME])
35 AC_SUBST($1_SONAME)
36 fi
37+ #set +x
38 ])
39
40 # Function to push and pop libs and includes for a command
41--
421.7.7.6
43
diff --git a/meta-multimedia/recipes-mediacentre/xbmc/xbmc_git.bb b/meta-multimedia/recipes-mediacentre/xbmc/xbmc_git.bb
index 605348959..e6600c1e5 100644
--- a/meta-multimedia/recipes-mediacentre/xbmc/xbmc_git.bb
+++ b/meta-multimedia/recipes-mediacentre/xbmc/xbmc_git.bb
@@ -15,6 +15,7 @@ SRC_URI = "git://github.com/xbmc/xbmc.git;branch=eden;protocol=git \
15 file://0001-configure-don-t-run-python-distutils-to-find-STAGING.patch \ 15 file://0001-configure-don-t-run-python-distutils-to-find-STAGING.patch \
16 file://0002-Revert-fixed-ios-Add-memory-barriers-to-atomic-Add-S.patch \ 16 file://0002-Revert-fixed-ios-Add-memory-barriers-to-atomic-Add-S.patch \
17 file://0003-Revert-fixed-ios-Add-memory-barriers-to-cas-assembly.patch \ 17 file://0003-Revert-fixed-ios-Add-memory-barriers-to-cas-assembly.patch \
18 file://0004-configure-cope-with-ld-is-gold-DISTRO_FEATURE.patch \
18 file://configure.in-Avoid-running-code.patch \ 19 file://configure.in-Avoid-running-code.patch \
19" 20"
20 21
@@ -22,6 +23,9 @@ inherit autotools gettext python-dir
22 23
23S = "${WORKDIR}/git" 24S = "${WORKDIR}/git"
24 25
26# breaks compilation
27CCACHE = ""
28
25CACHED_CONFIGUREVARS += " \ 29CACHED_CONFIGUREVARS += " \
26 ac_cv_path_PYTHON="${STAGING_BINDIR_NATIVE}/python-native/python" \ 30 ac_cv_path_PYTHON="${STAGING_BINDIR_NATIVE}/python-native/python" \
27" 31"