diff options
author | Fabien Lahoudere <fabien.lahoudere@collabora.co.uk> | 2017-09-08 15:34:15 +0200 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2017-09-13 11:13:22 +0200 |
commit | e890ecb1d2bb4f2d23f4d5cc7e40e0b1806da984 (patch) | |
tree | b04959e45e750d72c5035b096fcc3f1106e112fc /meta-multimedia/recipes-multimedia | |
parent | 09a285db6125f923d6a7dcaf6a31c898c811238e (diff) | |
download | meta-openembedded-e890ecb1d2bb4f2d23f4d5cc7e40e0b1806da984.tar.gz |
gerbera: Add recipe
Gerbera is a UPnP media server which allows you to stream your digital media
through your home network and consume it on a variety of UPnP compatible devices.
Gerbera is based on MediaTomb 12.1 which is dead upstream, so this is an attempt
to kick it back into life.
Signed-off-by: Fabien Lahoudere <fabien.lahoudere@collabora.co.uk>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-multimedia/recipes-multimedia')
-rw-r--r-- | meta-multimedia/recipes-multimedia/gerbera/files/gerbera.service | 13 | ||||
-rw-r--r-- | meta-multimedia/recipes-multimedia/gerbera/gerbera_git.bb | 34 |
2 files changed, 47 insertions, 0 deletions
diff --git a/meta-multimedia/recipes-multimedia/gerbera/files/gerbera.service b/meta-multimedia/recipes-multimedia/gerbera/files/gerbera.service new file mode 100644 index 000000000..1b5a3ad3e --- /dev/null +++ b/meta-multimedia/recipes-multimedia/gerbera/files/gerbera.service | |||
@@ -0,0 +1,13 @@ | |||
1 | [Unit] | ||
2 | Description=Start Gerbera, an UPnP media server | ||
3 | After=multi-user.target network-online.target | ||
4 | Wants=network-online.target | ||
5 | |||
6 | [Service] | ||
7 | ExecStart=/usr/bin/gerbera | ||
8 | Environment='HOME=/root' | ||
9 | Type=simple | ||
10 | RemainAfterExit=yes | ||
11 | |||
12 | [Install] | ||
13 | WantedBy=multi-user.target \ No newline at end of file | ||
diff --git a/meta-multimedia/recipes-multimedia/gerbera/gerbera_git.bb b/meta-multimedia/recipes-multimedia/gerbera/gerbera_git.bb new file mode 100644 index 000000000..2bbedc0d1 --- /dev/null +++ b/meta-multimedia/recipes-multimedia/gerbera/gerbera_git.bb | |||
@@ -0,0 +1,34 @@ | |||
1 | Description = "Gerbera - An UPnP media server" | ||
2 | |||
3 | LICENSE = "GPLv2" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE.md;md5=25cdec9afe3f1f26212ead6bd2f7fac8" | ||
5 | |||
6 | SRC_URI = "git://github.com/v00d00/gerbera.git;protocol=https \ | ||
7 | file://gerbera.service " | ||
8 | |||
9 | |||
10 | # Modify these as desired | ||
11 | PV = "1.0+git${SRCPV}" | ||
12 | SRCREV = "4435b165d121195aefd67d0287f7f9349e181d45" | ||
13 | |||
14 | S = "${WORKDIR}/git" | ||
15 | |||
16 | DEPENDS = "expat zlib curl libupnp e2fsprogs sqlite3 taglib " | ||
17 | RDEPENDS_${PN} = "expat zlib curl libupnp e2fsprogs taglib " | ||
18 | |||
19 | SYSTEMD_SERVICE_${PN} = "gerbera.service" | ||
20 | SYSTEMD_AUTO_ENABLE = "enable" | ||
21 | |||
22 | inherit cmake systemd | ||
23 | |||
24 | EXTRA_OECMAKE = "-DWITH_JS=FALSE -DWITH_TAGLIB=FALSE -DWITH_MAGIC=FALSE -DWITH_EXIF=FALSE -DLIBUUID_INCLUDE_DIRS=${WORKDIR}/recipe-sysroot/usr/include -DLIBUUID_LIBRARIES=-luuid" | ||
25 | |||
26 | do_install_append() { | ||
27 | install -d ${D}/root/.config/ | ||
28 | install -d ${D}${systemd_system_unitdir} | ||
29 | install -m 0644 ${WORKDIR}/gerbera.service ${D}${systemd_system_unitdir}/ | ||
30 | } | ||
31 | |||
32 | FILES_${PN} += " /root/.config/ \ | ||
33 | ${systemd_system_unitdir}/* \ | ||
34 | " \ No newline at end of file | ||