summaryrefslogtreecommitdiffstats
path: root/meta-multimedia/recipes-multimedia
diff options
context:
space:
mode:
authorCarlos Rafael Giani <dv@pseudoterminal.org>2018-04-15 16:15:26 +0200
committerArmin Kuster <akuster808@gmail.com>2018-05-01 18:12:50 -0700
commit5401466fba7d4b72ab8dea2ace8591eac011642f (patch)
treee9d818432d597b6386c5c774dfb371f97d8b7e8d /meta-multimedia/recipes-multimedia
parent97c09fd27eef86864c18f899dd0f3a8c57dad32a (diff)
downloadmeta-openembedded-5401466fba7d4b72ab8dea2ace8591eac011642f.tar.gz
tinyalsa: add recipe
TinyALSA is a small library to interface with ALSA in the Linux kernel. Signed-off-by: Carlos Rafael Giani <dv@pseudoterminal.org> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-multimedia/recipes-multimedia')
-rw-r--r--meta-multimedia/recipes-multimedia/tinyalsa/tinyalsa_1.1.1.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta-multimedia/recipes-multimedia/tinyalsa/tinyalsa_1.1.1.bb b/meta-multimedia/recipes-multimedia/tinyalsa/tinyalsa_1.1.1.bb
new file mode 100644
index 000000000..fa5449ff6
--- /dev/null
+++ b/meta-multimedia/recipes-multimedia/tinyalsa/tinyalsa_1.1.1.bb
@@ -0,0 +1,28 @@
1DESCRIPTION = "TinyALSA is a small library to interface with ALSA in \
2the Linux kernel. It is a lightweight alternative to libasound."
3HOMEPAGE = "https://github.com/tinyalsa/tinyalsa"
4SECTION = "libs/multimedia"
5
6LICENSE = "BSD-3-Clause"
7LIC_FILES_CHKSUM = "file://NOTICE;md5=dbdefe400d894b510a9de14813181d0b"
8
9SRC_URI = "https://github.com/tinyalsa/tinyalsa/archive/${PV}.tar.gz"
10SRC_URI[md5sum] = "ec5c1cc175fcb8c9d3d0adcececf10a9"
11SRC_URI[sha256sum] = "d92b438cea348ae316c4b2cbf367b4f01ed821a947e6a34d813624e9e3c936c1"
12
13do_configure() {
14 :
15}
16
17do_compile() {
18 oe_runmake CC='${CC}' LD='${CC}' AR='${AR}'
19}
20
21do_install() {
22 oe_runmake install \
23 PREFIX="${prefix}" DESTDIR="${D}" INCDIR="${includedir}/tinyalsa" \
24 LIBDIR="${libdir}" BINDIR="${bindir}" MANDIR="${mandir}"
25}
26
27PACKAGES =+ "${PN}-tools"
28FILES_${PN}-tools = "${bindir}/*"