diff options
author | Martin Jansa <Martin.Jansa@gmail.com> | 2014-02-01 07:49:19 +0100 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2014-02-18 09:22:38 +0100 |
commit | 30cd9379972711746b057e49ededb26749bb51a1 (patch) | |
tree | 42cf0afcc6af16cb2c9a85c4a2a87f56e7642824 /meta-multimedia/recipes-multimedia | |
parent | 38b3de4ad59ffe59ba74b7357f9899271edf1d5f (diff) | |
download | meta-openembedded-30cd9379972711746b057e49ededb26749bb51a1.tar.gz |
vlc: fix build with kernel headers 3.9 and newer
* V4L2_CID_HCENTER and V4L2_CID_VCENTER removed from linux v3.9
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-multimedia/recipes-multimedia')
-rw-r--r-- | meta-multimedia/recipes-multimedia/vlc/vlc/0001-V4L2-mark-horizontal-and-vertical-center-controls-ob.patch | 53 | ||||
-rw-r--r-- | meta-multimedia/recipes-multimedia/vlc/vlc_1.1.11.bb | 2 |
2 files changed, 55 insertions, 0 deletions
diff --git a/meta-multimedia/recipes-multimedia/vlc/vlc/0001-V4L2-mark-horizontal-and-vertical-center-controls-ob.patch b/meta-multimedia/recipes-multimedia/vlc/vlc/0001-V4L2-mark-horizontal-and-vertical-center-controls-ob.patch new file mode 100644 index 000000000..81233bffe --- /dev/null +++ b/meta-multimedia/recipes-multimedia/vlc/vlc/0001-V4L2-mark-horizontal-and-vertical-center-controls-ob.patch | |||
@@ -0,0 +1,53 @@ | |||
1 | From 4da99e58bd1b06267793ef728a368e4032789376 Mon Sep 17 00:00:00 2001 | ||
2 | From: =?UTF-8?q?R=C3=A9mi=20Denis-Courmont?= <remi@remlab.net> | ||
3 | Date: Sat, 1 Oct 2011 22:58:21 +0300 | ||
4 | Subject: [PATCH] V4L2: mark horizontal and vertical center controls obsolete | ||
5 | |||
6 | Upstream-Status: Backport | ||
7 | |||
8 | Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> | ||
9 | |||
10 | They were deprecated in Linux version 2.6.26. | ||
11 | --- | ||
12 | modules/access/v4l2/controls.c | 2 -- | ||
13 | modules/access/v4l2/video.c | 12 ++---------- | ||
14 | 2 files changed, 2 insertions(+), 12 deletions(-) | ||
15 | |||
16 | diff -uNr vlc-1.1.11.orig/modules/access/v4l2.c vlc-1.1.11/modules/access/v4l2.c | ||
17 | --- vlc-1.1.11.orig/modules/access/v4l2.c 2011-06-03 19:59:40.000000000 +0200 | ||
18 | +++ vlc-1.1.11/modules/access/v4l2.c 2014-02-01 07:38:28.905142516 +0100 | ||
19 | @@ -159,12 +159,6 @@ | ||
20 | #define VFLIP_TEXT N_( "Vertical flip" ) | ||
21 | #define VFLIP_LONGTEXT N_( \ | ||
22 | "Flip the video vertically (if supported by the v4l2 driver)." ) | ||
23 | -#define HCENTER_TEXT N_( "Horizontal centering" ) | ||
24 | -#define HCENTER_LONGTEXT N_( \ | ||
25 | - "Set the camera's horizontal centering (if supported by the v4l2 driver)." ) | ||
26 | -#define VCENTER_TEXT N_( "Vertical centering" ) | ||
27 | -#define VCENTER_LONGTEXT N_( \ | ||
28 | - "Set the camera's vertical centering (if supported by the v4l2 driver)." ) | ||
29 | |||
30 | #define AUDIO_VOLUME_TEXT N_( "Volume" ) | ||
31 | #define AUDIO_VOLUME_LONGTEXT N_( \ | ||
32 | @@ -351,10 +345,8 @@ | ||
33 | HFLIP_LONGTEXT, true ) | ||
34 | add_integer( CFG_PREFIX "vflip", -1, NULL, VFLIP_TEXT, | ||
35 | VFLIP_LONGTEXT, true ) | ||
36 | - add_integer( CFG_PREFIX "hcenter", -1, NULL, HCENTER_TEXT, | ||
37 | - HCENTER_LONGTEXT, true ) | ||
38 | - add_integer( CFG_PREFIX "vcenter", -1, NULL, VCENTER_TEXT, | ||
39 | - VCENTER_LONGTEXT, true ) | ||
40 | + add_obsolete_integer( CFG_PREFIX "hcenter" ) /* since Linux 2.6.26 */ | ||
41 | + add_obsolete_integer( CFG_PREFIX "vcenter" ) /* since Linux 2.6.26 */ | ||
42 | add_integer( CFG_PREFIX "audio-volume", -1, NULL, AUDIO_VOLUME_TEXT, | ||
43 | AUDIO_VOLUME_LONGTEXT, true ) | ||
44 | add_integer( CFG_PREFIX "audio-balance", -1, NULL, AUDIO_BALANCE_TEXT, | ||
45 | @@ -518,8 +510,6 @@ | ||
46 | { "gain", V4L2_CID_GAIN }, | ||
47 | { "hflip", V4L2_CID_HFLIP }, | ||
48 | { "vflip", V4L2_CID_VFLIP }, | ||
49 | - { "hcenter", V4L2_CID_HCENTER }, | ||
50 | - { "vcenter", V4L2_CID_VCENTER }, | ||
51 | { NULL, 0 } | ||
52 | }; | ||
53 | |||
diff --git a/meta-multimedia/recipes-multimedia/vlc/vlc_1.1.11.bb b/meta-multimedia/recipes-multimedia/vlc/vlc_1.1.11.bb index 11ecaa43a..e88e9647d 100644 --- a/meta-multimedia/recipes-multimedia/vlc/vlc_1.1.11.bb +++ b/meta-multimedia/recipes-multimedia/vlc/vlc_1.1.11.bb | |||
@@ -5,6 +5,8 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=ed7e492ee44e70125a5d42e118354a13" | |||
5 | 5 | ||
6 | require vlc.inc | 6 | require vlc.inc |
7 | 7 | ||
8 | SRC_URI += "file://0001-V4L2-mark-horizontal-and-vertical-center-controls-ob.patch" | ||
9 | |||
8 | PR = "r4" | 10 | PR = "r4" |
9 | 11 | ||
10 | # work around build failure | 12 | # work around build failure |