diff options
author | Alexander Kanavin <alex.kanavin@gmail.com> | 2022-01-22 22:46:50 +0100 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2022-01-25 09:13:09 -0800 |
commit | e9f5b21fd54a1fab455eff96e15d8c32a235fa38 (patch) | |
tree | cbae80ed09ff8c4a7e09b106f4f7a21e4620460c /meta-multimedia/recipes-multimedia | |
parent | 605ffa23020ec495b68f17df5a6b21b58ef881c1 (diff) | |
download | meta-openembedded-e9f5b21fd54a1fab455eff96e15d8c32a235fa38.tar.gz |
mpd: update 0.22.9 -> 0.23.5
This resolves ffmpeg 5.0 issues.
Signed-off-by: Alexander Kanavin <alex@linutronix.de>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-multimedia/recipes-multimedia')
-rw-r--r-- | meta-multimedia/recipes-multimedia/musicpd/mpd/0001-include-utility-for-std-forward.patch | 43 | ||||
-rw-r--r-- | meta-multimedia/recipes-multimedia/musicpd/mpd_0.23.5.bb (renamed from meta-multimedia/recipes-multimedia/musicpd/mpd_0.22.9.bb) | 13 |
2 files changed, 6 insertions, 50 deletions
diff --git a/meta-multimedia/recipes-multimedia/musicpd/mpd/0001-include-utility-for-std-forward.patch b/meta-multimedia/recipes-multimedia/musicpd/mpd/0001-include-utility-for-std-forward.patch deleted file mode 100644 index 68ccb6583..000000000 --- a/meta-multimedia/recipes-multimedia/musicpd/mpd/0001-include-utility-for-std-forward.patch +++ /dev/null | |||
@@ -1,43 +0,0 @@ | |||
1 | From 9bb962148672a3c20fb0119d7f71789b8ef3dc02 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Tue, 29 Jun 2021 19:31:34 -0700 | ||
4 | Subject: [PATCH] include <utility> for std::forward | ||
5 | |||
6 | Fixes | ||
7 | ../git/src/Log.hxx:121:42: error: no member named 'forward' in namespace 'std' | ||
8 | LogFormat(LogLevel::ERROR, e, fmt, std::forward<Args>(args)...); | ||
9 | |||
10 | Upstream-Status: Submitted [https://github.com/MusicPlayerDaemon/MPD/pull/1201] | ||
11 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
12 | --- | ||
13 | src/Log.hxx | 1 + | ||
14 | src/lib/expat/ExpatParser.hxx | 1 + | ||
15 | 2 files changed, 2 insertions(+) | ||
16 | |||
17 | diff --git a/src/Log.hxx b/src/Log.hxx | ||
18 | index a295ed9f6..87097b086 100644 | ||
19 | --- a/src/Log.hxx | ||
20 | +++ b/src/Log.hxx | ||
21 | @@ -24,6 +24,7 @@ | ||
22 | #include "util/Compiler.h" | ||
23 | |||
24 | #include <exception> | ||
25 | +#include <utility> | ||
26 | |||
27 | class Domain; | ||
28 | |||
29 | diff --git a/src/lib/expat/ExpatParser.hxx b/src/lib/expat/ExpatParser.hxx | ||
30 | index e1723d109..4b5221e89 100644 | ||
31 | --- a/src/lib/expat/ExpatParser.hxx | ||
32 | +++ b/src/lib/expat/ExpatParser.hxx | ||
33 | @@ -25,6 +25,7 @@ | ||
34 | #include <expat.h> | ||
35 | |||
36 | #include <stdexcept> | ||
37 | +#include <utility> | ||
38 | |||
39 | class InputStream; | ||
40 | |||
41 | -- | ||
42 | 2.32.0 | ||
43 | |||
diff --git a/meta-multimedia/recipes-multimedia/musicpd/mpd_0.22.9.bb b/meta-multimedia/recipes-multimedia/musicpd/mpd_0.23.5.bb index 4eac25674..3c6f3e41c 100644 --- a/meta-multimedia/recipes-multimedia/musicpd/mpd_0.22.9.bb +++ b/meta-multimedia/recipes-multimedia/musicpd/mpd_0.23.5.bb | |||
@@ -15,14 +15,13 @@ DEPENDS += " \ | |||
15 | icu \ | 15 | icu \ |
16 | dbus \ | 16 | dbus \ |
17 | expat \ | 17 | expat \ |
18 | fmt \ | ||
18 | " | 19 | " |
19 | 20 | ||
20 | SRC_URI = " \ | 21 | SRC_URI = "git://github.com/MusicPlayerDaemon/MPD;branch=v0.23.x;protocol=https \ |
21 | git://github.com/MusicPlayerDaemon/MPD;branch=v0.22.x;protocol=https \ | 22 | file://mpd.conf.in \ |
22 | file://0001-include-utility-for-std-forward.patch \ | 23 | " |
23 | file://mpd.conf.in \ | 24 | SRCREV = "df4b6b92f2c4bba1b55fe0a5559b19808abb28ff" |
24 | " | ||
25 | SRCREV = "18628bf89ebfa5a806971479a71cf9b5764e500e" | ||
26 | S = "${WORKDIR}/git" | 25 | S = "${WORKDIR}/git" |
27 | 26 | ||
28 | EXTRA_OEMESON += "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '-Dsystemd=enabled -Dsystemd_system_unit_dir=${systemd_system_unitdir} -Dsystemd_user_unit_dir=${systemd_system_unitdir}', '-Dsystemd=disabled', d)}" | 27 | EXTRA_OEMESON += "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '-Dsystemd=enabled -Dsystemd_system_unit_dir=${systemd_system_unitdir} -Dsystemd_user_unit_dir=${systemd_system_unitdir}', '-Dsystemd=disabled', d)}" |
@@ -63,7 +62,7 @@ PACKAGECONFIG[oss] = "-Doss=enabled,-Doss=disabled," | |||
63 | PACKAGECONFIG[recorder] = "-Drecorder=true,-Drecorder=false" | 62 | PACKAGECONFIG[recorder] = "-Drecorder=true,-Drecorder=false" |
64 | PACKAGECONFIG[smb] = "-Dsmbclient=enabled,-Dsmbclient=disabled,samba" | 63 | PACKAGECONFIG[smb] = "-Dsmbclient=enabled,-Dsmbclient=disabled,samba" |
65 | PACKAGECONFIG[sndfile] = "-Dsndfile=enabled,-Dsndfile=disabled,libsndfile1" | 64 | PACKAGECONFIG[sndfile] = "-Dsndfile=enabled,-Dsndfile=disabled,libsndfile1" |
66 | PACKAGECONFIG[upnp] = "-Dupnp=enabled,-Dupnp=disabled,libupnp" | 65 | PACKAGECONFIG[upnp] = "-Dupnp=pupnp,-Dupnp=disabled,libupnp" |
67 | PACKAGECONFIG[vorbis] = "-Dvorbis=enabled,-Dvorbis=disabled,libvorbis libogg" | 66 | PACKAGECONFIG[vorbis] = "-Dvorbis=enabled,-Dvorbis=disabled,libvorbis libogg" |
68 | PACKAGECONFIG[wavpack] = "-Dwavpack=enabled,-Dwavpack=disabled,wavpack" | 67 | PACKAGECONFIG[wavpack] = "-Dwavpack=enabled,-Dwavpack=disabled,wavpack" |
69 | PACKAGECONFIG[zlib] = "-Dzlib=enabled,-Dzlib=disabled,zlib" | 68 | PACKAGECONFIG[zlib] = "-Dzlib=enabled,-Dzlib=disabled,zlib" |