diff options
author | Maxin John <maxin.john@gmail.com> | 2024-03-08 15:28:10 +0200 |
---|---|---|
committer | Maxin John <maxin.john@gmail.com> | 2024-03-08 15:28:10 +0200 |
commit | 85d566ff91e5357aafa72a4e9343d0c5c09da939 (patch) | |
tree | 8cf8ce8840997dcc2bbbff55dfff2e8110edcb22 /meta-multimedia/recipes-multimedia | |
parent | b2f7f2b3e45de0158659c7c3926fd0440de29c96 (diff) | |
download | meta-openembedded-85d566ff91e5357aafa72a4e9343d0c5c09da939.tar.gz |
openal-soft: remove unused patches
Remove patches that were left unused after upgrade to version 1.23.1
Signed-off-by: Maxin John <maxin.john@gmail.com>
Diffstat (limited to 'meta-multimedia/recipes-multimedia')
2 files changed, 0 insertions, 60 deletions
diff --git a/meta-multimedia/recipes-multimedia/openal/openal-soft/0001-Use-BUILD_CC-to-compile-native-tools.patch b/meta-multimedia/recipes-multimedia/openal/openal-soft/0001-Use-BUILD_CC-to-compile-native-tools.patch deleted file mode 100644 index 2bffd65c6..000000000 --- a/meta-multimedia/recipes-multimedia/openal/openal-soft/0001-Use-BUILD_CC-to-compile-native-tools.patch +++ /dev/null | |||
@@ -1,31 +0,0 @@ | |||
1 | From 29217932c34d7e3368764ab64879dc6f1edab1a6 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Mon, 14 Jan 2019 11:19:44 -0800 | ||
4 | Subject: [PATCH] Use host compiler to compile native tools | ||
5 | |||
6 | Helps in cross compiling | ||
7 | |||
8 | Upstream-Status: Inappropriate [OE-Specific] | ||
9 | |||
10 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
11 | |||
12 | --- | ||
13 | CMakeLists.txt | 5 ++--- | ||
14 | 1 file changed, 2 insertions(+), 3 deletions(-) | ||
15 | |||
16 | --- a/CMakeLists.txt | ||
17 | +++ b/CMakeLists.txt | ||
18 | @@ -1085,11 +1085,10 @@ ELSE() | ||
19 | SET(BIN2H_COMMAND "${NATIVE_BIN_DIR}/bin2h") | ||
20 | SET(BSINCGEN_COMMAND "${NATIVE_BIN_DIR}/bsincgen") | ||
21 | ADD_CUSTOM_COMMAND(OUTPUT "${BIN2H_COMMAND}" "${BSINCGEN_COMMAND}" | ||
22 | - COMMAND ${CMAKE_COMMAND} -G "${CMAKE_GENERATOR}" "${NATIVE_SRC_DIR}" | ||
23 | COMMAND ${CMAKE_COMMAND} -E remove "${BIN2H_COMMAND}" "${BSINCGEN_COMMAND}" | ||
24 | - COMMAND ${CMAKE_COMMAND} --build . --config "Release" | ||
25 | + COMMAND gcc "${NATIVE_SRC_DIR}/bin2h.c" -o "${BIN2H_COMMAND}" -lm | ||
26 | + COMMAND gcc "${NATIVE_SRC_DIR}/bsincgen.c" -o "${BSINCGEN_COMMAND}" -lm | ||
27 | WORKING_DIRECTORY "${NATIVE_BIN_DIR}" | ||
28 | - DEPENDS "${NATIVE_SRC_DIR}/CMakeLists.txt" | ||
29 | IMPLICIT_DEPENDS | ||
30 | C "${NATIVE_SRC_DIR}/bin2h.c" | ||
31 | C "${NATIVE_SRC_DIR}/bsincgen.c" | ||
diff --git a/meta-multimedia/recipes-multimedia/openal/openal-soft/0002-makehrtf-Disable-Wstringop-truncation.patch b/meta-multimedia/recipes-multimedia/openal/openal-soft/0002-makehrtf-Disable-Wstringop-truncation.patch deleted file mode 100644 index 607ddab8d..000000000 --- a/meta-multimedia/recipes-multimedia/openal/openal-soft/0002-makehrtf-Disable-Wstringop-truncation.patch +++ /dev/null | |||
@@ -1,29 +0,0 @@ | |||
1 | From 07ef86e33ed6f7585f0dfaa1732ea17c816655a4 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Mon, 14 Jan 2019 11:45:42 -0800 | ||
4 | Subject: [PATCH] makehrtf: Disable Wstringop-truncation | ||
5 | |||
6 | Upstream-Status: Inappropriate [Should be fixed in code] | ||
7 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
8 | --- | ||
9 | utils/makemhr/makemhr.cpp | 2 ++ | ||
10 | 1 file changed, 2 insertions(+) | ||
11 | |||
12 | --- a/utils/makemhr/makemhr.cpp | ||
13 | +++ b/utils/makemhr/makemhr.cpp | ||
14 | @@ -161,6 +161,7 @@ enum ChannelIndex : uint { | ||
15 | * pattern string are replaced with the replacement string. The result is | ||
16 | * truncated if necessary. | ||
17 | */ | ||
18 | +#pragma GCC diagnostic ignored "-Wstringop-truncation" | ||
19 | static int StrSubst(const char *in, const char *pat, const char *rep, const size_t maxLen, char *out) | ||
20 | { | ||
21 | size_t inLen, patLen, repLen; | ||
22 | @@ -199,6 +200,7 @@ static int StrSubst(const char *in, cons | ||
23 | return !truncated; | ||
24 | } | ||
25 | |||
26 | +#pragma GCC diagnostic pop | ||
27 | |||
28 | /********************* | ||
29 | *** Math routines *** | ||