diff options
author | Khem Raj <raj.khem@gmail.com> | 2022-08-27 11:10:29 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2022-08-28 23:57:15 -0700 |
commit | 3dd74712ed7b5a281622af576cf8ffb6c68e9cb0 (patch) | |
tree | 99b9d6a4fddcc20cee9969d501309d86612c90c7 /meta-multimedia/recipes-multimedia | |
parent | b81f66a09a50a55d8f136b696d2bd119b2457c8f (diff) | |
download | meta-openembedded-3dd74712ed7b5a281622af576cf8ffb6c68e9cb0.tar.gz |
dvb-apps: Use tarball for SRC_URI and fix build on musl
Convert to using tarball for SRC_URI, this is only recipe in
meta-openembedded needing mercurial fetcher
Fix the stime replacement patch to fix type errors on time_t
| dvbdate.c:313:12: error: incompatible pointer to integer conversion assigning to 'time_t' (aka 'long') from 'time_t **' (aka 'long **') [-Wint-conversion]
| ts.tv_sec = &new_time;
| ^ ~~~~~~~~~
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-multimedia/recipes-multimedia')
-rw-r--r-- | meta-multimedia/recipes-multimedia/dvb-apps/dvb-apps_1.1.1.20140321.bb (renamed from meta-multimedia/recipes-multimedia/dvb-apps/dvb-apps_1.1.1.bb) | 7 | ||||
-rw-r--r-- | meta-multimedia/recipes-multimedia/dvb-apps/files/0001-dvbdate-Remove-Obsoleted-stime-API-calls.patch | 15 |
2 files changed, 8 insertions, 14 deletions
diff --git a/meta-multimedia/recipes-multimedia/dvb-apps/dvb-apps_1.1.1.bb b/meta-multimedia/recipes-multimedia/dvb-apps/dvb-apps_1.1.1.20140321.bb index 98970d5b7..90a69e5e2 100644 --- a/meta-multimedia/recipes-multimedia/dvb-apps/dvb-apps_1.1.1.bb +++ b/meta-multimedia/recipes-multimedia/dvb-apps/dvb-apps_1.1.1.20140321.bb | |||
@@ -2,9 +2,8 @@ SUMMARY = "Linux DVB API applications and utilities" | |||
2 | HOMEPAGE = "http://www.linuxtv.org" | 2 | HOMEPAGE = "http://www.linuxtv.org" |
3 | LICENSE = "GPL-2.0-only" | 3 | LICENSE = "GPL-2.0-only" |
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe" | 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe" |
5 | SRCREV = "3d43b280298c39a67d1d889e01e173f52c12da35" | ||
6 | 5 | ||
7 | SRC_URI = "hg://linuxtv.org/hg;module=dvb-apps;protocol=http \ | 6 | SRC_URI = "https://www.linuxtv.org/hg/dvb-apps/archive/3d43b280298c.tar.bz2;downloadfilename=${BPN}-3d43b280298c.tar.bz2 \ |
8 | file://dvb-scan-table \ | 7 | file://dvb-scan-table \ |
9 | file://0001-Fix-generate-keynames.patch \ | 8 | file://0001-Fix-generate-keynames.patch \ |
10 | file://0003-handle-static-shared-only-build.patch \ | 9 | file://0003-handle-static-shared-only-build.patch \ |
@@ -13,8 +12,8 @@ SRC_URI = "hg://linuxtv.org/hg;module=dvb-apps;protocol=http \ | |||
13 | file://0006-CA_SET_PID.patch \ | 12 | file://0006-CA_SET_PID.patch \ |
14 | file://0001-dvbdate-Remove-Obsoleted-stime-API-calls.patch \ | 13 | file://0001-dvbdate-Remove-Obsoleted-stime-API-calls.patch \ |
15 | " | 14 | " |
16 | 15 | SRC_URI[sha256sum] = "f39e2f0ebed7e32bce83522062ad4d414f67fccd5df1b647618524497e15e057" | |
17 | S = "${WORKDIR}/${BPN}" | 16 | S = "${WORKDIR}/${BPN}-3d43b280298c" |
18 | 17 | ||
19 | inherit perlnative | 18 | inherit perlnative |
20 | 19 | ||
diff --git a/meta-multimedia/recipes-multimedia/dvb-apps/files/0001-dvbdate-Remove-Obsoleted-stime-API-calls.patch b/meta-multimedia/recipes-multimedia/dvb-apps/files/0001-dvbdate-Remove-Obsoleted-stime-API-calls.patch index 9035b56f4..e89f9a3cd 100644 --- a/meta-multimedia/recipes-multimedia/dvb-apps/files/0001-dvbdate-Remove-Obsoleted-stime-API-calls.patch +++ b/meta-multimedia/recipes-multimedia/dvb-apps/files/0001-dvbdate-Remove-Obsoleted-stime-API-calls.patch | |||
@@ -11,22 +11,17 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com> | |||
11 | util/dvbdate/dvbdate.c | 5 ++++- | 11 | util/dvbdate/dvbdate.c | 5 ++++- |
12 | 1 file changed, 4 insertions(+), 1 deletion(-) | 12 | 1 file changed, 4 insertions(+), 1 deletion(-) |
13 | 13 | ||
14 | diff --git a/util/dvbdate/dvbdate.c b/util/dvbdate/dvbdate.c | ||
15 | index f0df437..492ed79 100644 | ||
16 | --- a/util/dvbdate/dvbdate.c | 14 | --- a/util/dvbdate/dvbdate.c |
17 | +++ b/util/dvbdate/dvbdate.c | 15 | +++ b/util/dvbdate/dvbdate.c |
18 | @@ -309,7 +309,10 @@ int atsc_scan_date(time_t *rx_time, unsigned int to) | 16 | @@ -309,7 +309,10 @@ int atsc_scan_date(time_t *rx_time, unsi |
19 | */ | 17 | */ |
20 | int set_time(time_t * new_time) | 18 | int set_time(time_t * new_time) |
21 | { | 19 | { |
22 | - if (stime(new_time)) { | 20 | - if (stime(new_time)) { |
23 | + struct timespec ts; | 21 | + struct timespec s = {0}; |
24 | + ts.tv_sec = &new_time; | 22 | + s.tv_sec = *new_time; |
25 | + ts.tv_nsec = 0; | 23 | + |
26 | + if (clock_settime(CLOCK_REALTIME, &ts)) { | 24 | + if (clock_settime(CLOCK_REALTIME, &s)) { |
27 | perror("Unable to set time"); | 25 | perror("Unable to set time"); |
28 | return -1; | 26 | return -1; |
29 | } | 27 | } |
30 | -- | ||
31 | 2.24.1 | ||
32 | |||