diff options
author | Khem Raj <raj.khem@gmail.com> | 2019-12-02 22:26:25 -0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2019-12-05 23:00:48 -0800 |
commit | b180b56f7ba9686b8e8ab35d9b83e6ab59aebbc4 (patch) | |
tree | 1a2918d0cca74b5d14d9703e4a23603753594285 /meta-multimedia/recipes-multimedia | |
parent | d1608c506f19918514d843517c95278b18fa7bab (diff) | |
download | meta-openembedded-b180b56f7ba9686b8e8ab35d9b83e6ab59aebbc4.tar.gz |
projucer: Upgrade to 5.4.5
License-Update: https://github.com/WeAreROLI/JUCE/commit/d9dee4d87332bf9e3d12da2e032608698829dc14#diff-37854d19817c792316d481f5beb93cc7
Enbable GPL build and disable webkit component
Merge native and nativesdk component into single recipe using
bbclassextend
Disable build on musl
Link with libatomic on arches without builtin atomics
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-multimedia/recipes-multimedia')
5 files changed, 105 insertions, 11 deletions
diff --git a/meta-multimedia/recipes-multimedia/juce/nativesdk-projucer_git.bb b/meta-multimedia/recipes-multimedia/juce/nativesdk-projucer_git.bb deleted file mode 100644 index 7836bae69..000000000 --- a/meta-multimedia/recipes-multimedia/juce/nativesdk-projucer_git.bb +++ /dev/null | |||
@@ -1,3 +0,0 @@ | |||
1 | inherit nativesdk | ||
2 | include projucer.inc | ||
3 | BBCLASSEXTEND = "nativesdk" | ||
diff --git a/meta-multimedia/recipes-multimedia/juce/projucer-native_git.bb b/meta-multimedia/recipes-multimedia/juce/projucer-native_git.bb deleted file mode 100644 index fb54fb9e9..000000000 --- a/meta-multimedia/recipes-multimedia/juce/projucer-native_git.bb +++ /dev/null | |||
@@ -1,3 +0,0 @@ | |||
1 | inherit native | ||
2 | include projucer.inc | ||
3 | BBCLASSEXTEND = "native" | ||
diff --git a/meta-multimedia/recipes-multimedia/juce/projucer.inc b/meta-multimedia/recipes-multimedia/juce/projucer.inc index 63ed9e90e..60bd0e24b 100644 --- a/meta-multimedia/recipes-multimedia/juce/projucer.inc +++ b/meta-multimedia/recipes-multimedia/juce/projucer.inc | |||
@@ -4,23 +4,36 @@ JUCE supported platforms, including Linux and Embedded Linux." | |||
4 | SECTION = "utils" | 4 | SECTION = "utils" |
5 | HOMEPAGE = "http://juce.com/" | 5 | HOMEPAGE = "http://juce.com/" |
6 | LICENSE = "GPLv3" | 6 | LICENSE = "GPLv3" |
7 | LIC_FILES_CHKSUM = "file://README.md;md5=65c50b4ff3522b99436da100536ccd1c" | 7 | LIC_FILES_CHKSUM = "file://LICENSE.md;md5=a20f91622a47d4e4af9340d5d3f1a2d8" |
8 | 8 | ||
9 | inherit pkgconfig | 9 | inherit pkgconfig |
10 | 10 | ||
11 | DEPENDS = "libx11 libxext libxinerama libxrandr libxcursor freetype alsa-lib curl" | 11 | DEPENDS = "libx11 libxext libxinerama libxrandr libxcursor freetype alsa-lib curl bzip2 libpng harfbuzz glib-2.0 libpcre" |
12 | DEPENDS_append_libc-musl = " libexecinfo" | ||
12 | 13 | ||
13 | SRCREV = "4f41f28b47d01b939559123d145b4e5860528bb7" | 14 | SRCREV = "724ae27c71ef809b836df06713cf9e50bc14162b" |
14 | BRANCH = "master" | 15 | BRANCH = "master" |
15 | SRC_URI = "git://github.com/WeAreROLI/JUCE.git;protocol=https;branch=${BRANCH}" | 16 | SRC_URI = "git://github.com/WeAreROLI/JUCE.git;protocol=https;branch=${BRANCH} \ |
17 | file://0001-Disable-webkit-component.patch \ | ||
18 | " | ||
16 | 19 | ||
17 | S = "${WORKDIR}/git" | 20 | S = "${WORKDIR}/git" |
18 | PV = "5.0.1" | 21 | PV = "5.4.5" |
19 | 22 | ||
20 | JUCE_PROJUCER_BUILD_PATH = "${B}/extras/Projucer/Builds" | 23 | JUCE_PROJUCER_BUILD_PATH = "${B}/extras/Projucer/Builds" |
21 | JUCE_PROJUCER_MAKEFILE_PATH = "${JUCE_PROJUCER_BUILD_PATH}/LinuxMakefile" | 24 | JUCE_PROJUCER_MAKEFILE_PATH = "${JUCE_PROJUCER_BUILD_PATH}/LinuxMakefile" |
22 | JUCE_PROJUCER = "${JUCE_PROJUCER_MAKEFILE_PATH}/build/Projucer" | 25 | JUCE_PROJUCER = "${JUCE_PROJUCER_MAKEFILE_PATH}/build/Projucer" |
23 | 26 | ||
27 | # export dummy TARGET_ARCH that doesn't do much, | ||
28 | # but disables "-march=native" optimization which does | ||
29 | # not work on cross builds | ||
30 | EXTRA_OEMAKE = "V=1 JUCE_ARCH_LABEL=${TARGET_ARCH} TARGET_ARCH='-g'" | ||
31 | |||
32 | LDFLAGS_append_mipsarcho32 = " -latomic" | ||
33 | LDFLAGS_append_powerpc = " -latomic" | ||
34 | LDFLAGS_append_riscv64 = " -latomic" | ||
35 | LDFLAGS_append_armv5 = " -latomic" | ||
36 | |||
24 | do_configure() { | 37 | do_configure() { |
25 | cd ${JUCE_PROJUCER_MAKEFILE_PATH} | 38 | cd ${JUCE_PROJUCER_MAKEFILE_PATH} |
26 | CONFIG=Release oe_runmake clean | 39 | CONFIG=Release oe_runmake clean |
@@ -35,3 +48,5 @@ do_install() { | |||
35 | install -d ${D}${bindir} | 48 | install -d ${D}${bindir} |
36 | install -m 0755 ${JUCE_PROJUCER} ${D}${bindir} | 49 | install -m 0755 ${JUCE_PROJUCER} ${D}${bindir} |
37 | } | 50 | } |
51 | # error: '_NL_IDENTIFICATION_LANGUAGE' was not declared in this scope | ||
52 | COMPATIBLE_HOST_libc-musl = "null" | ||
diff --git a/meta-multimedia/recipes-multimedia/juce/projucer/0001-Disable-webkit-component.patch b/meta-multimedia/recipes-multimedia/juce/projucer/0001-Disable-webkit-component.patch new file mode 100644 index 000000000..3728439c7 --- /dev/null +++ b/meta-multimedia/recipes-multimedia/juce/projucer/0001-Disable-webkit-component.patch | |||
@@ -0,0 +1,83 @@ | |||
1 | From df7190f430f30ee522f56f9714d42ee796f0d5ff Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Mon, 2 Dec 2019 22:18:41 -0800 | ||
4 | Subject: [PATCH] Disable webkit component | ||
5 | |||
6 | It asks for enable JUCER_ENABLE_GPL_MODE | ||
7 | |||
8 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
9 | --- | ||
10 | extras/Projucer/Builds/LinuxMakefile/Makefile | 10 +++++----- | ||
11 | extras/Projucer/JuceLibraryCode/AppConfig.h | 4 ++-- | ||
12 | 2 files changed, 7 insertions(+), 7 deletions(-) | ||
13 | |||
14 | diff --git a/extras/Projucer/Builds/LinuxMakefile/Makefile b/extras/Projucer/Builds/LinuxMakefile/Makefile | ||
15 | index 25b490460..8960f5bc6 100644 | ||
16 | --- a/extras/Projucer/Builds/LinuxMakefile/Makefile | ||
17 | +++ b/extras/Projucer/Builds/LinuxMakefile/Makefile | ||
18 | @@ -35,13 +35,13 @@ ifeq ($(CONFIG),Debug) | ||
19 | TARGET_ARCH := -march=native | ||
20 | endif | ||
21 | |||
22 | - JUCE_CPPFLAGS := $(DEPFLAGS) -DLINUX=1 -DDEBUG=1 -D_DEBUG=1 -DJUCER_LINUX_MAKE_6D53C8B4=1 -DJUCE_APP_VERSION=5.4.5 -DJUCE_APP_VERSION_HEX=0x50405 $(shell pkg-config --cflags x11 xinerama xext freetype2 webkit2gtk-4.0 gtk+-x11-3.0) -pthread -I../../JuceLibraryCode -I../../../../modules $(CPPFLAGS) | ||
23 | + JUCE_CPPFLAGS := $(DEPFLAGS) -DLINUX=1 -DDEBUG=1 -D_DEBUG=1 -DJUCER_LINUX_MAKE_6D53C8B4=1 -DJUCE_APP_VERSION=5.4.5 -DJUCE_APP_VERSION_HEX=0x50405 $(shell pkg-config --cflags x11 xinerama xext freetype2) -pthread -I../../JuceLibraryCode -I../../../../modules $(CPPFLAGS) | ||
24 | JUCE_CPPFLAGS_APP := -DJucePlugin_Build_VST=0 -DJucePlugin_Build_VST3=0 -DJucePlugin_Build_AU=0 -DJucePlugin_Build_AUv3=0 -DJucePlugin_Build_RTAS=0 -DJucePlugin_Build_AAX=0 -DJucePlugin_Build_Standalone=0 -DJucePlugin_Build_Unity=0 | ||
25 | JUCE_TARGET_APP := Projucer | ||
26 | |||
27 | JUCE_CFLAGS += $(JUCE_CPPFLAGS) $(TARGET_ARCH) -g -ggdb -O0 $(CFLAGS) | ||
28 | JUCE_CXXFLAGS += $(JUCE_CFLAGS) -std=c++11 $(CXXFLAGS) | ||
29 | - JUCE_LDFLAGS += $(TARGET_ARCH) -L$(JUCE_BINDIR) -L$(JUCE_LIBDIR) $(shell pkg-config --libs x11 xinerama xext freetype2 webkit2gtk-4.0 gtk+-x11-3.0) -lrt -ldl -lpthread $(LDFLAGS) | ||
30 | + JUCE_LDFLAGS += $(TARGET_ARCH) -L$(JUCE_BINDIR) -L$(JUCE_LIBDIR) $(shell pkg-config --libs x11 xinerama xext freetype2) -lrt -ldl -lpthread $(LDFLAGS) | ||
31 | |||
32 | CLEANCMD = rm -rf $(JUCE_OUTDIR)/$(TARGET) $(JUCE_OBJDIR) | ||
33 | endif | ||
34 | @@ -56,13 +56,13 @@ ifeq ($(CONFIG),Release) | ||
35 | TARGET_ARCH := -march=native | ||
36 | endif | ||
37 | |||
38 | - JUCE_CPPFLAGS := $(DEPFLAGS) -DLINUX=1 -DNDEBUG=1 -DJUCER_LINUX_MAKE_6D53C8B4=1 -DJUCE_APP_VERSION=5.4.5 -DJUCE_APP_VERSION_HEX=0x50405 $(shell pkg-config --cflags x11 xinerama xext freetype2 webkit2gtk-4.0 gtk+-x11-3.0) -pthread -I../../JuceLibraryCode -I../../../../modules $(CPPFLAGS) | ||
39 | + JUCE_CPPFLAGS := $(DEPFLAGS) -DLINUX=1 -DNDEBUG=1 -DJUCER_LINUX_MAKE_6D53C8B4=1 -DJUCE_APP_VERSION=5.4.5 -DJUCE_APP_VERSION_HEX=0x50405 $(shell pkg-config --cflags x11 xinerama xext freetype2) -pthread -I../../JuceLibraryCode -I../../../../modules $(CPPFLAGS) | ||
40 | JUCE_CPPFLAGS_APP := -DJucePlugin_Build_VST=0 -DJucePlugin_Build_VST3=0 -DJucePlugin_Build_AU=0 -DJucePlugin_Build_AUv3=0 -DJucePlugin_Build_RTAS=0 -DJucePlugin_Build_AAX=0 -DJucePlugin_Build_Standalone=0 -DJucePlugin_Build_Unity=0 | ||
41 | JUCE_TARGET_APP := Projucer | ||
42 | |||
43 | JUCE_CFLAGS += $(JUCE_CPPFLAGS) $(TARGET_ARCH) -O3 $(CFLAGS) | ||
44 | JUCE_CXXFLAGS += $(JUCE_CFLAGS) -std=c++11 $(CXXFLAGS) | ||
45 | - JUCE_LDFLAGS += $(TARGET_ARCH) -L$(JUCE_BINDIR) -L$(JUCE_LIBDIR) $(shell pkg-config --libs x11 xinerama xext freetype2 webkit2gtk-4.0 gtk+-x11-3.0) -fvisibility=hidden -lrt -ldl -lpthread $(LDFLAGS) | ||
46 | + JUCE_LDFLAGS += $(TARGET_ARCH) -L$(JUCE_BINDIR) -L$(JUCE_LIBDIR) $(shell pkg-config --libs x11 xinerama xext freetype2) -fvisibility=hidden -lrt -ldl -lpthread $(LDFLAGS) | ||
47 | |||
48 | CLEANCMD = rm -rf $(JUCE_OUTDIR)/$(TARGET) $(JUCE_OBJDIR) | ||
49 | endif | ||
50 | @@ -136,7 +136,7 @@ all : $(JUCE_OUTDIR)/$(JUCE_TARGET_APP) | ||
51 | |||
52 | $(JUCE_OUTDIR)/$(JUCE_TARGET_APP) : $(OBJECTS_APP) $(RESOURCES) | ||
53 | @command -v pkg-config >/dev/null 2>&1 || { echo >&2 "pkg-config not installed. Please, install it."; exit 1; } | ||
54 | - @pkg-config --print-errors x11 xinerama xext freetype2 webkit2gtk-4.0 gtk+-x11-3.0 | ||
55 | + @pkg-config --print-errors x11 xinerama xext freetype2 | ||
56 | @echo Linking "Projucer - App" | ||
57 | -$(V_AT)mkdir -p $(JUCE_BINDIR) | ||
58 | -$(V_AT)mkdir -p $(JUCE_LIBDIR) | ||
59 | diff --git a/extras/Projucer/JuceLibraryCode/AppConfig.h b/extras/Projucer/JuceLibraryCode/AppConfig.h | ||
60 | index dffd5af75..53302bd24 100644 | ||
61 | --- a/extras/Projucer/JuceLibraryCode/AppConfig.h | ||
62 | +++ b/extras/Projucer/JuceLibraryCode/AppConfig.h | ||
63 | @@ -32,7 +32,7 @@ | ||
64 | // BEGIN SECTION A | ||
65 | |||
66 | #ifndef JUCER_ENABLE_GPL_MODE | ||
67 | - #define JUCER_ENABLE_GPL_MODE 0 | ||
68 | + #define JUCER_ENABLE_GPL_MODE 1 | ||
69 | #endif | ||
70 | |||
71 | // END SECTION A | ||
72 | @@ -180,7 +180,7 @@ | ||
73 | // juce_gui_extra flags: | ||
74 | |||
75 | #ifndef JUCE_WEB_BROWSER | ||
76 | - //#define JUCE_WEB_BROWSER 1 | ||
77 | + #define JUCE_WEB_BROWSER 0 | ||
78 | #endif | ||
79 | |||
80 | #ifndef JUCE_ENABLE_LIVE_CONSTANT_EDITOR | ||
81 | -- | ||
82 | 2.24.0 | ||
83 | |||
diff --git a/meta-multimedia/recipes-multimedia/juce/projucer_git.bb b/meta-multimedia/recipes-multimedia/juce/projucer_git.bb new file mode 100644 index 000000000..f408f6f1b --- /dev/null +++ b/meta-multimedia/recipes-multimedia/juce/projucer_git.bb | |||
@@ -0,0 +1,2 @@ | |||
1 | include projucer.inc | ||
2 | BBCLASSEXTEND = "native nativesdk" | ||