diff options
author | Paul Barker <paul@paulbarker.me.uk> | 2013-05-04 10:35:15 +0100 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2013-05-07 18:59:01 +0200 |
commit | 6e8f3e6d46202fd6f911a065e8983a18103fed1b (patch) | |
tree | 7e7ca3bbe9e8b494f9549570d166c305a7a2ad8a /meta-multimedia/recipes-multimedia | |
parent | e740789097a1fa982a970072bbcb3d74eb2b3047 (diff) | |
download | meta-openembedded-6e8f3e6d46202fd6f911a065e8983a18103fed1b.tar.gz |
vlc: moved to meta-multimedia
vlc depends on fluidsynth which is in meta-multimedia.
Signed-off-by: Paul Barker <paul@paulbarker.me.uk>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-multimedia/recipes-multimedia')
-rw-r--r-- | meta-multimedia/recipes-multimedia/vlc/libdvdcss_1.2.10.bb | 13 | ||||
-rw-r--r-- | meta-multimedia/recipes-multimedia/vlc/vlc.inc | 85 | ||||
-rw-r--r-- | meta-multimedia/recipes-multimedia/vlc/vlc_1.1.11.bb | 15 |
3 files changed, 113 insertions, 0 deletions
diff --git a/meta-multimedia/recipes-multimedia/vlc/libdvdcss_1.2.10.bb b/meta-multimedia/recipes-multimedia/vlc/libdvdcss_1.2.10.bb new file mode 100644 index 000000000..1a0b7b87e --- /dev/null +++ b/meta-multimedia/recipes-multimedia/vlc/libdvdcss_1.2.10.bb | |||
@@ -0,0 +1,13 @@ | |||
1 | DESCRIPTION = "libdvdcss is a simple library designed for accessing DVDs like a block device without having to bother about the decryption." | ||
2 | LICENSE = "GPLv2" | ||
3 | LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f" | ||
4 | PR = "r1" | ||
5 | |||
6 | SRC_URI = "http://download.videolan.org/pub/libdvdcss/${PV}/libdvdcss-${PV}.tar.bz2" | ||
7 | |||
8 | inherit autotools | ||
9 | |||
10 | EXTRA_OECONF = " --disable-doc " | ||
11 | |||
12 | SRC_URI[md5sum] = "ebd5370b79ac5a83e5c61b24a214cf74" | ||
13 | SRC_URI[sha256sum] = "2394a75013ab66b592d8c91d53529ede392bc9faee37fe279bd29b455eff2220" | ||
diff --git a/meta-multimedia/recipes-multimedia/vlc/vlc.inc b/meta-multimedia/recipes-multimedia/vlc/vlc.inc new file mode 100644 index 000000000..1fe2d04f2 --- /dev/null +++ b/meta-multimedia/recipes-multimedia/vlc/vlc.inc | |||
@@ -0,0 +1,85 @@ | |||
1 | DESCRIPTION = "Video player and streamer - davinci edition" | ||
2 | HOMEPAGE = "http://www.videolan.org" | ||
3 | LICENSE = "GPLv2" | ||
4 | SECTION = "multimedia" | ||
5 | |||
6 | DEPENDS = "libfribidi libtool libgcrypt gst-plugins-bad virtual/libsdl qt4-x11-free dbus libxml2 gnutls tremor faad2 ffmpeg flac libxpm fluidsynth alsa-lib \ | ||
7 | ${@base_conditional('ENTERPRISE_DISTRO', '1', '', 'libmad libid3tag liba52 mpeg2dec', d)}" | ||
8 | |||
9 | SRC_URI = "http://download.videolan.org/pub/videolan/vlc/${PV}/vlc-${PV}.tar.bz2" | ||
10 | |||
11 | inherit autotools gettext | ||
12 | |||
13 | ARM_INSTRUCTION_SET = "arm" | ||
14 | |||
15 | DEPENDS += "libdvdcss libdvdread lua5.1-native lua5.1" | ||
16 | |||
17 | LEAD_SONAME = "libvlc.so.5" | ||
18 | |||
19 | PACKAGES =+ "libvlc-dbg libvlc-dev libvlc" | ||
20 | |||
21 | FILES_libvlc-dev = "${libdir}/lib*.so" | ||
22 | |||
23 | FILES_libvlc-dbg = "\ | ||
24 | ${libdir}/.debug \ | ||
25 | ${libdir}/vlc/meta_engine/.debug \ | ||
26 | ${libdir}/vlc/audio_filter/.debug ${libdir}/vlc/audio_output/.debug \ | ||
27 | ${libdir}/vlc/demux/.debug ${libdir}/vlc/control/.debug \ | ||
28 | ${libdir}/vlc/gui/.debug ${libdir}/vlc/packetizer/.debug \ | ||
29 | ${libdir}/vlc/audio_mixer/.debug ${libdir}/vlc/stream_out/.debug \ | ||
30 | ${libdir}/vlc/mux/.debug ${libdir}/vlc/access/.debug \ | ||
31 | ${libdir}/vlc/visualization/.debug ${libdir}/vlc/access_filter/.debug \ | ||
32 | ${libdir}/vlc/access_output/.debug ${libdir}/vlc/video_output/.debug \ | ||
33 | ${libdir}/vlc/services_discovery/.debug ${libdir}/vlc/video_chroma/.debug \ | ||
34 | ${libdir}/vlc/video_codec/.debug ${libdir}/vlc/video_filter/.debug \ | ||
35 | ${libdir}/vlc/misc/.debug ${libdir}/vlc/codec/.debug \ | ||
36 | " | ||
37 | |||
38 | FILES_libvlc = "${libdir}/lib*.so.*" | ||
39 | |||
40 | FILES_${PN} += "${bindir}/vlc \ | ||
41 | ${datadir}/applications \ | ||
42 | ${datadir}/vlc/ \ | ||
43 | ${datadir}/icons \ | ||
44 | " | ||
45 | |||
46 | FILES_${PN}-dbg += "${libdir}/vlc/*/.debug ${libdir}/vlc/plugins/*/.debug" | ||
47 | |||
48 | EXTRA_OECONF = "\ | ||
49 | --enable-dvdread \ | ||
50 | --enable-libtool \ | ||
51 | --with-contrib \ | ||
52 | --enable-run-as-root \ | ||
53 | --disable-wxwidgets \ | ||
54 | --enable-x11 --enable-xvideo \ | ||
55 | --disable-screen --disable-caca \ | ||
56 | --enable-httpd --enable-vlm \ | ||
57 | --enable-freetype \ | ||
58 | --enable-sdl \ | ||
59 | --enable-png \ | ||
60 | --enable-live555 --enable-tremor \ | ||
61 | --enable-v4l2 --enable-v4l --disable-aa --enable-wma --disable-faad \ | ||
62 | --enable-dbus \ | ||
63 | --disable-hal \ | ||
64 | --without-contrib \ | ||
65 | --without-kde-solid \ | ||
66 | --disable-opengl --disable-glx \ | ||
67 | --enable-realrtsp \ | ||
68 | ac_cv_path_MOC=${STAGING_BINDIR_NATIVE}/moc4 \ | ||
69 | ac_cv_path_RCC=${STAGING_BINDIR_NATIVE}/rcc4 \ | ||
70 | ac_cv_path_UIC=${STAGING_BINDIR_NATIVE}/uic4 \ | ||
71 | " | ||
72 | |||
73 | |||
74 | do_configure() { | ||
75 | cp ${STAGING_DATADIR}/aclocal/libgcrypt.m4 ${S}/m4/ | ||
76 | ./bootstrap | ||
77 | gnu-configize --force | ||
78 | libtoolize --force | ||
79 | #autoreconf --force -i | ||
80 | cp ${STAGING_DATADIR}/libtool/config.* ${S}/autotools/ || true | ||
81 | oe_runconf | ||
82 | rm config.log | ||
83 | sed -i -e s:-L/usr/lib:-L${STAGING_LIBDIR}/:g vlc-config | ||
84 | sed -i -e s:'$(MOC) $(DEFS) $(CPPFLAGS)':'$(MOC) $(DEFS)'\ -I${S}/include\ -DSYS_LINUX:g ${S}/modules/gui/qt4/Makefile | ||
85 | } | ||
diff --git a/meta-multimedia/recipes-multimedia/vlc/vlc_1.1.11.bb b/meta-multimedia/recipes-multimedia/vlc/vlc_1.1.11.bb new file mode 100644 index 000000000..11ecaa43a --- /dev/null +++ b/meta-multimedia/recipes-multimedia/vlc/vlc_1.1.11.bb | |||
@@ -0,0 +1,15 @@ | |||
1 | # This recipe packages vlc as a library as well, so qt4 dependencies | ||
2 | # can be avoided when only the library is installed. | ||
3 | |||
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=ed7e492ee44e70125a5d42e118354a13" | ||
5 | |||
6 | require vlc.inc | ||
7 | |||
8 | PR = "r4" | ||
9 | |||
10 | # work around build failure | ||
11 | EXTRA_OECONF += " --enable-libxml2=no" | ||
12 | |||
13 | SRC_URI[md5sum] = "a64846d6f21ea179ae8e8bfb6f9447fe" | ||
14 | SRC_URI[sha256sum] = "682560be08b82bedfaf30d8a611d80093c5883c1de72fcbcf05715b8e9f4e1cb" | ||
15 | |||