diff options
author | eu@felipetonello.com <eu@felipetonello.com> | 2016-07-18 20:46:31 +0100 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2016-07-29 11:00:59 +0200 |
commit | 3bbc28d7c76cf0a8aab18096420d0b52209103c7 (patch) | |
tree | 3c4bca3b8582a7de164585595e11b89f1f8116ee /meta-multimedia/recipes-multimedia | |
parent | ca6edca71a54cdfc91453d3e648d80a98ad1a963 (diff) | |
download | meta-openembedded-3bbc28d7c76cf0a8aab18096420d0b52209103c7.tar.gz |
juce: Added support for JUCE framework
See below for the official README from JUCE.
For TL;DRs: JUCE is a well known and widely used C++ Framework for audio
applications. It has good support for Linux and ARM.
A typical JUCE application recipe will only contain this skeleton:
inherit juce
SRC_URI = "..."
JUCE_JUCERS = "${B}/cool-project.jucer"
do_compile() {
CONFIG=Release oe_runmake
}
do_install() {
install ...
}
======
OBS: This recipe requires a patch[1] on oe-core which is been tested right now.
[1] http://lists.openembedded.org/pipermail/openembedded-core/2016-July/123972.html
======
>From the README:
JUCE (Jules' Utility Class Extensions) is an all-encompassing
C++ framework for developing cross-platform software.
It contains pretty much everything you're likely to need to create
most applications, and is particularly well-suited for building
highly-customised GUIs, and for handling graphics and sound.
Most JUCE modules are shared under the GNU Public Licence
(GPLv2, v3, and the AGPLv3). This means that the code can
be freely copied and distributed, and costs nothing to use
in other GPL applications. One module (the juce_core module)
is permissively licensed under the ISC.
For more information, visit the website:
http://www.juce.com
Signed-off-by: Felipe F. Tonello <eu@felipetonello.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-multimedia/recipes-multimedia')
3 files changed, 41 insertions, 0 deletions
diff --git a/meta-multimedia/recipes-multimedia/juce/nativesdk-projucer_git.bb b/meta-multimedia/recipes-multimedia/juce/nativesdk-projucer_git.bb new file mode 100644 index 000000000..93b23b1b5 --- /dev/null +++ b/meta-multimedia/recipes-multimedia/juce/nativesdk-projucer_git.bb | |||
@@ -0,0 +1,2 @@ | |||
1 | inherit nativesdk | ||
2 | include projucer.inc | ||
diff --git a/meta-multimedia/recipes-multimedia/juce/projucer-native_git.bb b/meta-multimedia/recipes-multimedia/juce/projucer-native_git.bb new file mode 100644 index 000000000..b919a7dcb --- /dev/null +++ b/meta-multimedia/recipes-multimedia/juce/projucer-native_git.bb | |||
@@ -0,0 +1,2 @@ | |||
1 | inherit native | ||
2 | include projucer.inc | ||
diff --git a/meta-multimedia/recipes-multimedia/juce/projucer.inc b/meta-multimedia/recipes-multimedia/juce/projucer.inc new file mode 100644 index 000000000..6f696e26f --- /dev/null +++ b/meta-multimedia/recipes-multimedia/juce/projucer.inc | |||
@@ -0,0 +1,37 @@ | |||
1 | SUMMARY = "JUCE's Projucer" | ||
2 | DESCRIPTION = "Projucer is used to build and generate support files and build infrastructure for all \ | ||
3 | JUCE supported platforms, including Linux and Embedded Linux." | ||
4 | SECTION = "utils" | ||
5 | HOMEPAGE = "http://juce.com/" | ||
6 | LICENSE = "GPLv2" | ||
7 | LIC_FILES_CHKSUM = "file://README.txt;md5=9ab765ccda8890efc753f287911a1958" | ||
8 | |||
9 | inherit pkgconfig | ||
10 | |||
11 | DEPENDS = "libx11 libxext libxinerama libxrandr libxcursor freetype alsa-lib curl" | ||
12 | |||
13 | SRCREV = "a8a7fa28e2e9cb19db6a27fcccb567a8ccfe6109" | ||
14 | BRANCH = "develop" | ||
15 | SRC_URI = "git://github.com/julianstorer/JUCE.git;protocol=https;branch=${BRANCH}" | ||
16 | |||
17 | S = "${WORKDIR}/git" | ||
18 | PV = "4.2.3+git${SRCPV}" | ||
19 | |||
20 | JUCE_PROJUCER_BUILD_PATH = "${B}/extras/Projucer/Builds" | ||
21 | JUCE_PROJUCER_MAKEFILE_PATH = "${JUCE_PROJUCER_BUILD_PATH}/LinuxMakefile" | ||
22 | JUCE_PROJUCER = "${JUCE_PROJUCER_MAKEFILE_PATH}/build/Projucer" | ||
23 | |||
24 | do_configure() { | ||
25 | cd ${JUCE_PROJUCER_MAKEFILE_PATH} | ||
26 | CONFIG=Release oe_runmake clean | ||
27 | } | ||
28 | |||
29 | do_compile() { | ||
30 | cd ${JUCE_PROJUCER_MAKEFILE_PATH} | ||
31 | CONFIG=Release oe_runmake | ||
32 | } | ||
33 | |||
34 | do_install() { | ||
35 | install -d ${D}${bindir} | ||
36 | install -m 0755 ${JUCE_PROJUCER} ${D}${bindir} | ||
37 | } | ||