summaryrefslogtreecommitdiffstats
path: root/meta-multimedia/recipes-multimedia/vorbis-tools
diff options
context:
space:
mode:
authorStefan Müller-Klieser <s.mueller-klieser@phytec.de>2015-08-13 12:19:14 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2015-08-24 13:59:43 +0200
commitba0d87692de24a574e69269b9f1c9ad27d91454b (patch)
tree3a30108926f7f0161e756fbc9fad91bab2573ee3 /meta-multimedia/recipes-multimedia/vorbis-tools
parent67d903e519c7e18e8061c68d0e61b2dc6d164203 (diff)
downloadmeta-openembedded-ba0d87692de24a574e69269b9f1c9ad27d91454b.tar.gz
vorbis-tools: add new recipe
Vorbis tools provide command line editing and playback tools for the patent free audio codec. Use cases in embedded are audio tests and performance benchmarks. Signed-off-by: Stefan Müller-Klieser <s.mueller-klieser@phytec.de> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-multimedia/recipes-multimedia/vorbis-tools')
-rw-r--r--meta-multimedia/recipes-multimedia/vorbis-tools/vorbis-tools_1.4.0.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta-multimedia/recipes-multimedia/vorbis-tools/vorbis-tools_1.4.0.bb b/meta-multimedia/recipes-multimedia/vorbis-tools/vorbis-tools_1.4.0.bb
new file mode 100644
index 000000000..de89d22a6
--- /dev/null
+++ b/meta-multimedia/recipes-multimedia/vorbis-tools/vorbis-tools_1.4.0.bb
@@ -0,0 +1,32 @@
1SUMMARY = "Vorbis Tools"
2DESCRIPTION = "Ogg Vorbis is a high-quality lossy audio codec \
3that is free of intellectual property restrictions. vorbis-tools \
4include some command line applications to use the libraries."
5HOMEPAGE = "http://www.vorbis.com/"
6BUGTRACKER = "https://trac.xiph.org"
7SECTION = "multimedia"
8LICENSE = "GPLv2"
9LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
10
11DEPENDS = "libogg libvorbis curl libao"
12
13SRC_URI = "http://downloads.xiph.org/releases/vorbis/${BP}.tar.gz"
14
15SRC_URI[md5sum] = "567e0fb8d321b2cd7124f8208b8b90e6"
16SRC_URI[sha256sum] = "a389395baa43f8e5a796c99daf62397e435a7e73531c9f44d9084055a05d22bc"
17
18inherit autotools pkgconfig gettext
19
20RDEPENDS_${PN} = "libogg libvorbis libcurl libao"
21
22PACKAGECONFIG ??= "flac"
23PACKAGECONFIG[flac] = ",--without-flac,flac,libflac"
24PACKAGECONFIG[speex] = ",--without-speex,speex,speex"
25
26EXTRA_OECONF = "--with-ogg-libraries=${STAGING_LIBDIR} \
27 --with-ogg-includes=${STAGING_INCDIR} \
28 --with-vorbis-libraries=${STAGING_LIBDIR} \
29 --with-vorbis-includes=${STAGING_INCDIR} \
30 --with-curl-libraries=${STAGING_LIBDIR} \
31 --with-curl-libraries=${STAGING_LIBDIR} \
32"