diff options
author | Khem Raj <raj.khem@gmail.com> | 2021-12-01 12:16:56 -0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2021-12-01 12:39:28 -0800 |
commit | 260968790546acce067ab1265f53ceb40791dfa1 (patch) | |
tree | a8b963361ddf849406f03e8e12bd5681dc9a8fae /meta-multimedia/recipes-multimedia/libcamera | |
parent | 6950f120606acf927dcc21395f173210eb532d1b (diff) | |
download | meta-openembedded-260968790546acce067ab1265f53ceb40791dfa1.tar.gz |
libcamera: Fix build break on musl
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-multimedia/recipes-multimedia/libcamera')
-rw-r--r-- | meta-multimedia/recipes-multimedia/libcamera/libcamera.bb | 1 | ||||
-rw-r--r-- | meta-multimedia/recipes-multimedia/libcamera/libcamera/0001-backtrace-Include-cxxabi.h-without-HAVE_DW.patch | 41 |
2 files changed, 42 insertions, 0 deletions
diff --git a/meta-multimedia/recipes-multimedia/libcamera/libcamera.bb b/meta-multimedia/recipes-multimedia/libcamera/libcamera.bb index be88fded3..97b920cea 100644 --- a/meta-multimedia/recipes-multimedia/libcamera/libcamera.bb +++ b/meta-multimedia/recipes-multimedia/libcamera/libcamera.bb | |||
@@ -10,6 +10,7 @@ LIC_FILES_CHKSUM = "\ | |||
10 | 10 | ||
11 | SRC_URI = " \ | 11 | SRC_URI = " \ |
12 | git://git.libcamera.org/libcamera/libcamera.git;protocol=https;branch=master \ | 12 | git://git.libcamera.org/libcamera/libcamera.git;protocol=https;branch=master \ |
13 | file://0001-backtrace-Include-cxxabi.h-without-HAVE_DW.patch \ | ||
13 | " | 14 | " |
14 | 15 | ||
15 | SRCREV = "f47c9c36ed161c9afefe7d4910840fd41f38ae3d" | 16 | SRCREV = "f47c9c36ed161c9afefe7d4910840fd41f38ae3d" |
diff --git a/meta-multimedia/recipes-multimedia/libcamera/libcamera/0001-backtrace-Include-cxxabi.h-without-HAVE_DW.patch b/meta-multimedia/recipes-multimedia/libcamera/libcamera/0001-backtrace-Include-cxxabi.h-without-HAVE_DW.patch new file mode 100644 index 000000000..3c01c5a23 --- /dev/null +++ b/meta-multimedia/recipes-multimedia/libcamera/libcamera/0001-backtrace-Include-cxxabi.h-without-HAVE_DW.patch | |||
@@ -0,0 +1,41 @@ | |||
1 | From 8aa0d83749609ed571b984d2dc64c7f757950c7c Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Wed, 1 Dec 2021 12:10:11 -0800 | ||
4 | Subject: [PATCH v2] backtrace: Include cxxabi.h without HAVE_DW | ||
5 | |||
6 | Since its used in code without HAVE_DW, it fails to compile on such | ||
7 | systems e.g. linux/musl | ||
8 | |||
9 | Fixes | ||
10 | src/libcamera/base/backtrace.cpp:235:16: error: use of undeclared identifier 'abi' | ||
11 | char *name = abi::__cxa_demangle(symbol, nullptr, nullptr, nullptr); | ||
12 | ^ | ||
13 | 1 error generated. | ||
14 | |||
15 | Upstream-Status: Submitted [https://lists.libcamera.org/pipermail/libcamera-devel/2021-December/027989.html] | ||
16 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
17 | --- | ||
18 | src/libcamera/base/backtrace.cpp | 3 ++- | ||
19 | 1 file changed, 2 insertions(+), 1 deletion(-) | ||
20 | |||
21 | diff --git a/src/libcamera/base/backtrace.cpp b/src/libcamera/base/backtrace.cpp | ||
22 | index d93e5518..42c60f7c 100644 | ||
23 | --- a/src/libcamera/base/backtrace.cpp | ||
24 | +++ b/src/libcamera/base/backtrace.cpp | ||
25 | @@ -13,11 +13,12 @@ | ||
26 | #endif | ||
27 | |||
28 | #ifdef HAVE_DW | ||
29 | -#include <cxxabi.h> | ||
30 | #include <elfutils/libdwfl.h> | ||
31 | #include <unistd.h> | ||
32 | #endif | ||
33 | |||
34 | +#include <cxxabi.h> | ||
35 | + | ||
36 | #if HAVE_UNWIND | ||
37 | /* | ||
38 | * Disable support for remote unwinding to enable a more optimized | ||
39 | -- | ||
40 | 2.34.1 | ||
41 | |||