summaryrefslogtreecommitdiffstats
path: root/meta-multimedia/recipes-multimedia/gstreamer/gst-plugins.inc
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2015-05-18 17:12:47 +0300
committerMartin Jansa <Martin.Jansa@gmail.com>2015-05-22 20:14:07 +0200
commit175406cdca39bf5b218bb4127a3e9c9bd11b653f (patch)
tree1efd8f8282fb774dbd8d3ba8e912d57cbdbfed13 /meta-multimedia/recipes-multimedia/gstreamer/gst-plugins.inc
parent2b79eeb404af36cffb3f12097175556e5819a88d (diff)
downloadmeta-openembedded-175406cdca39bf5b218bb4127a3e9c9bd11b653f.tar.gz
recipes-multimedia: add gstreamer-0.10 recipes
So that they can be removed from oe-core https://bugzilla.yoctoproject.org/show_bug.cgi?id=6294 Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-multimedia/recipes-multimedia/gstreamer/gst-plugins.inc')
-rw-r--r--meta-multimedia/recipes-multimedia/gstreamer/gst-plugins.inc28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta-multimedia/recipes-multimedia/gstreamer/gst-plugins.inc b/meta-multimedia/recipes-multimedia/gstreamer/gst-plugins.inc
new file mode 100644
index 000000000..123df4251
--- /dev/null
+++ b/meta-multimedia/recipes-multimedia/gstreamer/gst-plugins.inc
@@ -0,0 +1,28 @@
1SUMMARY = "Plugins for the GStreamer multimedia framework"
2HOMEPAGE = "http://gstreamer.freedesktop.org/"
3BUGTRACKER = "https://bugzilla.gnome.org/enter_bug.cgi?product=Gstreamer"
4SECTION = "multimedia"
5DEPENDS = "gstreamer"
6
7inherit autotools pkgconfig
8
9SRC_URI = "http://gstreamer.freedesktop.org/src/${BPN}/${BPN}-${PV}.tar.bz2"
10
11GSTREAMER_DEBUG ?= "--disable-debug"
12EXTRA_OECONF = "--disable-valgrind ${GSTREAMER_DEBUG} --disable-examples "
13
14acpaths = "-I ${S}/common/m4 -I ${S}/m4"
15
16LIBV = "0.10"
17require recipes-multimedia/gstreamer/gst-plugins-package.inc
18
19PACKAGES_DYNAMIC += "^${PN}-.*"
20
21# apply gstreamer hack after Makefile.in.in in source is replaced by our version from
22# ${STAGING_DATADIR_NATIVE}/gettext/po/Makefile.in.in, but before configure is executed
23# http://lists.linuxtogo.org/pipermail/openembedded-core/2012-November/032233.html
24oe_runconf_prepend() {
25 if [ -e ${S}/po/Makefile.in.in ]; then
26 sed -i -e "1a\\" -e 'GETTEXT_PACKAGE = @GETTEXT_PACKAGE@' ${S}/po/Makefile.in.in
27 fi
28}