diff options
author | Paul Gortmaker <paul.gortmaker@windriver.com> | 2017-02-15 13:03:29 -0500 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2017-02-20 11:50:14 +0100 |
commit | 3f39aa0101a0e6ea43846a6a41f0538ac9479200 (patch) | |
tree | f689830cff308b5bdb317d2c22bc76e745ead8fc /meta-multimedia/recipes-multimedia/gstreamer-0.10 | |
parent | cfa4ae250f8d711b9316c73d21b8762ce2c0f448 (diff) | |
download | meta-openembedded-3f39aa0101a0e6ea43846a6a41f0538ac9479200.tar.gz |
gstreamer: fix dependency issue and un-blacklist it
In http://errors.yoctoproject.org/Errors/Details/130583/ we see the
following:
/bin/bash: line 1: glib-mkenums: command not found
/bin/bash: glib-genmarshal: command not found
Makefile:1808: recipe for target 'gstenumtypes.h' failed
make[2]: *** [gstenumtypes.h] Error 127
Most people don't see this because most hosts have these binaries
in /usr/bin -- e.g. libglib2.0-dev in Ubuntu provides them.
However, after making this change, we see the following in the
build for gstreamer:
./recipe-sysroot-native/usr/bin/glib-mkenums
./recipe-sysroot-native/usr/bin/glib-genmarshal
..and hence this change should resolve the above Yocto issue.
Signed-off-by: Paul Gortmaker <paul.gortmaker@windriver.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-multimedia/recipes-multimedia/gstreamer-0.10')
-rw-r--r-- | meta-multimedia/recipes-multimedia/gstreamer-0.10/gstreamer_0.10.36.bb | 4 |
1 files changed, 1 insertions, 3 deletions
diff --git a/meta-multimedia/recipes-multimedia/gstreamer-0.10/gstreamer_0.10.36.bb b/meta-multimedia/recipes-multimedia/gstreamer-0.10/gstreamer_0.10.36.bb index fa80ddac7..5f97a20fd 100644 --- a/meta-multimedia/recipes-multimedia/gstreamer-0.10/gstreamer_0.10.36.bb +++ b/meta-multimedia/recipes-multimedia/gstreamer-0.10/gstreamer_0.10.36.bb | |||
@@ -7,7 +7,7 @@ SECTION = "multimedia" | |||
7 | LICENSE = "LGPLv2+" | 7 | LICENSE = "LGPLv2+" |
8 | LIC_FILES_CHKSUM = "file://COPYING;md5=55ca817ccb7d5b5b66355690e9abc605 \ | 8 | LIC_FILES_CHKSUM = "file://COPYING;md5=55ca817ccb7d5b5b66355690e9abc605 \ |
9 | file://gst/gst.h;beginline=1;endline=21;md5=8e5fe5e87d33a04479fde862e238eaa4" | 9 | file://gst/gst.h;beginline=1;endline=21;md5=8e5fe5e87d33a04479fde862e238eaa4" |
10 | DEPENDS = "glib-2.0 libxml2 bison-native flex-native" | 10 | DEPENDS = "glib-2.0 libxml2 bison-native flex-native glib-2.0-native" |
11 | 11 | ||
12 | PR = "r2" | 12 | PR = "r2" |
13 | 13 | ||
@@ -51,5 +51,3 @@ RRECOMMENDS_${PN}_qemux86-64 += "kernel-module-snd-ens1370 kernel-module-snd-raw | |||
51 | FILES_${PN} += " ${libdir}/gstreamer-0.10/*.so" | 51 | FILES_${PN} += " ${libdir}/gstreamer-0.10/*.so" |
52 | FILES_${PN}-dev += " ${libdir}/gstreamer-0.10/*.la ${libdir}/gstreamer-0.10/*.a" | 52 | FILES_${PN}-dev += " ${libdir}/gstreamer-0.10/*.la ${libdir}/gstreamer-0.10/*.a" |
53 | FILES_${PN}-dbg += " ${libdir}/gstreamer-0.10/.debug/ ${libexecdir}/gstreamer-0.10/.debug/" | 53 | FILES_${PN}-dbg += " ${libdir}/gstreamer-0.10/.debug/ ${libexecdir}/gstreamer-0.10/.debug/" |
54 | |||
55 | PNBLACKLIST[gstreamer] ?= "Fails to build with RSS http://errors.yoctoproject.org/Errors/Details/130583/" | ||