summaryrefslogtreecommitdiffstats
path: root/meta-multimedia/recipes-multimedia/gstreamer-0.10
diff options
context:
space:
mode:
authorCarlos Rafael Giani <dv@pseudoterminal.org>2015-10-19 19:53:19 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2015-10-23 12:53:24 +0200
commit879b4ec5f85805f298e97df7e3489410118841dc (patch)
treecb279d4eda885712225d692ccb9406b1b64edfac /meta-multimedia/recipes-multimedia/gstreamer-0.10
parent06efc118e07e09f5e1c67c35fed94657672d390d (diff)
downloadmeta-openembedded-879b4ec5f85805f298e97df7e3489410118841dc.tar.gz
gst-plugins-ugly: Fix opencore AMR plugin support
opencore 0.1.3 and later use a different header installation path. Fix the gst-plugins-ugly AMR plugin to use the correct paths, and add packageconfigs for amrwb and amrnb. Signed-off-by: Carlos Rafael Giani <dv@pseudoterminal.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-multimedia/recipes-multimedia/gstreamer-0.10')
-rw-r--r--meta-multimedia/recipes-multimedia/gstreamer-0.10/gst-plugins-ugly/0002-Fix-opencore-include-paths.patch58
-rw-r--r--meta-multimedia/recipes-multimedia/gstreamer-0.10/gst-plugins-ugly_0.10.19.bb7
2 files changed, 64 insertions, 1 deletions
diff --git a/meta-multimedia/recipes-multimedia/gstreamer-0.10/gst-plugins-ugly/0002-Fix-opencore-include-paths.patch b/meta-multimedia/recipes-multimedia/gstreamer-0.10/gst-plugins-ugly/0002-Fix-opencore-include-paths.patch
new file mode 100644
index 000000000..3fd6a2697
--- /dev/null
+++ b/meta-multimedia/recipes-multimedia/gstreamer-0.10/gst-plugins-ugly/0002-Fix-opencore-include-paths.patch
@@ -0,0 +1,58 @@
1From e634bc6420826f760f6519a9f134c6a4d3412ef8 Mon Sep 17 00:00:00 2001
2From: Carlos Rafael Giani <dv@pseudoterminal.org>
3Date: Mon, 19 Oct 2015 15:26:24 +0200
4Subject: [PATCH] Fix opencore include paths
5
6Upstream-Status: Inappropriate [no upstream - GStreamer 0.10 is no longer being maintained]
7
8Signed-off-by: Carlos Rafael Giani <dv@pseudoterminal.org>
9---
10 ext/amrnb/amrnbdec.h | 2 +-
11 ext/amrnb/amrnbenc.h | 2 +-
12 ext/amrwbdec/amrwbdec.h | 4 ++--
13 3 files changed, 4 insertions(+), 4 deletions(-)
14
15diff --git a/ext/amrnb/amrnbdec.h b/ext/amrnb/amrnbdec.h
16index 1e81839..01b7154 100644
17--- a/ext/amrnb/amrnbdec.h
18+++ b/ext/amrnb/amrnbdec.h
19@@ -22,7 +22,7 @@
20
21 #include <gst/gst.h>
22 #include <gst/audio/gstaudiodecoder.h>
23-#include <interf_dec.h>
24+#include <opencore-amrnb/interf_dec.h>
25
26 G_BEGIN_DECLS
27
28diff --git a/ext/amrnb/amrnbenc.h b/ext/amrnb/amrnbenc.h
29index 7f673ac..5be39b5 100644
30--- a/ext/amrnb/amrnbenc.h
31+++ b/ext/amrnb/amrnbenc.h
32@@ -21,7 +21,7 @@
33 #define __GST_AMRNBENC_H__
34
35 #include <gst/gst.h>
36-#include <interf_enc.h>
37+#include <opencore-amrnb/interf_enc.h>
38 #include <gst/audio/gstaudioencoder.h>
39
40 G_BEGIN_DECLS
41diff --git a/ext/amrwbdec/amrwbdec.h b/ext/amrwbdec/amrwbdec.h
42index c3528fc..f27c6d2 100644
43--- a/ext/amrwbdec/amrwbdec.h
44+++ b/ext/amrwbdec/amrwbdec.h
45@@ -22,8 +22,8 @@
46
47 #include <gst/gst.h>
48 #include <gst/audio/gstaudiodecoder.h>
49-#include <dec_if.h>
50-#include <if_rom.h>
51+#include <opencore-amrwb/dec_if.h>
52+#include <opencore-amrwb/if_rom.h>
53
54 G_BEGIN_DECLS
55
56--
571.9.1
58
diff --git a/meta-multimedia/recipes-multimedia/gstreamer-0.10/gst-plugins-ugly_0.10.19.bb b/meta-multimedia/recipes-multimedia/gstreamer-0.10/gst-plugins-ugly_0.10.19.bb
index 11f20cad8..a8cb85275 100644
--- a/meta-multimedia/recipes-multimedia/gstreamer-0.10/gst-plugins-ugly_0.10.19.bb
+++ b/meta-multimedia/recipes-multimedia/gstreamer-0.10/gst-plugins-ugly_0.10.19.bb
@@ -19,6 +19,8 @@ PACKAGECONFIG ??= ""
19PACKAGECONFIG[x264] = "--enable-x264,--disable-x264,x264" 19PACKAGECONFIG[x264] = "--enable-x264,--disable-x264,x264"
20PACKAGECONFIG[cdio] = "--enable-cdio,--disable-cdio,libcdio" 20PACKAGECONFIG[cdio] = "--enable-cdio,--disable-cdio,libcdio"
21PACKAGECONFIG[dvdread] = "--enable-dvdread,--disable-dvdread,libdvdread" 21PACKAGECONFIG[dvdread] = "--enable-dvdread,--disable-dvdread,libdvdread"
22PACKAGECONFIG[amrnb] = "--enable-amrnb,--disable-amrnb,opencore-amr"
23PACKAGECONFIG[amrwb] = "--enable-amrwb,--disable-amrwb,opencore-amr"
22 24
23do_configure_prepend() { 25do_configure_prepend() {
24 # This m4 file contains nastiness which conflicts with libtool 2.2.2 26 # This m4 file contains nastiness which conflicts with libtool 2.2.2
@@ -27,4 +29,7 @@ do_configure_prepend() {
27 29
28SRC_URI[md5sum] = "1d81c593e22a6cdf0f2b4f57eae93df2" 30SRC_URI[md5sum] = "1d81c593e22a6cdf0f2b4f57eae93df2"
29SRC_URI[sha256sum] = "1ca90059275c0f5dca71d4d1601a8f429b7852baed0723e820703b977e2c8df0" 31SRC_URI[sha256sum] = "1ca90059275c0f5dca71d4d1601a8f429b7852baed0723e820703b977e2c8df0"
30SRC_URI += "file://0001-cdio-compensate-for-libcdio-s-recent-cd-text-api-cha.patch" 32SRC_URI += "file://0001-cdio-compensate-for-libcdio-s-recent-cd-text-api-cha.patch \
33 file://0002-Fix-opencore-include-paths.patch"
34
35FILES_${PN}-amrnb += "${datadir}/gstreamer-0.10/presets/GstAmrnbEnc.prs"