diff options
author | William A. Kennington III <wak@google.com> | 2022-09-29 12:01:09 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2022-09-29 19:18:27 -0700 |
commit | 3efcb4c5f8fe8d2779118218ebc5f3d3bd7a87d1 (patch) | |
tree | 96680a75d25a8abbda7323887e96631713b4d7c1 /meta-multimedia/recipes-multimedia/gerbera | |
parent | 8480f29d18df66521192477378a3e72b8be46e84 (diff) | |
download | meta-openembedded-3efcb4c5f8fe8d2779118218ebc5f3d3bd7a87d1.tar.gz |
gerbera: upgrade 1.9.2 -> 1.11.0
Signed-off-by: William A. Kennington III <wak@google.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-multimedia/recipes-multimedia/gerbera')
-rw-r--r-- | meta-multimedia/recipes-multimedia/gerbera/gerbera/0001-Fix-build-with-fmt-9.0.patch | 35 | ||||
-rw-r--r-- | meta-multimedia/recipes-multimedia/gerbera/gerbera/0001-Fix-for-fmt-8.0.patch | 46 | ||||
-rw-r--r-- | meta-multimedia/recipes-multimedia/gerbera/gerbera_1.11.0.bb (renamed from meta-multimedia/recipes-multimedia/gerbera/gerbera_1.9.2.bb) | 6 |
3 files changed, 38 insertions, 49 deletions
diff --git a/meta-multimedia/recipes-multimedia/gerbera/gerbera/0001-Fix-build-with-fmt-9.0.patch b/meta-multimedia/recipes-multimedia/gerbera/gerbera/0001-Fix-build-with-fmt-9.0.patch new file mode 100644 index 000000000..9de0e4f28 --- /dev/null +++ b/meta-multimedia/recipes-multimedia/gerbera/gerbera/0001-Fix-build-with-fmt-9.0.patch | |||
@@ -0,0 +1,35 @@ | |||
1 | From d7b8fafbc94405c20753fed569abd8878cccde89 Mon Sep 17 00:00:00 2001 | ||
2 | From: Felix Yan <felixonmars@archlinux.org> | ||
3 | Date: Fri, 19 Aug 2022 15:22:10 +0300 | ||
4 | Subject: [PATCH] Fix build with fmt 9.0 | ||
5 | |||
6 | Fixes #2681 | ||
7 | --- | ||
8 | src/database/sql_format.h | 4 ++-- | ||
9 | 1 file changed, 2 insertions(+), 2 deletions(-) | ||
10 | |||
11 | diff --git a/src/database/sql_format.h b/src/database/sql_format.h | ||
12 | index 32dc00ef..e4e1909a 100644 | ||
13 | --- a/src/database/sql_format.h | ||
14 | +++ b/src/database/sql_format.h | ||
15 | @@ -42,7 +42,7 @@ struct SQLIdentifier { | ||
16 | template <> | ||
17 | struct fmt::formatter<SQLIdentifier> : formatter<std::string_view> { | ||
18 | template <typename FormatContext> | ||
19 | - auto format(const SQLIdentifier& tn, FormatContext& ctx) -> decltype(ctx.out()) | ||
20 | + auto format(const SQLIdentifier& tn, FormatContext& ctx) const -> decltype(ctx.out()) | ||
21 | { | ||
22 | return format_to(ctx.out(), "{}{}{}", tn.quote_begin, tn.name, tn.quote_end); | ||
23 | } | ||
24 | @@ -61,7 +61,7 @@ struct ColumnUpdate { | ||
25 | template <> | ||
26 | struct fmt::formatter<ColumnUpdate> : formatter<std::string_view> { | ||
27 | template <typename FormatContext> | ||
28 | - auto format(const ColumnUpdate& a, FormatContext& ctx) -> decltype(ctx.out()) | ||
29 | + auto format(const ColumnUpdate& a, FormatContext& ctx) const -> decltype(ctx.out()) | ||
30 | { | ||
31 | return format_to(ctx.out(), "{} = {}", a.column, a.value); | ||
32 | } | ||
33 | -- | ||
34 | 2.38.0.rc1.362.ged0d419d3c-goog | ||
35 | |||
diff --git a/meta-multimedia/recipes-multimedia/gerbera/gerbera/0001-Fix-for-fmt-8.0.patch b/meta-multimedia/recipes-multimedia/gerbera/gerbera/0001-Fix-for-fmt-8.0.patch deleted file mode 100644 index efd8dc066..000000000 --- a/meta-multimedia/recipes-multimedia/gerbera/gerbera/0001-Fix-for-fmt-8.0.patch +++ /dev/null | |||
@@ -1,46 +0,0 @@ | |||
1 | From 22b3a91473d548456a0823f9f170db0d7db5a444 Mon Sep 17 00:00:00 2001 | ||
2 | From: kyak <bas@bmail.ru> | ||
3 | Date: Wed, 12 Jan 2022 19:41:37 +0300 | ||
4 | Subject: [PATCH] Fix for fmt > 8.0 | ||
5 | |||
6 | Upstream-Status: Backport [https://github.com/gerbera/gerbera/commit/82d84ac5e62c23e717198fc7b2ef190ff95e70d1] | ||
7 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
8 | --- | ||
9 | src/util/logger.h | 15 +++++++++++++++ | ||
10 | 1 file changed, 15 insertions(+) | ||
11 | |||
12 | diff --git a/src/util/logger.h b/src/util/logger.h | ||
13 | index 8a8f0b1f..0a512bff 100644 | ||
14 | --- a/src/util/logger.h | ||
15 | +++ b/src/util/logger.h | ||
16 | @@ -32,7 +32,9 @@ | ||
17 | #ifndef __LOGGER_H__ | ||
18 | #define __LOGGER_H__ | ||
19 | |||
20 | +#include <fmt/format.h> | ||
21 | #include <spdlog/spdlog.h> | ||
22 | +#include <type_traits> | ||
23 | |||
24 | #define log_debug SPDLOG_DEBUG | ||
25 | #define log_info SPDLOG_INFO | ||
26 | @@ -40,4 +42,17 @@ | ||
27 | #define log_error SPDLOG_ERROR | ||
28 | #define log_js SPDLOG_INFO | ||
29 | |||
30 | +#if FMT_VERSION >= 80100 | ||
31 | +template <typename T> | ||
32 | +struct fmt::formatter<T, std::enable_if_t<std::is_enum_v<T>, char>> | ||
33 | + : formatter<std::underlying_type_t<T>> { | ||
34 | + template <typename FormatContext> | ||
35 | + auto format(const T& value, FormatContext& ctx) -> decltype(ctx.out()) | ||
36 | + { | ||
37 | + return fmt::formatter<std::underlying_type_t<T>>::format( | ||
38 | + static_cast<std::underlying_type_t<T>>(value), ctx); | ||
39 | + } | ||
40 | +}; | ||
41 | +#endif | ||
42 | + | ||
43 | #endif // __LOGGER_H__ | ||
44 | -- | ||
45 | 2.35.0 | ||
46 | |||
diff --git a/meta-multimedia/recipes-multimedia/gerbera/gerbera_1.9.2.bb b/meta-multimedia/recipes-multimedia/gerbera/gerbera_1.11.0.bb index cbb127d3d..9f2f1b093 100644 --- a/meta-multimedia/recipes-multimedia/gerbera/gerbera_1.9.2.bb +++ b/meta-multimedia/recipes-multimedia/gerbera/gerbera_1.11.0.bb | |||
@@ -3,11 +3,11 @@ Description = "Gerbera - An UPnP media server" | |||
3 | LICENSE = "GPL-2.0-only" | 3 | LICENSE = "GPL-2.0-only" |
4 | LIC_FILES_CHKSUM = "file://LICENSE.md;md5=25cdec9afe3f1f26212ead6bd2f7fac8" | 4 | LIC_FILES_CHKSUM = "file://LICENSE.md;md5=25cdec9afe3f1f26212ead6bd2f7fac8" |
5 | 5 | ||
6 | SRC_URI = "git://github.com/v00d00/gerbera.git;protocol=https;branch=master \ | 6 | SRC_URI = "git://github.com/gerbera/gerbera.git;protocol=https;branch=master \ |
7 | file://0001-Fix-for-fmt-8.0.patch \ | 7 | file://0001-Fix-build-with-fmt-9.0.patch \ |
8 | " | 8 | " |
9 | 9 | ||
10 | SRCREV = "3b93d362ec33f738868a4e896a2c9ee8e9d7a92a" | 10 | SRCREV = "d73d8c1346213d784753c02ea771970500e0df2a" |
11 | 11 | ||
12 | S = "${WORKDIR}/git" | 12 | S = "${WORKDIR}/git" |
13 | 13 | ||