summaryrefslogtreecommitdiffstats
path: root/meta-multimedia/recipes-mkv
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-04-13 22:49:41 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-15 16:23:17 +0200
commita45830a39bb47a9eab27980d52966226c9504ea4 (patch)
tree001209d9740e8668b2eeeac4212b3561aecebf29 /meta-multimedia/recipes-mkv
parent6f48cf899aed0622f8fb26ffa144656a1143c9c5 (diff)
downloadmeta-openembedded-a45830a39bb47a9eab27980d52966226c9504ea4.tar.gz
recipes: Unify indentation
* This change is only aesthetic (unlike indentation in Python tasks). * Some recipes were using tabs. * Some were using 8 spaces. * Some were using mix or different number of spaces. * Make them consistently use 4 spaces everywhere. * Yocto styleguide advises to use tabs (but the only reason to keep tabs is the need to update a lot of recipes). Lately this advice was also merged into the styleguide on the OE wiki. * Using 4 spaces in both types of tasks is better because it's less error prone when someone is not sure if e.g. do_generate_toolchain_file() is Python or shell task and also allows to highlight every tab used in .bb, .inc, .bbappend, .bbclass as potentially bad (shouldn't be used for indenting of multiline variable assignments and cannot be used for Python tasks). * Don't indent closing quote on multiline variables we're quite inconsistent wheater it's first character on line under opening quote or under first non-whitespace character in previous line. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Acked-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-multimedia/recipes-mkv')
-rw-r--r--meta-multimedia/recipes-mkv/libebml/libebml_1.2.2.bb30
-rw-r--r--meta-multimedia/recipes-mkv/libmatroska/libmatroska_1.3.0.bb30
-rw-r--r--meta-multimedia/recipes-mkv/mkvtoolnix/mkvtoolnix_5.9.0.bb8
3 files changed, 34 insertions, 34 deletions
diff --git a/meta-multimedia/recipes-mkv/libebml/libebml_1.2.2.bb b/meta-multimedia/recipes-mkv/libebml/libebml_1.2.2.bb
index 210a40995..b66160d59 100644
--- a/meta-multimedia/recipes-mkv/libebml/libebml_1.2.2.bb
+++ b/meta-multimedia/recipes-mkv/libebml/libebml_1.2.2.bb
@@ -7,25 +7,25 @@ SRC_URI[md5sum] = "726cc2bd1a525929ff35ff9854c0ebab"
7SRC_URI[sha256sum] = "476b08c6436a96c024a53e788e7c945ce9b41cd8654165763444aa7e5245b7a5" 7SRC_URI[sha256sum] = "476b08c6436a96c024a53e788e7c945ce9b41cd8654165763444aa7e5245b7a5"
8 8
9do_compile() { 9do_compile() {
10 cd ${S}/make/linux 10 cd ${S}/make/linux
11 oe_runmake CROSS="${TARGET_PREFIX}" 11 oe_runmake CROSS="${TARGET_PREFIX}"
12} 12}
13 13
14do_install() { 14do_install() {
15 cd ${S}/make/linux 15 cd ${S}/make/linux
16 16
17 install -d ${D}${libdir} 17 install -d ${D}${libdir}
18 install -m 0644 libebml.a ${D}${libdir} 18 install -m 0644 libebml.a ${D}${libdir}
19 install -m 0755 libebml.so.* ${D}${libdir} 19 install -m 0755 libebml.so.* ${D}${libdir}
20 cp -a libebml.so ${D}${libdir} 20 cp -a libebml.so ${D}${libdir}
21 21
22 install -d ${D}${includedir}/ebml 22 install -d ${D}${includedir}/ebml
23 for i in ../../ebml/*.h; do 23 for i in ../../ebml/*.h; do
24 install -m 0644 $i ${D}${includedir}/ebml 24 install -m 0644 $i ${D}${includedir}/ebml
25 done 25 done
26 26
27 install -d ${D}${includedir}/ebml/c 27 install -d ${D}${includedir}/ebml/c
28 for i in ../../ebml/c/*.h; do 28 for i in ../../ebml/c/*.h; do
29 install -m 0644 $i ${D}${includedir}/ebml/c 29 install -m 0644 $i ${D}${includedir}/ebml/c
30 done 30 done
31} 31}
diff --git a/meta-multimedia/recipes-mkv/libmatroska/libmatroska_1.3.0.bb b/meta-multimedia/recipes-mkv/libmatroska/libmatroska_1.3.0.bb
index 3a3dd0e95..cedd283b1 100644
--- a/meta-multimedia/recipes-mkv/libmatroska/libmatroska_1.3.0.bb
+++ b/meta-multimedia/recipes-mkv/libmatroska/libmatroska_1.3.0.bb
@@ -9,25 +9,25 @@ SRC_URI[md5sum] = "f4a8c411f09d39c754eb726efd616043"
9SRC_URI[sha256sum] = "5231ec958571365e719a6fd3c220227af6cf0f14e0bd1bcf766ddbc068d18e69" 9SRC_URI[sha256sum] = "5231ec958571365e719a6fd3c220227af6cf0f14e0bd1bcf766ddbc068d18e69"
10 10
11do_compile() { 11do_compile() {
12 cd ${S}/make/linux 12 cd ${S}/make/linux
13 oe_runmake CROSS="${TARGET_PREFIX}" 13 oe_runmake CROSS="${TARGET_PREFIX}"
14} 14}
15 15
16do_install() { 16do_install() {
17 cd ${S}/make/linux 17 cd ${S}/make/linux
18 18
19 install -d ${D}${libdir} 19 install -d ${D}${libdir}
20 install -m 0644 libmatroska.a ${D}${libdir} 20 install -m 0644 libmatroska.a ${D}${libdir}
21 install -m 0755 libmatroska.so.* ${D}${libdir} 21 install -m 0755 libmatroska.so.* ${D}${libdir}
22 cp -a libmatroska.so ${D}${libdir} 22 cp -a libmatroska.so ${D}${libdir}
23 23
24 install -d ${D}${includedir}/matroska 24 install -d ${D}${includedir}/matroska
25 for i in ../../matroska/*.h; do 25 for i in ../../matroska/*.h; do
26 install -m 0644 $i ${D}${includedir}/matroska 26 install -m 0644 $i ${D}${includedir}/matroska
27 done 27 done
28 28
29 install -d ${D}${includedir}/matroska/c 29 install -d ${D}${includedir}/matroska/c
30 for i in ../../matroska/c/*.h; do 30 for i in ../../matroska/c/*.h; do
31 install -m 0644 $i ${D}${includedir}/matroska/c 31 install -m 0644 $i ${D}${includedir}/matroska/c
32 done 32 done
33} 33}
diff --git a/meta-multimedia/recipes-mkv/mkvtoolnix/mkvtoolnix_5.9.0.bb b/meta-multimedia/recipes-mkv/mkvtoolnix/mkvtoolnix_5.9.0.bb
index e7f93d2c2..13edaa95f 100644
--- a/meta-multimedia/recipes-mkv/mkvtoolnix/mkvtoolnix_5.9.0.bb
+++ b/meta-multimedia/recipes-mkv/mkvtoolnix/mkvtoolnix_5.9.0.bb
@@ -13,18 +13,18 @@ SRC_URI[sha256sum] = "d913f531331c3332d2fb334c872ea19bfea7293dfedc4bf33ae7162e4e
13inherit autotools 13inherit autotools
14 14
15EXTRA_OECONF = " --with-boost-libdir=${STAGING_LIBDIR} \ 15EXTRA_OECONF = " --with-boost-libdir=${STAGING_LIBDIR} \
16 " 16"
17 17
18# remove some hardcoded searchpaths 18# remove some hardcoded searchpaths
19do_configure_prepend() { 19do_configure_prepend() {
20 sed -i -e s:/usr/local/lib:${STAGING_LIBDIR}:g -e s:/usr/local/include:${STAGING_INCDIR}:g ac/ebml.m4 20 sed -i -e s:/usr/local/lib:${STAGING_LIBDIR}:g -e s:/usr/local/include:${STAGING_INCDIR}:g ac/ebml.m4
21} 21}
22 22
23# Yeah, no makefile 23# Yeah, no makefile
24do_compile() { 24do_compile() {
25 ./drake 25 ./drake
26} 26}
27 27
28do_install() { 28do_install() {
29 ./drake install DESTDIR=${D} 29 ./drake install DESTDIR=${D}
30} 30}