summaryrefslogtreecommitdiffstats
path: root/meta-multimedia/recipes-mkv/libebml
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-04-13 22:49:41 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-15 16:23:17 +0200
commita45830a39bb47a9eab27980d52966226c9504ea4 (patch)
tree001209d9740e8668b2eeeac4212b3561aecebf29 /meta-multimedia/recipes-mkv/libebml
parent6f48cf899aed0622f8fb26ffa144656a1143c9c5 (diff)
downloadmeta-openembedded-a45830a39bb47a9eab27980d52966226c9504ea4.tar.gz
recipes: Unify indentation
* This change is only aesthetic (unlike indentation in Python tasks). * Some recipes were using tabs. * Some were using 8 spaces. * Some were using mix or different number of spaces. * Make them consistently use 4 spaces everywhere. * Yocto styleguide advises to use tabs (but the only reason to keep tabs is the need to update a lot of recipes). Lately this advice was also merged into the styleguide on the OE wiki. * Using 4 spaces in both types of tasks is better because it's less error prone when someone is not sure if e.g. do_generate_toolchain_file() is Python or shell task and also allows to highlight every tab used in .bb, .inc, .bbappend, .bbclass as potentially bad (shouldn't be used for indenting of multiline variable assignments and cannot be used for Python tasks). * Don't indent closing quote on multiline variables we're quite inconsistent wheater it's first character on line under opening quote or under first non-whitespace character in previous line. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Acked-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-multimedia/recipes-mkv/libebml')
-rw-r--r--meta-multimedia/recipes-mkv/libebml/libebml_1.2.2.bb30
1 files changed, 15 insertions, 15 deletions
diff --git a/meta-multimedia/recipes-mkv/libebml/libebml_1.2.2.bb b/meta-multimedia/recipes-mkv/libebml/libebml_1.2.2.bb
index 210a40995..b66160d59 100644
--- a/meta-multimedia/recipes-mkv/libebml/libebml_1.2.2.bb
+++ b/meta-multimedia/recipes-mkv/libebml/libebml_1.2.2.bb
@@ -7,25 +7,25 @@ SRC_URI[md5sum] = "726cc2bd1a525929ff35ff9854c0ebab"
7SRC_URI[sha256sum] = "476b08c6436a96c024a53e788e7c945ce9b41cd8654165763444aa7e5245b7a5" 7SRC_URI[sha256sum] = "476b08c6436a96c024a53e788e7c945ce9b41cd8654165763444aa7e5245b7a5"
8 8
9do_compile() { 9do_compile() {
10 cd ${S}/make/linux 10 cd ${S}/make/linux
11 oe_runmake CROSS="${TARGET_PREFIX}" 11 oe_runmake CROSS="${TARGET_PREFIX}"
12} 12}
13 13
14do_install() { 14do_install() {
15 cd ${S}/make/linux 15 cd ${S}/make/linux
16 16
17 install -d ${D}${libdir} 17 install -d ${D}${libdir}
18 install -m 0644 libebml.a ${D}${libdir} 18 install -m 0644 libebml.a ${D}${libdir}
19 install -m 0755 libebml.so.* ${D}${libdir} 19 install -m 0755 libebml.so.* ${D}${libdir}
20 cp -a libebml.so ${D}${libdir} 20 cp -a libebml.so ${D}${libdir}
21 21
22 install -d ${D}${includedir}/ebml 22 install -d ${D}${includedir}/ebml
23 for i in ../../ebml/*.h; do 23 for i in ../../ebml/*.h; do
24 install -m 0644 $i ${D}${includedir}/ebml 24 install -m 0644 $i ${D}${includedir}/ebml
25 done 25 done
26 26
27 install -d ${D}${includedir}/ebml/c 27 install -d ${D}${includedir}/ebml/c
28 for i in ../../ebml/c/*.h; do 28 for i in ../../ebml/c/*.h; do
29 install -m 0644 $i ${D}${includedir}/ebml/c 29 install -m 0644 $i ${D}${includedir}/ebml/c
30 done 30 done
31} 31}