summaryrefslogtreecommitdiffstats
path: root/meta-multimedia/recipes-mediacentre
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-04-13 22:49:41 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-15 16:23:17 +0200
commita45830a39bb47a9eab27980d52966226c9504ea4 (patch)
tree001209d9740e8668b2eeeac4212b3561aecebf29 /meta-multimedia/recipes-mediacentre
parent6f48cf899aed0622f8fb26ffa144656a1143c9c5 (diff)
downloadmeta-openembedded-a45830a39bb47a9eab27980d52966226c9504ea4.tar.gz
recipes: Unify indentation
* This change is only aesthetic (unlike indentation in Python tasks). * Some recipes were using tabs. * Some were using 8 spaces. * Some were using mix or different number of spaces. * Make them consistently use 4 spaces everywhere. * Yocto styleguide advises to use tabs (but the only reason to keep tabs is the need to update a lot of recipes). Lately this advice was also merged into the styleguide on the OE wiki. * Using 4 spaces in both types of tasks is better because it's less error prone when someone is not sure if e.g. do_generate_toolchain_file() is Python or shell task and also allows to highlight every tab used in .bb, .inc, .bbappend, .bbclass as potentially bad (shouldn't be used for indenting of multiline variable assignments and cannot be used for Python tasks). * Don't indent closing quote on multiline variables we're quite inconsistent wheater it's first character on line under opening quote or under first non-whitespace character in previous line. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Acked-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-multimedia/recipes-mediacentre')
-rw-r--r--meta-multimedia/recipes-mediacentre/xbmc/xbmc_git.bb36
1 files changed, 18 insertions, 18 deletions
diff --git a/meta-multimedia/recipes-mediacentre/xbmc/xbmc_git.bb b/meta-multimedia/recipes-mediacentre/xbmc/xbmc_git.bb
index 74bf71066..605348959 100644
--- a/meta-multimedia/recipes-mediacentre/xbmc/xbmc_git.bb
+++ b/meta-multimedia/recipes-mediacentre/xbmc/xbmc_git.bb
@@ -16,23 +16,23 @@ SRC_URI = "git://github.com/xbmc/xbmc.git;branch=eden;protocol=git \
16 file://0002-Revert-fixed-ios-Add-memory-barriers-to-atomic-Add-S.patch \ 16 file://0002-Revert-fixed-ios-Add-memory-barriers-to-atomic-Add-S.patch \
17 file://0003-Revert-fixed-ios-Add-memory-barriers-to-cas-assembly.patch \ 17 file://0003-Revert-fixed-ios-Add-memory-barriers-to-cas-assembly.patch \
18 file://configure.in-Avoid-running-code.patch \ 18 file://configure.in-Avoid-running-code.patch \
19 " 19"
20 20
21inherit autotools gettext python-dir 21inherit autotools gettext python-dir
22 22
23S = "${WORKDIR}/git" 23S = "${WORKDIR}/git"
24 24
25CACHED_CONFIGUREVARS += " \ 25CACHED_CONFIGUREVARS += " \
26 ac_cv_path_PYTHON="${STAGING_BINDIR_NATIVE}/python-native/python" \ 26 ac_cv_path_PYTHON="${STAGING_BINDIR_NATIVE}/python-native/python" \
27" 27"
28 28
29EXTRA_OECONF = " \ 29EXTRA_OECONF = " \
30 --disable-rpath \ 30 --disable-rpath \
31 --enable-gles \ 31 --enable-gles \
32 --enable-libusb \ 32 --enable-libusb \
33 --enable-airplay \ 33 --enable-airplay \
34 --disable-optical-drive \ 34 --disable-optical-drive \
35 --enable-external-libraries \ 35 --enable-external-libraries \
36" 36"
37 37
38FULL_OPTIMIZATION_armv7a = "-fexpensive-optimizations -fomit-frame-pointer -O4 -ffast-math" 38FULL_OPTIMIZATION_armv7a = "-fexpensive-optimizations -fomit-frame-pointer -O4 -ffast-math"
@@ -48,27 +48,27 @@ export STAGING_INCDIR
48export PYTHON_DIR 48export PYTHON_DIR
49 49
50do_configure() { 50do_configure() {
51 sh bootstrap 51 sh bootstrap
52 oe_runconf 52 oe_runconf
53} 53}
54 54
55PARALLEL_MAKE = "" 55PARALLEL_MAKE = ""
56 56
57do_compile_prepend() { 57do_compile_prepend() {
58 for i in $(find . -name "Makefile") ; do 58 for i in $(find . -name "Makefile") ; do
59 sed -i -e 's:I/usr/include:I${STAGING_INCDIR}:g' $i 59 sed -i -e 's:I/usr/include:I${STAGING_INCDIR}:g' $i
60 done 60 done
61 61
62 for i in $(find . -name "*.mak*" -o -name "Makefile") ; do 62 for i in $(find . -name "*.mak*" -o -name "Makefile") ; do
63 sed -i -e 's:I/usr/include:I${STAGING_INCDIR}:g' -e 's:-rpath \$(libdir):-rpath ${libdir}:g' $i 63 sed -i -e 's:I/usr/include:I${STAGING_INCDIR}:g' -e 's:-rpath \$(libdir):-rpath ${libdir}:g' $i
64 done 64 done
65} 65}
66 66
67INSANE_SKIP_${PN} = "rpaths" 67INSANE_SKIP_${PN} = "rpaths"
68 68
69# on ARM architectures xbmc will use GLES which will make the regular wrapper fail, so start it directly 69# on ARM architectures xbmc will use GLES which will make the regular wrapper fail, so start it directly
70do_install_append_arm() { 70do_install_append_arm() {
71 sed -i -e 's:Exec=xbmc:Exec=${libdir}/xbmc/xbmc.bin:g' ${D}${datadir}/applications/xbmc.desktop 71 sed -i -e 's:Exec=xbmc:Exec=${libdir}/xbmc/xbmc.bin:g' ${D}${datadir}/applications/xbmc.desktop
72} 72}
73 73
74FILES_${PN} += "${datadir}/xsessions ${datadir}/icons" 74FILES_${PN} += "${datadir}/xsessions ${datadir}/icons"
@@ -81,5 +81,5 @@ RRECOMMENDS_${PN}_append = " libcec \
81 python-re \ 81 python-re \
82 python-netclient \ 82 python-netclient \
83 libcurl \ 83 libcurl \
84 " 84"
85RRECOMMENDS_${PN}_append_libc-glibc = " glibc-charmap-ibm850 glibc-gconv-ibm850" 85RRECOMMENDS_${PN}_append_libc-glibc = " glibc-charmap-ibm850 glibc-gconv-ibm850"