diff options
author | Khem Raj <raj.khem@gmail.com> | 2016-11-03 14:19:12 -0700 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2017-02-06 16:48:14 +0100 |
commit | 99fce36cad8510911b8d72d27f03c381c9966c6b (patch) | |
tree | 3ab59d38035ef5b6952e71103e5c387ecaed5c80 /meta-multimedia/recipes-mediacenter | |
parent | ab4369c5841e7f87bdc52aa8a67363c4e6524211 (diff) | |
download | meta-openembedded-99fce36cad8510911b8d72d27f03c381c9966c6b.tar.gz |
kodi: Fix build with pic on x86_64
Upgrade 17.x to latest on master
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-multimedia/recipes-mediacenter')
-rw-r--r-- | meta-multimedia/recipes-mediacenter/kodi/kodi-17/0005-Always-compile-libcpluff-as-PIC.patch | 30 | ||||
-rw-r--r-- | meta-multimedia/recipes-mediacenter/kodi/kodi_17.bb | 3 |
2 files changed, 32 insertions, 1 deletions
diff --git a/meta-multimedia/recipes-mediacenter/kodi/kodi-17/0005-Always-compile-libcpluff-as-PIC.patch b/meta-multimedia/recipes-mediacenter/kodi/kodi-17/0005-Always-compile-libcpluff-as-PIC.patch new file mode 100644 index 000000000..f513334bf --- /dev/null +++ b/meta-multimedia/recipes-mediacenter/kodi/kodi-17/0005-Always-compile-libcpluff-as-PIC.patch | |||
@@ -0,0 +1,30 @@ | |||
1 | From 603e8925a8b1609d483d866346a35fefbc66cfca Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Thu, 3 Nov 2016 13:10:00 -0700 | ||
4 | Subject: [PATCH 5/5] Always compile libcpluff as PIC | ||
5 | |||
6 | Fixes errors e.g. | ||
7 | |||
8 | ld: lib/cpluff/libcpluff/.libs/libcpluff.a(pcontrol.o): relocation R_X86_64_PC32 against symbol `cp_stop_plugins' can not be used when making a shared object; recompile with -fPIC | ||
9 | |||
10 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
11 | --- | ||
12 | configure.ac | 2 +- | ||
13 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
14 | |||
15 | diff --git a/configure.ac b/configure.ac | ||
16 | index b210b73..52d5f11 100644 | ||
17 | --- a/configure.ac | ||
18 | +++ b/configure.ac | ||
19 | @@ -2385,7 +2385,7 @@ XB_CONFIG_MODULE([lib/cpluff], [ | ||
20 | --prefix="${prefix}" --includedir="${includedir}" --libdir="${libdir}" --datadir="${datadir}" \ | ||
21 | --host=$host_alias \ | ||
22 | --build=$build_alias \ | ||
23 | - --target=$target_alias CFLAGS="$CFLAGS" CC="$CC" CXX="$CXX" LDFLAGS="$LDFLAGS" LIBS="" | ||
24 | + --target=$target_alias --with-pic=yes CFLAGS="$CFLAGS" CC="$CC" CXX="$CXX" LDFLAGS="$LDFLAGS" LIBS="" | ||
25 | #LDFLAGS="$LDFLAGS -Wl,-read_only_relocs,suppress" | ||
26 | ], [0]) | ||
27 | |||
28 | -- | ||
29 | 2.10.2 | ||
30 | |||
diff --git a/meta-multimedia/recipes-mediacenter/kodi/kodi_17.bb b/meta-multimedia/recipes-mediacenter/kodi/kodi_17.bb index c9de5920d..ba14d6433 100644 --- a/meta-multimedia/recipes-mediacenter/kodi/kodi_17.bb +++ b/meta-multimedia/recipes-mediacenter/kodi/kodi_17.bb | |||
@@ -63,13 +63,14 @@ DEPENDS = " \ | |||
63 | 63 | ||
64 | PROVIDES = "xbmc" | 64 | PROVIDES = "xbmc" |
65 | 65 | ||
66 | SRCREV = "32c7788e7cce711be5b7f3893c82dddd79658268" | 66 | SRCREV = "7f6abd1dd6d1aefcb4303083f34aaa90a8df9fce" |
67 | PV = "17.0+gitr${SRCPV}" | 67 | PV = "17.0+gitr${SRCPV}" |
68 | SRC_URI = "git://github.com/xbmc/xbmc.git;branch=master \ | 68 | SRC_URI = "git://github.com/xbmc/xbmc.git;branch=master \ |
69 | file://0001-configure-don-t-try-to-run-stuff-to-find-tinyxml.patch \ | 69 | file://0001-configure-don-t-try-to-run-stuff-to-find-tinyxml.patch \ |
70 | file://0002-handle-SIGTERM.patch \ | 70 | file://0002-handle-SIGTERM.patch \ |
71 | file://0003-add-support-to-read-frequency-output-if-using-intel-.patch \ | 71 | file://0003-add-support-to-read-frequency-output-if-using-intel-.patch \ |
72 | file://0004-Disable-DVD-support.patch \ | 72 | file://0004-Disable-DVD-support.patch \ |
73 | file://0005-Always-compile-libcpluff-as-PIC.patch \ | ||
73 | " | 74 | " |
74 | 75 | ||
75 | inherit autotools-brokensep gettext pythonnative | 76 | inherit autotools-brokensep gettext pythonnative |