diff options
author | Martin Jansa <Martin.Jansa@gmail.com> | 2017-04-27 11:04:51 +0200 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2017-08-31 10:18:33 +0200 |
commit | ec9e5ed06256ad92c818474cdb490dc0d3a0d0a3 (patch) | |
tree | e16d2a838f4561d5538928a58f805e5f1373225a /meta-multimedia/recipes-dvb | |
parent | 6775acb048dabd624c5c8197b683aba45ed91569 (diff) | |
download | meta-openembedded-ec9e5ed06256ad92c818474cdb490dc0d3a0d0a3.tar.gz |
recipes: remove blacklisted recipes
* as PNBLACKLIST message says, these recipes are blacklisted for long
time and nobody showed any interest to fix them
* remove all unused .patch and .inc files as well
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-multimedia/recipes-dvb')
7 files changed, 0 insertions, 359 deletions
diff --git a/meta-multimedia/recipes-dvb/dvb-apps/dvb-apps_1.1.1.bb b/meta-multimedia/recipes-dvb/dvb-apps/dvb-apps_1.1.1.bb deleted file mode 100644 index 4a7ed9a6e..000000000 --- a/meta-multimedia/recipes-dvb/dvb-apps/dvb-apps_1.1.1.bb +++ /dev/null | |||
@@ -1,136 +0,0 @@ | |||
1 | HOMEPAGE = "http://www.linuxtv.org" | ||
2 | SUMMARY = "Linux DVB API applications and utilities" | ||
3 | |||
4 | LICENSE = "GPLv2" | ||
5 | LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe" | ||
6 | |||
7 | DEPENDS = "v4l-utils-native" | ||
8 | |||
9 | SRC_URI = " \ | ||
10 | hg://linuxtv.org/hg;module=dvb-apps;protocol=http;name=apps \ | ||
11 | git://linuxtv.org/git/dtv-scan-tables.git;protocol=http;destsuffix=dvb-apps/initial-scan-tables;name=scantables \ | ||
12 | " | ||
13 | SRCREV_apps = "3d43b280298c" | ||
14 | SRCREV_scantables = "ceb11833b35f05813b1f0397a60e0f3b99430aab" | ||
15 | SRCREV_FORMAT = "apps_scantables" | ||
16 | |||
17 | S = "${WORKDIR}/${BPN}" | ||
18 | |||
19 | TARGET_CC_ARCH += "${LDFLAGS}" | ||
20 | EXTRA_OEMAKE = "VERSION_FILE='${STAGING_INCDIR}/linux/dvb/version.h'" | ||
21 | |||
22 | do_configure() { | ||
23 | sed -i -e s:/usr/include:${STAGING_INCDIR}:g util/av7110_loadkeys/generate-keynames.sh | ||
24 | } | ||
25 | |||
26 | do_compile_append() { | ||
27 | # dvb-apps only support DVBAPI v3, so generate them from the DVBAPI v5 downloaded files | ||
28 | make -C initial-scan-tables clean | ||
29 | make -C initial-scan-tables dvbv3 | ||
30 | } | ||
31 | |||
32 | do_install() { | ||
33 | make DESTDIR=${D} install | ||
34 | # dvb-apps only support DVBAPI v3, so only install the generated DVBAPI v3 files | ||
35 | make -C initial-scan-tables DATADIR=${D}/${datadir} DVBV3DIR=dvb install_v3 | ||
36 | |||
37 | install -d ${D}/${bindir} | ||
38 | install -d ${D}/${docdir}/dvb-apps | ||
39 | install -d ${D}/${docdir}/dvb-apps/szap | ||
40 | chmod a+rx ${D}/${libdir}/*.so* | ||
41 | |||
42 | # Install tests | ||
43 | install -m 0755 ${S}/test/setvoltage ${D}${bindir}/test_setvoltage | ||
44 | install -m 0755 ${S}/test/set22k ${D}${bindir}/test_set22k | ||
45 | install -m 0755 ${S}/test/sendburst ${D}${bindir}/test_sendburst | ||
46 | install -m 0755 ${S}/test/diseqc ${D}${bindir}/test_diseqc | ||
47 | install -m 0755 ${S}/test/test_sections ${D}${bindir}/ | ||
48 | install -m 0755 ${S}/test/test_av_play ${D}${bindir}/ | ||
49 | install -m 0755 ${S}/test/test_stillimage ${D}${bindir}/ | ||
50 | install -m 0755 ${S}/test/test_dvr_play ${D}${bindir}/ | ||
51 | install -m 0755 ${S}/test/test_tt ${D}${bindir}/ | ||
52 | install -m 0755 ${S}/test/test_sec_ne ${D}${bindir}/ | ||
53 | install -m 0755 ${S}/test/test_stc ${D}${bindir}/ | ||
54 | install -m 0755 ${S}/test/test_av ${D}${bindir}/ | ||
55 | install -m 0755 ${S}/test/test_vevent ${D}${bindir}/ | ||
56 | install -m 0755 ${S}/test/test_pes ${D}${bindir}/ | ||
57 | install -m 0755 ${S}/test/test_dvr ${D}${bindir}/ | ||
58 | |||
59 | cp -pPR ${S}/util/szap/channels-conf* ${D}/${docdir}/dvb-apps/szap/ | ||
60 | cp -pPR ${S}/util/szap/README ${D}/${docdir}/dvb-apps/szap/ | ||
61 | } | ||
62 | |||
63 | python populate_packages_prepend () { | ||
64 | dvb_libdir = bb.data.expand('${libdir}', d) | ||
65 | do_split_packages(d, dvb_libdir, '^lib(.*)\.so$', 'lib%s', 'DVB %s package', extra_depends='', allow_links=True) | ||
66 | do_split_packages(d, dvb_libdir, '^lib(.*)\.la$', 'lib%s-dev', 'DVB %s development package', extra_depends='${PN}-dev') | ||
67 | do_split_packages(d, dvb_libdir, '^lib(.*)\.a$', 'lib%s-dev', 'DVB %s development package', extra_depends='${PN}-dev') | ||
68 | do_split_packages(d, dvb_libdir, '^lib(.*)\.so\.*', 'lib%s', 'DVB %s library', extra_depends='', allow_links=True) | ||
69 | } | ||
70 | |||
71 | PACKAGES =+ "dvb-evtest dvb-evtest-dbg \ | ||
72 | dvbapp-tests dvbapp-tests-dbg \ | ||
73 | dvbdate dvbdate-dbg \ | ||
74 | dvbtraffic dvbtraffic-dbg \ | ||
75 | dvbnet dvbnet-dbg \ | ||
76 | dvb-scan dvb-scan-dbg dvb-scan-data \ | ||
77 | dvb-azap dvb-azap-dbg \ | ||
78 | dvb-czap dvb-czap-dbg \ | ||
79 | dvb-szap dvb-szap-dbg \ | ||
80 | dvb-tzap dvb-tzap-dbg \ | ||
81 | dvb-femon dvb-femon-dbg \ | ||
82 | dvb-zap-data" | ||
83 | |||
84 | # Expose the packages from the above spitting | ||
85 | PACKAGES =+ "libdvbapi libdvbcfg libdvben50221 \ | ||
86 | libesg libucsi libdvbsec" | ||
87 | |||
88 | FILES_${PN} = "${bindir} ${datadir}/dvb" | ||
89 | FILES_${PN}-doc = "" | ||
90 | FILES_${PN}-dev = "${includedir}" | ||
91 | |||
92 | FILES_dvb-evtest = "${bindir}/evtest" | ||
93 | FILES_dvb-evtest-dbg = "${bindir}/.debug/evtest" | ||
94 | RCONFLICTS_dvb-evtest = "evtest" | ||
95 | |||
96 | FILES_dvbapp-tests = "${bindir}/*test* " | ||
97 | FILES_dvbapp-tests-dbg = "${bindir}/.debug/*test*" | ||
98 | |||
99 | FILES_dvbdate = "${bindir}/dvbdate" | ||
100 | FILES_dvbdate-dbg = "${bindir}/.debug/dvbdate" | ||
101 | |||
102 | FILES_dvbtraffic = "${bindir}/dvbtraffic" | ||
103 | FILES_dvbtraffic-dbg = "${bindir}/.debug/dvbtraffic" | ||
104 | |||
105 | FILES_dvbnet = "${bindir}/dvbnet" | ||
106 | FILES_dvbnet-dbg = "${bindir}/.debug/dvbnet" | ||
107 | |||
108 | FILES_dvb-scan = "${bindir}/*scan " | ||
109 | FILES_dvb-scan-dbg = "${bindir}/.debug/*scan" | ||
110 | FILES_dvb-scan-data = "${datadir}/dvb" | ||
111 | |||
112 | FILES_dvb-azap = "${bindir}/azap" | ||
113 | FILES_dvb-azap-dbg = "${bindir}/.debug/azap" | ||
114 | |||
115 | FILES_dvb-czap = "${bindir}/czap" | ||
116 | FILES_dvb-czap-dbg = "${bindir}/.debug/czap" | ||
117 | |||
118 | FILES_dvb-szap = "${bindir}/szap" | ||
119 | FILES_dvb-szap-dbg = "${bindir}/.debug/szap" | ||
120 | |||
121 | FILES_dvb-tzap = "${bindir}/tzap" | ||
122 | FILES_dvb-tzap-dbg = "${bindir}/.debug/tzap" | ||
123 | |||
124 | FILES_dvb-femon = "${bindir}/femon" | ||
125 | FILES_dvb-femon-dbg = "${bindir}/.debug/femon" | ||
126 | |||
127 | FILES_dvb-zap-data = "${docdir}/dvb-apps/szap" | ||
128 | |||
129 | RDEPENDS_dvbdate =+ "libdvbapi libucsi" | ||
130 | RDEPENDS_dvbtraffic =+ "libdvbapi" | ||
131 | RDEPENDS_dvb-scan =+ "libdvbapi libdvbcfg libdvbsec" | ||
132 | RDEPENDS_dvb-apps =+ "libdvbapi libdvbcfg libdvbsec libdvben50221 libucsi" | ||
133 | RDEPENDS_dvb-femon =+ "libdvbapi" | ||
134 | RDEPENDS_dvbnet =+ "libdvbapi" | ||
135 | |||
136 | PNBLACKLIST[dvb-apps] ?= "Fails to build with RSS http://errors.yoctoproject.org/Errors/Details/130603/ - the recipe will be removed on 2017-09-01 unless the issue is fixed" | ||
diff --git a/meta-multimedia/recipes-dvb/tvheadend/tvheadend/0001-Fix-checks-for-sse2-mmx.patch b/meta-multimedia/recipes-dvb/tvheadend/tvheadend/0001-Fix-checks-for-sse2-mmx.patch deleted file mode 100644 index 3283a5b6a..000000000 --- a/meta-multimedia/recipes-dvb/tvheadend/tvheadend/0001-Fix-checks-for-sse2-mmx.patch +++ /dev/null | |||
@@ -1,40 +0,0 @@ | |||
1 | From f0dab6d6fe4b0aae4394eee93be86e9747c6ed5c Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Tue, 22 Nov 2016 05:07:38 +0000 | ||
4 | Subject: [PATCH] Fix checks for sse2/mmx | ||
5 | |||
6 | Just checking for cmdline options is not enough | ||
7 | its better to check for builtin defines to be | ||
8 | sure, clang does not error out on sse2 options on | ||
9 | arm e.g. and it ends up doing SSE2 stuff for arm | ||
10 | which is not desired | ||
11 | |||
12 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
13 | --- | ||
14 | configure | 10 ++++++++-- | ||
15 | 1 file changed, 8 insertions(+), 2 deletions(-) | ||
16 | |||
17 | diff --git a/configure b/configure | ||
18 | index 47d2cf2..4be000c 100755 | ||
19 | --- a/configure | ||
20 | +++ b/configure | ||
21 | @@ -118,8 +118,14 @@ fi | ||
22 | # Valiate compiler | ||
23 | check_cc || die 'No C compiler found' | ||
24 | check_cc_header execinfo | ||
25 | -check_cc_option mmx | ||
26 | -check_cc_option sse2 | ||
27 | +check_cc_snippet mmx '#ifndef __MMX__ | ||
28 | +error "MMX not supported" | ||
29 | +#endif | ||
30 | +' | ||
31 | +check_cc_snippet sse2 '#ifndef __SSE2__ | ||
32 | +error "SSE2 not supported" | ||
33 | +#endif | ||
34 | +' | ||
35 | |||
36 | if check_cc ' | ||
37 | #if !defined(__clang__) | ||
38 | -- | ||
39 | 1.9.1 | ||
40 | |||
diff --git a/meta-multimedia/recipes-dvb/tvheadend/tvheadend/0001-Makefile-Ignore-warning-about-wrong-includes.patch b/meta-multimedia/recipes-dvb/tvheadend/tvheadend/0001-Makefile-Ignore-warning-about-wrong-includes.patch deleted file mode 100644 index 248a5e6a8..000000000 --- a/meta-multimedia/recipes-dvb/tvheadend/tvheadend/0001-Makefile-Ignore-warning-about-wrong-includes.patch +++ /dev/null | |||
@@ -1,31 +0,0 @@ | |||
1 | From 7d672305c7ad2f716dfe1c487b525a1a92954d4a Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Tue, 22 Nov 2016 06:22:36 +0000 | ||
4 | Subject: [PATCH] Makefile: Ignore warning about wrong includes | ||
5 | |||
6 | It happens on musl especially | ||
7 | usr/include/sys/poll.h:1:2: error: redirecting incorrect #include <sys/poll.h> to <poll.h> [-Werror,-W#warnings] | ||
8 | | #warning redirecting incorrect #include <sys/poll.h> to <poll.h> | ||
9 | | ^ | ||
10 | | In file included from src/avahi.c:48: | ||
11 | |||
12 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
13 | --- | ||
14 | Makefile | 1 + | ||
15 | 1 file changed, 1 insertion(+) | ||
16 | |||
17 | diff --git a/Makefile b/Makefile | ||
18 | index f41ef1a..cc7b249 100644 | ||
19 | --- a/Makefile | ||
20 | +++ b/Makefile | ||
21 | @@ -54,6 +54,7 @@ CFLAGS += -Wno-microsoft -Qunused-arguments -Wno-unused-function | ||
22 | CFLAGS += -Wno-unused-value -Wno-tautological-constant-out-of-range-compare | ||
23 | CFLAGS += -Wno-parentheses-equality -Wno-incompatible-pointer-types | ||
24 | CFLAGS += -Wno-error=varargs | ||
25 | +CFLAGS += -Wno-error=\#warnings | ||
26 | endif | ||
27 | |||
28 | ifeq ($(CONFIG_LIBFFMPEG_STATIC),yes) | ||
29 | -- | ||
30 | 1.8.3.1 | ||
31 | |||
diff --git a/meta-multimedia/recipes-dvb/tvheadend/tvheadend/0001-disable-varargs-warning-on-clang.patch b/meta-multimedia/recipes-dvb/tvheadend/tvheadend/0001-disable-varargs-warning-on-clang.patch deleted file mode 100644 index a4c4c4d0f..000000000 --- a/meta-multimedia/recipes-dvb/tvheadend/tvheadend/0001-disable-varargs-warning-on-clang.patch +++ /dev/null | |||
@@ -1,32 +0,0 @@ | |||
1 | From 906d95695af95970bf551ea55b6c3e70332c6b97 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Tue, 22 Nov 2016 05:22:32 +0000 | ||
4 | Subject: [PATCH] disable varargs warning on clang | ||
5 | |||
6 | The issue is that 'len' is an unsigned char and we violate the promotion rules | ||
7 | for passing the value to va_start. | ||
8 | |||
9 | passing an object that undergoes defau | ||
10 | lt argument promotion to 'va_start' has undefined behavior [-Wvarargs] | ||
11 | | va_start(ap, len); | ||
12 | |||
13 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
14 | --- | ||
15 | Makefile | 1 + | ||
16 | 1 file changed, 1 insertion(+) | ||
17 | |||
18 | diff --git a/Makefile b/Makefile | ||
19 | index 8c5e380..f41ef1a 100644 | ||
20 | --- a/Makefile | ||
21 | +++ b/Makefile | ||
22 | @@ -53,6 +53,7 @@ ifeq ($(COMPILER), clang) | ||
23 | CFLAGS += -Wno-microsoft -Qunused-arguments -Wno-unused-function | ||
24 | CFLAGS += -Wno-unused-value -Wno-tautological-constant-out-of-range-compare | ||
25 | CFLAGS += -Wno-parentheses-equality -Wno-incompatible-pointer-types | ||
26 | +CFLAGS += -Wno-error=varargs | ||
27 | endif | ||
28 | |||
29 | ifeq ($(CONFIG_LIBFFMPEG_STATIC),yes) | ||
30 | -- | ||
31 | 1.9.1 | ||
32 | |||
diff --git a/meta-multimedia/recipes-dvb/tvheadend/tvheadend/0001-dvr-Use-labs-instead-of-abs.patch b/meta-multimedia/recipes-dvb/tvheadend/tvheadend/0001-dvr-Use-labs-instead-of-abs.patch deleted file mode 100644 index ea34cdb62..000000000 --- a/meta-multimedia/recipes-dvb/tvheadend/tvheadend/0001-dvr-Use-labs-instead-of-abs.patch +++ /dev/null | |||
@@ -1,37 +0,0 @@ | |||
1 | From a715671eadcbf989fdaf05f62e71b93ac1749615 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Tue, 22 Nov 2016 06:08:31 +0000 | ||
4 | Subject: [PATCH] dvr: Use labs() instead of abs() | ||
5 | |||
6 | Makes clang happy | ||
7 | |||
8 | dvr/dvr_db.c:853:10: error: absolute value function | ||
9 | 'abs' given an argument of type 'long' but has parameter of type 'int' which may cause truncation of value [-Werror,-Wabsolute-value] | ||
10 | if ((abs(de->de_start - e->start) < 600) && (abs(de->de_stop - e->stop) < 600)) { | ||
11 | |||
12 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
13 | --- | ||
14 | src/dvr/dvr_db.c | 4 ++-- | ||
15 | 1 file changed, 2 insertions(+), 2 deletions(-) | ||
16 | |||
17 | diff --git a/src/dvr/dvr_db.c b/src/dvr/dvr_db.c | ||
18 | index 165caa6..5656569 100644 | ||
19 | --- a/src/dvr/dvr_db.c | ||
20 | +++ b/src/dvr/dvr_db.c | ||
21 | @@ -414,11 +414,11 @@ dvr_entry_fuzzy_match(dvr_entry_t *de, epg_broadcast_t *e) | ||
22 | /* Wrong length (+/-20%) */ | ||
23 | t1 = de->de_stop - de->de_start; | ||
24 | t2 = e->stop - e->start; | ||
25 | - if ( abs(t2 - t1) > (t1 / 5) ) | ||
26 | + if ( labs(t2 - t1) > (t1 / 5) ) | ||
27 | return 0; | ||
28 | |||
29 | /* Outside of window */ | ||
30 | - if (abs(e->start - de->de_start) > de->de_config->dvr_update_window) | ||
31 | + if (labs(e->start - de->de_start) > de->de_config->dvr_update_window) | ||
32 | return 0; | ||
33 | |||
34 | /* Title match (or contains?) */ | ||
35 | -- | ||
36 | 1.9.1 | ||
37 | |||
diff --git a/meta-multimedia/recipes-dvb/tvheadend/tvheadend/0001-hdhomerun-Override-forced-overrdiing-og-CC-STRIP-and.patch b/meta-multimedia/recipes-dvb/tvheadend/tvheadend/0001-hdhomerun-Override-forced-overrdiing-og-CC-STRIP-and.patch deleted file mode 100644 index 484e723d9..000000000 --- a/meta-multimedia/recipes-dvb/tvheadend/tvheadend/0001-hdhomerun-Override-forced-overrdiing-og-CC-STRIP-and.patch +++ /dev/null | |||
@@ -1,40 +0,0 @@ | |||
1 | From c3767e189e90965407937b6178adbbd8cdafe31d Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Tue, 22 Nov 2016 05:59:10 +0000 | ||
4 | Subject: [PATCH] hdhomerun: Override forced overrdiing og CC/STRIP and CFLAGS | ||
5 | |||
6 | This is required for cross compiling otherwise it ends up | ||
7 | using build host gcc | ||
8 | |||
9 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
10 | --- | ||
11 | Makefile.hdhomerun | 6 ++++-- | ||
12 | 1 file changed, 4 insertions(+), 2 deletions(-) | ||
13 | |||
14 | diff --git a/Makefile.hdhomerun b/Makefile.hdhomerun | ||
15 | index 943ffec..8bd14ff 100644 | ||
16 | --- a/Makefile.hdhomerun | ||
17 | +++ b/Makefile.hdhomerun | ||
18 | @@ -18,8 +18,8 @@ | ||
19 | |||
20 | include $(dir $(lastword $(MAKEFILE_LIST))).config.mk | ||
21 | |||
22 | -unexport CFLAGS | ||
23 | -unexport LDFLAGS | ||
24 | +#unexport CFLAGS | ||
25 | +#unexport LDFLAGS | ||
26 | |||
27 | define DOWNLOAD | ||
28 | @mkdir -p $(LIBHDHRDIR)/build | ||
29 | @@ -75,6 +75,8 @@ $(LIBHDHRDIR)/$(LIBHDHR)/.tvh_download: | ||
30 | $(call DOWNLOAD,$(LIBHDHR_URL),$(LIBHDHRDIR)/$(LIBHDHR_TB),$(LIBHDHR_SHA1)) | ||
31 | $(call UNTAR,$(LIBHDHR_TB),z) | ||
32 | ln -sf libhdhomerun $(LIBHDHRDIR)/$(LIBHDHR) | ||
33 | + @sed -i -e "s/CC.*:=/CC ?=/" $(LIBHDHRDIR)/$(LIBHDHR)/Makefile | ||
34 | + @sed -i -e "s/STRIP.*:=/STRIP ?=/" $(LIBHDHRDIR)/$(LIBHDHR)/Makefile | ||
35 | @touch $@ | ||
36 | |||
37 | $(LIBHDHRDIR)/$(LIBHDHR)/.tvh_build: \ | ||
38 | -- | ||
39 | 1.9.1 | ||
40 | |||
diff --git a/meta-multimedia/recipes-dvb/tvheadend/tvheadend_git.bb b/meta-multimedia/recipes-dvb/tvheadend/tvheadend_git.bb deleted file mode 100644 index 3b73549d2..000000000 --- a/meta-multimedia/recipes-dvb/tvheadend/tvheadend_git.bb +++ /dev/null | |||
@@ -1,43 +0,0 @@ | |||
1 | SUMMARY = "Tvheadend TV streaming server" | ||
2 | HOMEPAGE = "https://www.lonelycoder.com/redmine/projects/tvheadend" | ||
3 | |||
4 | DEPENDS = "avahi zlib openssl python-native dvb-apps" | ||
5 | |||
6 | LICENSE = "GPLv3+" | ||
7 | LIC_FILES_CHKSUM = "file://LICENSE.md;md5=9cae5acac2e9ee2fc3aec01ac88ce5db" | ||
8 | |||
9 | SRC_URI = "git://github.com/tvheadend/tvheadend.git;branch=release/4.0 \ | ||
10 | file://0001-Fix-checks-for-sse2-mmx.patch \ | ||
11 | file://0001-disable-varargs-warning-on-clang.patch \ | ||
12 | file://0001-hdhomerun-Override-forced-overrdiing-og-CC-STRIP-and.patch \ | ||
13 | file://0001-dvr-Use-labs-instead-of-abs.patch \ | ||
14 | file://0001-Makefile-Ignore-warning-about-wrong-includes.patch \ | ||
15 | " | ||
16 | SRCREV = "64fec8120158de585e18be705055259484518d94" | ||
17 | PV = "4.0.9+git${SRCREV}" | ||
18 | |||
19 | S = "${WORKDIR}/git" | ||
20 | |||
21 | PACKAGECONFIG ?= "" | ||
22 | PACKAGECONFIG[uriparser] = "--enable-uriparser,--disable-uriparser,uriparser" | ||
23 | |||
24 | do_configure() { | ||
25 | ./configure ${PACKAGECONFIG_CONFARGS} \ | ||
26 | --prefix=${prefix} \ | ||
27 | --libdir=${libdir} \ | ||
28 | --bindir=${bindir} \ | ||
29 | --datadir=${datadir} \ | ||
30 | --arch=${TARGET_ARCH} \ | ||
31 | --disable-dvbscan \ | ||
32 | --disable-bundle | ||
33 | } | ||
34 | |||
35 | do_install() { | ||
36 | oe_runmake install DESTDIR=${D} | ||
37 | } | ||
38 | |||
39 | FILES_${PN} += "${datadir}/${BPN}" | ||
40 | |||
41 | RDEPENDS_${PN} += "libdvben50221 libucsi libdvbapi" | ||
42 | |||
43 | PNBLACKLIST[tvheadend] ?= "Depends on blacklisted dvb-apps - the recipe will be removed on 2017-09-01 unless the issue is fixed" | ||