summaryrefslogtreecommitdiffstats
path: root/meta-multimedia/recipes-connectivity
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2023-06-30 03:29:59 -0700
committerKhem Raj <raj.khem@gmail.com>2023-06-30 03:37:10 -0700
commitbb4461e6ae469e33d4cda875dc35185f025291ef (patch)
tree6c77d99770b8edea1753bd2c07527c753811c77e /meta-multimedia/recipes-connectivity
parentcb3864b3803470cf649fd90b945df1ba7395f7b1 (diff)
downloadmeta-openembedded-bb4461e6ae469e33d4cda875dc35185f025291ef.tar.gz
gupnp-av: Fix build with libxml2-2.11 and newer
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-multimedia/recipes-connectivity')
-rw-r--r--meta-multimedia/recipes-connectivity/gupnp/gupnp-av/0001-all-Drop-xmlRecoverMemory.patch44
-rw-r--r--meta-multimedia/recipes-connectivity/gupnp/gupnp-av_0.14.0.bb4
2 files changed, 47 insertions, 1 deletions
diff --git a/meta-multimedia/recipes-connectivity/gupnp/gupnp-av/0001-all-Drop-xmlRecoverMemory.patch b/meta-multimedia/recipes-connectivity/gupnp/gupnp-av/0001-all-Drop-xmlRecoverMemory.patch
new file mode 100644
index 000000000..92b52ad98
--- /dev/null
+++ b/meta-multimedia/recipes-connectivity/gupnp/gupnp-av/0001-all-Drop-xmlRecoverMemory.patch
@@ -0,0 +1,44 @@
1From d99f71a4a52da7582d5e26992a1ab303b280d28a Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Fri, 30 Jun 2023 03:23:12 -0700
4Subject: [PATCH] Drop xmlRecoverMemory
5
6newer libxml has deprecated xmlRecoverMemory therefore replace it with xmlReadMemory
7
8Upstream-Status: Backport [https://gitlab.gnome.org/GNOME/gupnp/-/commit/80e68995b745a5900eaaa1d0c424d3a9d354e42d]
9
10Signed-off-by: Khem Raj <raj.khem@gmail.com>
11---
12 gupnp-didl-lite-parser.c | 2 +-
13 gupnp-feature-list-parser.c | 2 +-
14 2 files changed, 2 insertions(+), 2 deletions(-)
15
16diff --git a/gupnp-didl-lite-parser.c b/gupnp-didl-lite-parser.c
17index 3a5727f..840d718 100644
18--- a/libgupnp-av/gupnp-didl-lite-parser.c
19+++ b/libgupnp-av/gupnp-didl-lite-parser.c
20@@ -230,7 +230,7 @@ gupnp_didl_lite_parser_parse_didl_recursive (GUPnPDIDLLiteParser *parser,
21 GUPnPAVXMLDoc *xml_doc = NULL;
22 gboolean result;
23
24- doc = xmlRecoverMemory (didl, strlen (didl));
25+ doc = xmlReadMemory (didl, strlen (didl), NULL, NULL, XML_PARSE_NONET | XML_PARSE_RECOVER);
26 if (doc == NULL) {
27 g_set_error (error,
28 G_MARKUP_ERROR,
29diff --git a/gupnp-feature-list-parser.c b/gupnp-feature-list-parser.c
30index 16208b5..f804fe7 100644
31--- a/libgupnp-av/gupnp-feature-list-parser.c
32+++ b/libgupnp-av/gupnp-feature-list-parser.c
33@@ -114,7 +114,7 @@ gupnp_feature_list_parser_parse_text
34 xmlNode *element;
35 GList *feature_list = NULL;
36
37- doc = xmlRecoverMemory (text, strlen (text));
38+ doc = xmlReadMemory (text, strlen (text), NULL, NULL, XML_PARSE_NONET | XML_PARSE_RECOVER);
39 if (doc == NULL) {
40 g_set_error (error,
41 G_MARKUP_ERROR,
42--
432.41.0
44
diff --git a/meta-multimedia/recipes-connectivity/gupnp/gupnp-av_0.14.0.bb b/meta-multimedia/recipes-connectivity/gupnp/gupnp-av_0.14.0.bb
index b253c54d9..48de5868d 100644
--- a/meta-multimedia/recipes-connectivity/gupnp/gupnp-av_0.14.0.bb
+++ b/meta-multimedia/recipes-connectivity/gupnp/gupnp-av_0.14.0.bb
@@ -8,5 +8,7 @@ DEPENDS = "gupnp"
8 8
9inherit meson pkgconfig gobject-introspection vala 9inherit meson pkgconfig gobject-introspection vala
10 10
11SRC_URI = "${GNOME_MIRROR}/${BPN}/0.14/${BPN}-${PV}.tar.xz" 11SRC_URI = "${GNOME_MIRROR}/${BPN}/0.14/${BPN}-${PV}.tar.xz \
12 file://0001-all-Drop-xmlRecoverMemory.patch \
13 "
12SRC_URI[sha256sum] = "20aed546fc882e78a3f186a0c8bce5c841cc3a44b7ea528298fbdc82596fb156" 14SRC_URI[sha256sum] = "20aed546fc882e78a3f186a0c8bce5c841cc3a44b7ea528298fbdc82596fb156"