diff options
author | Martin Jansa <martin.jansa@gmail.com> | 2022-02-20 09:48:12 +0100 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2022-02-21 18:12:04 -0800 |
commit | 856902b8c0014fdbfd70b4c63cb353929dacbbf0 (patch) | |
tree | 78ff3c35f5d7c2891b56b5d0082866fe6fc12640 /meta-multimedia/recipes-connectivity | |
parent | bfd22261ef554575dee9a857e518b7b6c603af2a (diff) | |
download | meta-openembedded-856902b8c0014fdbfd70b4c63cb353929dacbbf0.tar.gz |
Fix DeprecationWarning about regexps
* fixes:
meta-oe/meta-networking/recipes-support/strongswan/strongswan_5.9.4.bb:125: DeprecationWarning: invalid escape sequence \.
meta-oe/meta-networking/recipes-support/strongswan/strongswan_5.9.4.bb:126: DeprecationWarning: invalid escape sequence \.
meta-oe/meta-networking/recipes-support/strongswan/strongswan_5.9.4.bb:128: DeprecationWarning: invalid escape sequence \.
meta-oe/meta-networking/recipes-support/strongswan/strongswan_5.9.4.bb:129: DeprecationWarning: invalid escape sequence \.
meta-oe/meta-networking/recipes-support/strongswan/strongswan_5.9.4.bb:130: DeprecationWarning: invalid escape sequence \.
meta-oe/meta-oe/recipes-graphics/ttf-fonts/ttf-mplus_027.bb:18: DeprecationWarning: invalid escape sequence \.
meta-oe/meta-oe/recipes-multimedia/libcdio/libcdio-paranoia_10.2+2.0.1.bb:21: DeprecationWarning: invalid escape sequence \.
meta-oe/meta-oe/recipes-multimedia/libcdio/libcdio_2.1.0.bb:28: DeprecationWarning: invalid escape sequence \.
oe-core/meta/classes/package.bbclass:1342: DeprecationWarning: invalid escape sequence \.
oe-core/meta/classes/package.bbclass:1343: DeprecationWarning: invalid escape sequence \-
oe-core/meta/classes/package.bbclass:1343: DeprecationWarning: invalid escape sequence \.
oe-core/meta/classes/package.bbclass:1344: DeprecationWarning: invalid escape sequence \.
oe-core/meta/classes/package.bbclass:1345: DeprecationWarning: invalid escape sequence \.
oe-core/meta/classes/package.bbclass:1348: DeprecationWarning: invalid escape sequence \.
oe-core/meta/classes/package.bbclass:1350: DeprecationWarning: invalid escape sequence \.
oe-core/meta/classes/package.bbclass:1353: DeprecationWarning: invalid escape sequence \.
oe-core/meta/classes/package.bbclass:1355: DeprecationWarning: invalid escape sequence \.
oe-core/meta/classes/package.bbclass:1358: DeprecationWarning: invalid escape sequence \.
oe-core/meta/classes/package.bbclass:1360: DeprecationWarning: invalid escape sequence \.
oe-core/meta/classes/package.bbclass:1365: DeprecationWarning: invalid escape sequence \.
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-multimedia/recipes-connectivity')
-rw-r--r-- | meta-multimedia/recipes-connectivity/rygel/rygel_0.38.3.bb | 4 |
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-multimedia/recipes-connectivity/rygel/rygel_0.38.3.bb b/meta-multimedia/recipes-connectivity/rygel/rygel_0.38.3.bb index c08ab11b2..9633cab53 100644 --- a/meta-multimedia/recipes-connectivity/rygel/rygel_0.38.3.bb +++ b/meta-multimedia/recipes-connectivity/rygel/rygel_0.38.3.bb | |||
@@ -64,8 +64,8 @@ python populate_packages:prepend () { | |||
64 | postinst = d.getVar('plugin_postinst') | 64 | postinst = d.getVar('plugin_postinst') |
65 | pkgs = [] | 65 | pkgs = [] |
66 | 66 | ||
67 | pkgs += do_split_packages(d, oe.path.join(rygel_libdir, "plugins"), 'librygel-(.*)\.so$', d.expand('${PN}-plugin-%s'), 'Rygel plugin for %s', postinst=postinst, extra_depends=d.expand('${PN}')) | 67 | pkgs += do_split_packages(d, oe.path.join(rygel_libdir, "plugins"), r'librygel-(.*)\.so$', d.expand('${PN}-plugin-%s'), 'Rygel plugin for %s', postinst=postinst, extra_depends=d.expand('${PN}')) |
68 | pkgs += do_split_packages(d, oe.path.join(rygel_libdir, "plugins"), '(.*)\.plugin$', d.expand('${PN}-plugin-%s'), 'Rygel plugin for %s', postinst=postinst, extra_depends=d.expand('${PN}')) | 68 | pkgs += do_split_packages(d, oe.path.join(rygel_libdir, "plugins"), r'(.*)\.plugin$', d.expand('${PN}-plugin-%s'), 'Rygel plugin for %s', postinst=postinst, extra_depends=d.expand('${PN}')) |
69 | 69 | ||
70 | metapkg = d.getVar('PN') + '-meta' | 70 | metapkg = d.getVar('PN') + '-meta' |
71 | d.setVar('RDEPENDS:' + metapkg, ' '.join(pkgs)) | 71 | d.setVar('RDEPENDS:' + metapkg, ' '.join(pkgs)) |